Helios 16 PH16-71 Predator sense dosent work as it should.

wildwolf15
wildwolf15 Member Posts: 9

Tinkerer

edited December 2023 in Predator Laptops

when I first start my Helios 16 PH16-71 occasionally PredatorSense will boot correctly and I can control both lighting and fan speed, however other times it will only display the default lighting on start. when I launch the app on a bad boot it won't allow me to change the fan speed and pushing fn+F11 or F12 will generally stop the RGB. I've noticed if the RGB lighting is good the fan controller is good as well. I just want to know how to fix it so I don't have to restart my computer 5 times for it to work properly.

[Edited the thread to add model name to the title]

Answers

  • Forest_tm23
    Forest_tm23 Member Posts: 8

    Tinkerer

    Have same laptop but didnt really had this issue. Try updating drivers on Acer drivers page. Also try goind to cmd with admin privilege and type sfc /scannow . The only option imo

  • wildwolf15
    wildwolf15 Member Posts: 9

    Tinkerer

    It also doesn't work after a good boot and then I put it to sleep, the second I bring it back it crashes (ie not responding to the PS software) …and it's just out of the box. Had this problem on day 1 when I first started the laptop…It came out of the box broken.

  • btobachh
    btobachh Member Posts: 14

    Tinkerer

    Same issue here, sometimes predator sense unhooks from the system and wont even control mode, fan speed or lighting. I've found that lighting control can be temporarily restored by restarting the Acerlighting… service. But it stops by itself seconds after you make some changes, I even tried to set the service to restart automatically when it's stopped, but it's not enough. Really I never had this issue with my Nitro 5 and Nitro sense… It's a new computer, this shouldn't be happening.

  • Horse
    Horse Member Posts: 5

    Tinkerer

    same problem here, i cant control properly the keyboard lights

  • StevenGen
    StevenGen ACE Posts: 9,916 Trailblazer

    The Predator Helios 16 PH16-71 is a new model gaming laptop and the PS is also new and specifically programed to your laptop, wait until Acer updates the PS for this model as there are no fixes for this problem. I’ve also had problems with my NitroSense not installing on a clean install but the NS has some fixes and work around installation procedures which installs NS on my laptop, which does not work with the PS. Good luck.

    If this answers your question and solved your query please "Click on Yes" or "Click on Like" if you find my answer useful👍

  • DSpartan
    DSpartan Member Posts: 5

    Tinkerer

    Hope this can help someone as this was driving me crazy, I have a Predator Helios PH16-71 (just bought it) and was making a fresh install of Windows 11 as I hate the way PC comes out of the Manufacturers. Predator sense was completely dead and I tried a ton of things to make it work even though I was downloading the latest app from the official Acer site which drove me almost insane. I found solace and help on a Reddit post "Predator Sense download issues for Predator Helios Neo 16".

    Long story short, ignore the Predator Sense App from the official Acer site for "Predator Helios PH16-71" and download the latest "Predator Sense" app installing the one for "PH16-72" instead.

    This has fixed my issue of the app not working altogether. The keyboard lightning was a little glitchy in the beginning but after restarting the computer all seems fine now.

    Hope this can help you !!!!


  • DSpartan
    DSpartan Member Posts: 5

    Tinkerer

    Step by Step

    Oh yeah, just to provide a little update step by step of what I did in terms of installation.

    • Downloaded official Win11 and done a complete clean install on the computer
    • Windows Update to install all driver for the computer (don't forget to tick → Windows Update » Advanced Options » Receive Updates for other Microsoft Products) → This seems sufficient for most of the drivers that you can find on the Predator Helios PH16-71 page
    • After Windows Update was done I've downloaded Intel Driver Support Assistant and Geforce Experience
    • At this point I've realised that Windows update downloaded Geforce Experience and Drivers previously but I've opted to completely uninstall Geforce from the computer and reinstall using Geforce Experience that I downloaded (to avoid any potential issues)
    • Intel Driver Support Assistant was used to install some additional Intel drivers but I didn't install this one below as there was a message of potential errors so I've opted to "hide it"
    • Following that, I installed "Acer Care Center" and "Predator Sense" (the one from the official Acer site for PH16-71 which didn't work).
    • At this point, I tried different solutions but the one I recommend is (as someone described) go on Windows Update and download any pending "optional features" (Windows Update » Advanced Options » Optional Features)
    • This is where the miracle happened… I found the link I've described previously with the fix and decided to completely uninstall the Predator Sense app (for PH16-71), restart the computer and install the one for the PH16-72
    • After some rebooting and CCleaner for the registry, all seems working now !!!!