Nitro 5 AN515 -58: Internal HDD inaccessible after resuming from sleep mode

pvfreitas Member Posts: 4 New User
edited December 2023 in Nitro Gaming

I bought a Nitro 5 AN515-58 a few days ago. It came with Linux but I installed Windows 11 using a license I already had. Afterwards, I installed a 1 TB HDD that I already used in another computer, using the SATA cable provided within the package. In general, it works normally, however, almost every time the notebook returns from sleep mode, the following happens:

  1. when trying to access this HD or any of its files, Windows shows the message "Drive D: is not accessible", even though the disk is listed in "My Computer" and in disk management;
  2. In task manager, the System process uses almost 100% of the CPU and uses 100% of disk D for some time. Then usage drops, but the disk remains inaccessible;
  3. The only thing that, until then, makes access come back is restarting the computer.

Solutions I've already tried:

  1. I updated the BIOS to the latest version;
  2. I checked the settings in BIOS;
  3. I tried to install Intel RST, either by downloading it from the Intel website or using the drivers present in the WINDRIVER folder, but the installation failed saying the device is not compatible;
  4. in the power settings I set the hard drives shutdown time to NEVER;
  5. I installed the Intel utility to search and update drivers, and they are all up to date;
  6. I checked the S.M.A.R.T. from the disk and it is ok;
  7. I checked on Windows Update that everything is up to date;
  8. I checked the device manager for items without drivers installed;
  9. I checked the installation of the SATA cable, ensuring that it is properly seated.

I can't think of more possible solutions. Does anyone else go (or have gone) through this?

[Edited the thread to add model name to the title]