Acer 5742 the motherboard is setting something to mono audio to stereo

BrunoLoebens
BrunoLoebens Member Posts: 20 Networker
edited December 2023 in Aspire Laptops

Hey guys.

I have here the motherboard of an Acer 5742. It has two L and R speaker connectors.

However, only the L side is working. Apparently the motherboard is setting something to Mono even when the audio should be Stereo.

The upper part of the notebook I have has the two speakers because it was the Acer 5733 model.

Both models use the same motherboard (PEW71-La6582p), except that the 5742's audio is mono and has HDMI. Is there anything that can be done, since the motherboard has two speakers?

This problem has been documented here on the forum and on other sites for some time.

In this case, his motherboard didn't even have the connector for the R speaker but he says he managed to make it work.

[Edited the thread to add issue detail]

Answers

  • This is the only specs and diagram of the Aspire 5742 audio and speaker installation and removal from its SG

    This is the only specs and diagram of the Aspire 5733 audio and speaker installation and removal from its SG

    If this answers your question and solved your query please "Click on Yes" or "Click on Like" if you find my answer useful👍

  • BrunoLoebens
    BrunoLoebens Member Posts: 20 Networker

    Yes friend, I already did that. Unfortunately the audio is mono. It has already been replaced.

    Only the left side works. This has already been reported in the post above. The user didn't even have JSPK2.