Acer Predator P03-630 Unable to reinstall predator sense or control fans

Bill82 Member Posts: 1 New User
edited September 20 in Predator Desktops

Hi, really hope someone can help us with this!!.. my son has an Acer Predator P03-630 Intel i7, rtx37. He updated the os to windows 11.

Recently we did a few upgrades, adding 32gb of ram which went ok. But then we upgraded the cpu fan to a Noctua NHU-9S. Which we found instructions for on here.

After the fan upgrade, predator sense wouldn't allow control of the cpu fan so my son uninstalled ps thinking that by reinstalling it, it might work. Unfortunately now when we try and reinstall Predator sense, it won't install. It looks like it 'tries' to install, but the installation progress bar gets about a third of the way and then just stops.. we've tried a lot of times with the same result.

We've also tried installing a few third party fan control software, but none of those are allowing any control of the cpu fan...

We've tried accessing fan control through 'bios' on startup but they don't appear to allow manual control of the fans..

Can anyone please offer any advice on where we're going wrong?, or if there is any third party fan control software that might work?

Any help would be greatly appreciated! Thanks

[Edited the thread to add model name to the title]


  • chugzilla
    chugzilla Member Posts: 577 Seasoned Specialist

    most likely it's from upgrading to windows 11 try the version of PS for the po3-640 and see if that helps any and the Noctua fan has to be plugged into where the stock fan was for it to work and show in PS.