predator X28 monitor losing signal for 1-2 seconds while in game

RyzerT
RyzerT Member Posts: 13

Tinkerer

edited July 13 in Predator Monitors

Recently purchased a predator x28 monitor. I'm having an issue where the monitor goes black for 1-2 seconds only while gaming and only while gsync is on. I've done a lot of troubleshooting myself to narrow down the issue, tried multiple high quality vesa certified cables, various power sources, only using 1 monitor and then tried 2 monitors. If gsync is off the issue never occurs, if it's on it occurs in all scenarios. I've seen a couple of other posts from users experiencing the same issue. anyone got any advice on how to resolve this? I've called acer to open a case and they're going to call me back after more investigation their side, but just thought I'd post here for help from users that may have some answers or suggestions

[Edited the thread to add model name to the title]

Best Answer

  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    Answer ✓

    Found a solution, quite odd and I won't pretend to even have any idea on the technicals of why this was the fix, but basically turning on nvidia low latency + boost on the particular game I was having issues with (valorant) resolved this completely. Could be something to do with my high end hardware (both pc + monitor) running on such a graphically non intensive game, just a guess

Answers

  • GAMING6698
    GAMING6698 ACE Posts: 5,726 Pathfinder

    Install monitor driver and frimware is available.

    And try to lower refresh rate a bit

    windows 10/11 optimization guide for gaming 
    Windows 10/11 optimization guide for gaming — Acer Community

    My AN515-43 laptop UserBenchmark-
    https://www.userbenchmark.com/UserRun/51514566
  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    I have tried lowering refresh rate to 120Hz still got the same problem, will lower it to 75 or something like that and see what happens. Thanks for that optimization guide, will have a run through that. In terms of drivers and firmware. I have tried downloading and installing the driver from the acer website for the x28 monitor, however when i go to device manager and select the folder to install from i get a message telling me windows determined I'm already on the best driver

  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    Ok i've now managed to successfully install the driver will see how i get on

  • GAMING6698
    GAMING6698 ACE Posts: 5,726 Pathfinder
    edited July 12

    what about frimware? Is it available on website?.

    Check if your issue solve after installing driver. Monitor name should be under monitor tab in device manager if you installed driver successfully.

    windows 10/11 optimization guide for gaming 
    Windows 10/11 optimization guide for gaming — Acer Community

    My AN515-43 laptop UserBenchmark-
    https://www.userbenchmark.com/UserRun/51514566
  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    I don't see any firmware available on the website. So the now driver installed fine, this is how the device looks in device manager:

    unfortunately issue still occurs, it occurs at 144Hz, 120Hz and 96Hz but so far on 72Hz I've not seen the issue. Bit strange

  • GAMING6698
    GAMING6698 ACE Posts: 5,726 Pathfinder
    edited July 12

    • Try a different DP cable
    • Have the monitor be the only one connected
    • Go to control panel, power saving, change plan, set never turn off the monitor/

    windows 10/11 optimization guide for gaming 
    Windows 10/11 optimization guide for gaming — Acer Community

    My AN515-43 laptop UserBenchmark-
    https://www.userbenchmark.com/UserRun/51514566
  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    ok so interesting update, I've booted up the PC with only 1 monitor connected, rather than the usual 2 and it seems to get rid of the problem. Still seems odd and doesn't really resolve things as I run two monitors. My second monitor is via hdmi connection also via the gpu, will have to play around but there must be a way i can get two monitors running and not have this problem

  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    if anyone has any ideas why this happens please let me know

  • GAMING6698
    GAMING6698 ACE Posts: 5,726 Pathfinder
    edited July 13

    As I know you should connect both monitor vie Display Port when gsync enabled And it's rare when multi monitors with VRR run fine.

    windows 10/11 optimization guide for gaming 
    Windows 10/11 optimization guide for gaming — Acer Community

    My AN515-43 laptop UserBenchmark-
    https://www.userbenchmark.com/UserRun/51514566
  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    Answer ✓

    Found a solution, quite odd and I won't pretend to even have any idea on the technicals of why this was the fix, but basically turning on nvidia low latency + boost on the particular game I was having issues with (valorant) resolved this completely. Could be something to do with my high end hardware (both pc + monitor) running on such a graphically non intensive game, just a guess

  • firebolt059
    firebolt059 Member Posts: 13

    Tinkerer

    edited August 2

    I also have this issue, 2 monitors connected via display port into my gpu (4090). Updated monitor driver just like above and tried at various 144/120/72hz, etc still happens.

    I'll look into the low latency settings. I've had the issue while sitting at the desktop as well and not every game supports nvidia low latency + boost.

  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    I have the same gpu and same setup in terms of 2 monitors both DP into the 4090. Have now done quite an extensive amount of testing, do not have a complete fix yet. What I do know is with gsync off I experience no issues no matter what settings I have. As soon as gsync is on the issue can occur. It only occurs in games where the fps is constantly matching the refresh rate and with nvidia reflex set to on or off. For example with valorant it will sit at 142fps constantly (slightly below 144 which is recommended for best gsync results however I've tried it as 144fps as well and same results) and I will see the black screen occasionally for 1-2 seconds. If I set nvidia reflex on + boost it resolves this entirely. For more proof, I loaded up cyberpunk with max settings, in game frames will be anywhere from 60-90 frames (with path tracing on), as soon as I go into the settings menu where frames will sit at a constant 144fps I'll encounter the issue while in the menu almost instantly. Once out of the menu and in game and frames are back to 60-90 I never see the problem. This is an example where there is no workaround as you cannot turn on reflex on + boost as frame generation enabled will lock reflex to "ON" only. Fortunately i'll only have this problem in the menu which I can cope with although not ideal. Interestingly one game I've not seen the problem is battlefield 2042. Can't work out for the life of my what's different about that game but I can seem to have 142fps constantly and reflex at any setting and I've not seen the issue yet. Basically where I'm at now, for first person shooter games I turn off gsync which is optimal anyway for those types of games so it's not the end of the world. The problem will be single player games where I get a solid 144fps and cannot turn on reflex on + boost, whether that be due to frame generation or the game simply not having that feature. Eitherway it's a very strange issue and one I'd rather not have, given it's a premium monitor. I'll keep experimenting as I play more games and try my best to find a proper fix. Acer support certainly don't seem to know what the solution is although they are aware as they've had other people raise the same issue. Let me know if you get anywhere with it also. Interesting you say you've had this while simply being at the desktop and not even playing games? I have not experienced this myself, has this been while no game is running at all? or while a game is running in the background/minimised whilst you're browsing the internet or something?

  • firebolt059
    firebolt059 Member Posts: 13

    Tinkerer

    edited August 15

    Yes I will have a virtual machine with hyper V running on my second monitor (a 1440p g sync monitor) and my main monitor being the x28 would flicker and turn off for 2-3 seconds. I was also playing final fantasy 7 remake (a game that does not have full screenmode) and I alt tabbed out to respond to a discord message on my other screen and the x28 went black for 2-3 seconds.

    I did the below that seems to have helped:

    -capped to 144hz on monitor, disabled 152hz OC
    -reset nvivia control panel settings to default
    -make second asus monitor (the 1440p one) capped at 60hz
    -g sync to full screen mode in nvidia control panel
    -keep hdr off
    -in games, cap fps to 141 (3 below 144 cap)
    -force v sync on in nvidia control panel (helps with g sync in games)

    I also primarily play games in full screen only. It sucks to lose out on the convenience of alt tabbing but playing in full screen only seems to solve the issue while gaming.

    Please let me know if these help or if you find anything else.

  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    I gave your suggestions a try briefly but unfortunately didn't resolve the problem for me. I'll retry on some other games and see what happens. There is one difference between our setups which is that my secondary monitor is a standard 1080p 60hz monitor not designed for gaming, not sure if that has anything to do with it but worth mentioning.

  • firebolt059
    firebolt059 Member Posts: 13

    Tinkerer

    I also got the black screen in my games after my post.

    I found a theory on reddit that the card needs to be in maximum performance in nvidia control panel settings as well as GPU scaling to be set instead of display under adjust desktop size and position. apparently when you alt tab or the game isn't active (aka loading screen, in menu, etc) the gpu can downclock itself to save power, however when it needs to kick back on it can cause the black screen. I will test over the next few days and report back.

    https://www.reddit.com/r/Monitors/comments/10l11fl/asus_pg27aqn_gsync_bug/

    https://www.reddit.com/r/nvidia/comments/13v06z7/comment/jm62zh8/?utm_source=share&utm_medium=web2x&context=3

  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    This is a really good find, definitely the most technical potential solution I've heard, I applied these 2 changes last night (max performance mode + gpu scaling) and so far it has worked, going to do more tests tonight on some different games to see what happens but it seems promising.

    One other thing I did was tick the override scaling set by games box in the adjust desktop size section as the OP of the reddit post suggested this as well on one of the comments. I assume this just ensures no game overrides the selection of gpu scaling.

  • firebolt059
    firebolt059 Member Posts: 13

    Tinkerer

    Another thing, you may need to change the color output for the X28. See this interaction I had on a forum with someone that seems knowledgeable.

    https://forums.blurbusters.com/viewtopic.php?f=2&t=12420

  • RyzerT
    RyzerT Member Posts: 13

    Tinkerer

    So I've now done more than enough testing and can confirm changing the power setting to 'prefer maximum performance' completely resolves the problem. I did also try the other setting change the scaling one but i changed that back to default to see if the max performance alone would solve it and it has! Hopefully the changes have worked for you as well?