Acer Spin 5 Sp513 Laptop stuck in constant boot mode after fresh restore

Dan_H Member Posts: 3 New User
edited June 6 in Swift and Spin Series

Hey everyone,

I will try and be as succinct as possible. Thank you for anyone who is able to offer some guidance.

  • I just did a full restore on my Acer Spin 5 (erased personal files too)
  • Now, the computer is stuck constantly rebooting. It's been like this for 8 hours+. A quick blue screen will flash as part of the loop. It flashes so fast that I can't make out all the text but at the bottom it says something like "this computer will restart". I've tried leaving it to continue rebooting but like I said, after 8+ hours, nothing changed.
  • I used Alt - F10 to go into troubleshooting mode. However, I do not have my administrator's password so I'm unable to initiate most of the options
  • I've tried restoring the computer again from the Alt - F10 prompt but after the computer has done the restore, the same loop keeps happening.

Can anyone offer some guidance? Thank you in advance.

[Edited the thread to add model name]

FAQ & Answers

  • brummyfan2
    brummyfan2 ACE Posts: 27,286 Trailblazer


    Could you please post the full model name of the laptop, like SP5xx-xx, in the meantime, switch off the laptop, disconnect from mains, and look for a reset pinhole at the base cover, if you have one, follow the instructions in the video, leave the laptop to rest for 20 minutes, reconnect AC adapter and fully charge the battery before trying to start using the laptop.

  • Puraw
    Puraw ACE, Member Posts: 3,817 Pathfinder

    How did you logon to Windows before on your laptop without a password?

    You have to get to the WindowsRE Troubleshoot menu, the only way to do that if you are not logged in to your account, or don't have/forgot your local windows password, is to boot with the recovery USB flash drive. If you don't have this USB drive, borrow one or make one on another PC with the Windows version you are using. Test the USB recovery drive on another Windows PC (same version) to see if you can boot with it. Insert the drive in the corresponding USB port (if the USB drive is 3.01 use your USB 3.01 port). Boot to BIOS (F2) and go to the Boot page, move the USB drive to the top of the list with Boot Devices, save on exit and reboot. You will now see the WindowsRE (blue) screen, you can Reset this PC losing all your files, Restart to Safe Mode (F4 or 4) or add a new user account:

  • Dan_H
    Dan_H Member Posts: 3 New User

    Hi Brummyfan2 and Puraw,

    Thank you both for your responses. It's an Acer Spin 5 Sp513 series. I just reset the battery as per the instructions in the video. The same issue is occurring.

    I saw that the blue screen that flashes for a quick second says that "windows is still installing: 64% Please wait and restart your computer"…or some message to that effect. The message is the same everytime so it sounds like the original restore never completed.

    I also found that each time I hit alt F10 and then select "Use Another Operating System", I see there are 7 different Windows iterations on there. And they keep increasing as I try and retry the restoration process each time. I've included a screenshot of what I'm seeing.

    Regarding the password, I was logging in using the admin account but for some reason that password isn't working. Perhaps it has to do with the fact that the restore never completed.

    Anyways, if you have any additional thoughts, I'd appreciate hearing them. Thank you

  • Dan_H
    Dan_H Member Posts: 3 New User

    Hi Puraw, I followed the instructions to create a bootable USB. I entered the BIOS and prioritized the order so the computer would boot from the USB. However, I'm getting the same rebooting loop.

    Any help would be appreciated. Thanks

  • billsey
    billsey ACE Posts: 29,225 Trailblazer

    You need to have the F12 Boot Menu enabled in the BIOS, then use F12 to choose the correct boot environment. Setting boot order in the BIOS doesn't do anything except change the order they are listed in the boot menu. You have a corrupted EFI partition, which holds the master list of boot environments.

    BTW, there have been at least five different SP513 series designs, and hundred of models within those series. That's why we were asking for the full model number. Your full model number is usually on the same sticker as your serial number, it should look something like SP513-xxx-xxxx.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.

Assistance by Acer

The opinions expressed on Acer Community are the personal opinions of the authors, not of Acer. By using this site, you accept Acer's Privacy Policy and the Acer Community User Agreement.

  • swiftevopoweron-tertiarybanner_620x335
    Swift Series Intel® Evo™

    Power On

  • xbox-agw-tertiary-banner-620
    Game Pass

    Game Pass

  • win-11-pro-banner
    Windows 11 Pro

    Windows 11 Pro for Acer business laptops

  • chromebook-gaming
    Gaming on Chromebook

    Gaming on Chromebook