Acer Iconia B3-A40 tablet bootlooping / not turning on How can I fix this?

Options
mnichur
mnichur Member Posts: 1 New User
edited May 2023 in Tablets

I apologize for any grammar mistakes; english is not my first language.

Hi, my aunt has a problem with my Acer Iconia tablet. She brought it to me and told me it's not turning on. I took it to my house to fix it (because I thought I won't have any problems with it).

First of all, I tried doing what other people did. I tried unplugging the battery for some time and plugging it back in but it still didn't turn on. I tried this about 4 times.

Then, I tried to enter recovery mode to do a hard reset, but no matter how many times I tried, for some reason it didn't turn on. I tried it about 15-20 times.

I also tried connecting it to my laptop with a cable. A notification showed up, it said the laptop is connecting to the tablet. After a few seconds I heard the windows device unplugging sound. I tried connecting the devices about 3 times.

After a few days (today) I tried entering into recovery mode again after connecting the tablet with my laptop. This time, entering into recovery mode kind of worked. The Acer logo disappeared. A message appeared at the bottom left corner of the screen. It says "Supported API: 3". It disappears around every 30 seconds for 1 second, then it reappears and moves up a little.

I watched a video where a guy did a hard reset on the tablet and he showed that a menu appears after booting into recovery mode. The menu didn't appear on my tablet.

How can I fix this? Or how can I reset the tablet to fabric settings?

[Edited the thread to add issue detail]

Answers

  • billsey
    billsey ACE Posts: 32,329 Trailblazer
    Options

    So you likely started out with a fully dead battery and it took a while before it got up far enough to even start the boot process. These can be a little confusing as to how to get fully into recovery mode, because the 'volume up' key changes between portrait and landscape. :) Try it with both options. You need to press and hold the volume up key, then while holding press and hold the power button. When you get it to start powering on release only the power button and continue to hold the volume. Once the Recovery mode menu appears you can release the volume button. At that point it should look something like this:

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • Lastshadow001
    Lastshadow001 Member Posts: 1 New User
    edited May 16
    Options

    I had the same problem I repaired it from sd card. Found the recovery rom..

    Send me your email I will send the link