Acer Aspire A315-21G windows 10 installation problems from usb stick

RorschdarkRorschdark Member Posts: 3 New User

I have a very annoying issue with the an Acer Aspire A315-21G laptop, I tried to install W10 from usb stick with no success. First I made a couple of sticks using the Windows Media Creation tool but the system restarts automatically when the windows logo appears or I get some funny artefacts. I tried to switch between UEFI (secure boot enable/disable) and Legacy with no success and I tried to make another bootable version using Rufus with MBR or GTP partition but I still can't understand why it's not working, it could be a faulty hardware?

It's the first time when I encounter such problem, I attached two photos with the BIOS version and another one with the funny artefacts on the laptop screen.

FAQ & Answers

  • JackEJackE ACE Posts: 41,761 Trailblazer
    1. BIOS must remain in UEFI mode.
    2. Make sure the F12 boot option is enabled in the BIOS Main tab.
    3. Also set and save a supervisor password.
    4. Then re-enter the BIOS menu with the password.
    5. Then disable secure boot. Save setting and exit.
    6. Shut down laptop.
    7. Insert the bootable USB3-certified stick (bootable USB2 sticks can be unreliable in USB3 blue ports) and the Media Creation tool, not Rufus.
    8. Turn the machine on and IMMEDIATELY start tapping the F12 key.
    9. The F12 boot menu should appear to allow you to boot from the bootable USB3 installation stick.
    Jack E/NJ
  • solyomssolyoms Member Posts: 3 New User

    I have the same issue with an A315-21G-65UM. I think I tried everything without success, it is possible we need a BIOS update ?

  • JackEJackE ACE Posts: 41,761 Trailblazer

    If the screen looks OK in the BIOS menu, then the issue is probably a Windows driver issue, not a BIOS problem.

    Jack E/NJ
  • RorschdarkRorschdark Member Posts: 3 New User

    Hi and I apologize for late reply, unfortunately I don't have access to that laptop anymore.

  • solyomssolyoms Member Posts: 3 New User
  • solyomssolyoms Member Posts: 3 New User

    So the problem was solved successfully. First of all I downloaded an old windows 10 ( from 2016 January ) , with this the boot seemed ok, after this I downloaded a BIOS update from official Acer website and installed the 1.25 version BIOS. After the installation I downloaded and installed an up to date Windows 10 from Microsoft website. Hope this will help others !

  • RorschdarkRorschdark Member Posts: 3 New User

    Unfortunately not, he didn't have the patience to resolve the issue and decided to buy another laptop. Another thing that I tried was with BIOS update but I couldn't do it because of an error.


  • leonaipleonaip Member Posts: 416 Specialist

    clean or replace your RAM

    if 4 gb, make it 8 gb by adding a 4 gb or buy an 8 gb RAM

    If my answers/solutions help you, please consider hitting "Like" and "Yes".

    Regards and God speed 😉

    Acer Nitro 5 AN515-58

    - Intel Core i5-12500H 12th gen Octacore ( 2.70 ghz... Turbo up to 4.50 ghz ) with p-cores and e-cores

    - 15.6 inch thin bezel IPS FHD ( 1920X1080 ) 144hz

    - RAM 8 GB DDR4 MAX 32 GB

    - SSD 512 GB Nvme

    - Nvidia Geforce RTX 3050 ( DEDICATED 4 GB GDDR6 )

Sign In or Register to comment.

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer

Drivers &