Acer Nitro 5 Nitro AN515-57) randomly started lagging

Options
Blobfish64
Blobfish64 Member Posts: 3 New User
edited July 2022 in Nitro Gaming
So I have had this laptop (Nitro AN515-57) for about 8 months now, and it would run games completely fine. Now just about 2 days ago I booted up Genshin Impact and it started lagging like crazy. I have tried many other games and I get the same results. I have reset my computer multiple times since then as well. It's probably something with the GPU because it caps out at 100% constantly whenever I run a game, and it has never done that in the past. The games say they are running on the RTX card, so that's not the issue either. Any help would be greatly appreciated!

(edited the title to add the model name from the content)

Best Answer

Answers

  • Blobfish64
    Blobfish64 Member Posts: 3 New User
    Answer ✓
    Options
    Ok after many attempts on fixing it, I finally found a solution! If you have the same issue, try downloading the drivers from https://www.acer.com/ac/en/US/content/drivers
  • FuryUA
    FuryUA Member Posts: 26 Enthusiast WiFi Icon
    Options
    which driver did you download?
  • Blobfish64
    Blobfish64 Member Posts: 3 New User
    Options
    FuryUA said:
    which driver did you download?
    Oh right I didn't fully say lol. The one that has your graphics card in parenthesis
  • REEEIIIN
    REEEIIIN Member Posts: 1 New User
    Options

    I'm experiencing the same problem is this the one that you have downloaded?


  • Shinobi12
    Shinobi12 Member Posts: 4 New User
    Options

    If anyone still has the same problem, here's my solution. I had the same exact problem and have been struggling with it for days and no solution on any forum have fixed it for me.
    Today I have tried to uninstall all the vga drivers once again manually and noticed that whatever I do they kept coming back even with the internet off. Windows just kept installing them somehow and I had to prevent it from doing that.
    Here's what I've done:
    1. Download GPU drivers from official Acer site: https://www.acer.com/pl-pl/support?search=Nitro%20AN515-57&filter=global_download&suggest=an515-57;1 - VGA Driver ('your gpu model')
    2. Turn off your internet connection
    3. In Windows go to Settings > System > About/Info > System protection > Hardware > Device install settings; here just click the 'No' option- this prevents Windows from installing any driver updates by itself
    4. Open Device manager and uninstall your gpu drivers
    5. Restart your system
    6. Install your designated GPU drivers ( Advanced install > Clean install )

    This method finally worked for me and now my GPU usage in Divinity Original Sin 2 on Ultra is just 35% and I have a stable 60fps, whilst before the usage was at 100% and I had 5-10 fps max
    Hope this helps anyone with a similar problem!

  • Shinobi12
    Shinobi12 Member Posts: 4 New User
    Options

    Little UPDATE:
    After you've done the things I mentioned in this comment you should do the followinng:
    1. Go to https://www.acer.com/pl-pl/support/drivers-and-manuals
    2. Find your model
    3. Go to BIOS tab and download the latest BIOS update
    4. Run the update
    5. All done! Fixed it for me!

  • massi357911
    massi357911 Member Posts: 4 New User
    Options

    I've done this and i wanna thank u. I have a question tho. the drivers that i installed are one year old now. Do i need to update them with nvidia geforce experience right? if so, what was the point to uninstall them and reinstall the same drivers? thanks again