Examples: Monday, today, last week, Mar 26, 3/26/04

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

A500 Still Frozen at Google sign-in-screen latest results

ivibreivibre Posts: 7Member

Reference to A500 frozen: Have pushed every button, reset, used usb keyboard, not rooted, factory Honeycomb 3.2, (stuck in update aparently?), missed pattern lock, went to Google sign-in-screen - now frozen there. Have gotten dead android, safe mode, different locked screen. A500 purchased new, out of warranty one month and froze. Not rooted, not tweaked, pristine condition, no kid/other person ever used it. At point of giving up. Decided to try one more time. This is what I found this morning: Black text (me); Green/red text (XDA); blue (n/a).


Found in XDA Developers. Got in touch with a 15 yr old who said "you have allot of reading to do" but aparently he didn't read my beggar plea in the entirety of the message because it is not possible to find the CPU ID in the A500 Tablet.


From XDA Developers: "This is a good way to bring an A500 back to full stock from just about any rom, custom or stock rooted. You need to already have CWM installed" the page is: "Iconia A500 General" (since addresses are not allowed, sorry).


In HUGE red letters warn: "Wipe? - back up in MULTIPLE locations"


Then: "reference to various factory ROMS"


XDA: "I have included post 20 from below. It is a guide for getting recovery back should something go wrong. What it will do is install CWM as well as the V8 bootloader. After that you can start all over or flash whatever you want.

I prefer to use Blackthund3rs APX Flash Tool. To get the apx tool google this. blackthund3r apx tool

Basically what you will do is get the tool, open it, choose bundle market, choose 17, use default bct, enter APX download mode, and flash the V8 bootloader with CWM.

The steps are... (Copied from (shown on page as described above)


What I want is step-by-step instructions how to "read" my A500 from the PC. Have installed the USB driver but can only see the A500 as a camera. Someone said "old is gold" but I'm feeling a little lead here. Thanks anyone . . . . smiles 4 miles v


  • ivibreivibre Posts: 7Member

    QuoteOriginally Posted by VelosCohagen View Post

    Tab should go in apx mode when holding reset and then while holding reset press power button for about 4 seconds. Then release power button and then reset button. Then power button should light up white while display stays dead.

    This is exactly what i did. Further i installed all packages listed in the XDA thread and was able to compile the apx program without any compiler/linker error.
    Later this evening i will try out your seggestion to use a different computer/laptop.
    UPDATE: I tried two different laptops but had no luck. I got always the same error message "Error: Failed to open device!"
    Is the device ID 0955:7820 correct for an A501 in APX mode?
    UPDATE 2: I took a look at the apx tools source code and saw that it is the correct id, as the tool tries to open a device with the same ID.
    Does anybody have a clue what is going wrong?

    EDIT: I finally got my CPUID :-)!!! I did not know that i have to run the apx program as root....
    BIG thanks to everybody for your help!

  • ivibreivibre Posts: 7Member

         [GUIDE] Recovering Recovery/Obtaining SKB

    Recently I decided to upgrade to ICS. True ICS, new bootloader and stuff from my quazi-ICS install (HC bootloader, ICS rom) This sounds easy, however, my recovery was too old! Being used to using my forgiving Samsung SGS2X, I just flashed a NEW recovery while IN recovery - thus REMOVING recovery. (rather than using the problem-free Acer Recovery Installer via google play like smart people do)
    Heres where it begins.
    symtoms: -Boots to ACER logo and stops -Refuses to read update.zip package from microSD/USB (likely, as the recovery was corrupted!) -I can enter APX mode however. I have no recovery, no boot, no ADB mode, no way to read internal flash.
    I did do a NANDROID backup, which is immensely important and EVERYONE should have at least ONE of these, due to your UID being recorded. This is where my problem came in. The NANDROID backup was on the internal storage!
    So, I have a tablet that has no recovery, won't update.zip install, but WILL get to APX mode. I have NO UID, no SKB, no NANDROID backup. Solution is to send to acer? I think not!
    Theres some brilliant people on this forum. One post in particular was golden. /en/home/leaving?target=http%3A%2F%2Fforum.xda-developers.com%2Fshow...75%26amp%3Bpostcount%3D9" class="Popup by eppeP
    "If you can get the device into APX mode it will answer the first read request with the UID."
    This is 100% true, and he provided a simple source example but little instructions. I hope I can elaborate and make someone elses life easier.
    Requirements: -Ubuntu (I used 12.04 LTS) -microUSB cable -powered tablet (can't be dead) -paper clip, tac, needle - something to hit reset with -patience
    Boot Ubuntu, can be from CD/DVD/USB/network or installed copy Install GCC, lsusb, libusb-1.0.x, libusb-1.0-dev - you NEED these! (hoping these are the only ones required for fresh installs) Grab the code eppeP posted and save to a text file as apx.c fire up terminal, browse to where the apx.c file is ('cd /home/<user>/Desktop/APX' for me) run the following commands
    sudo su gcc apx.c -o apx -lusb-1.0
    You should now have a file called apx on your desktop, that is ready to run. If you get errors, you are likely missing a package. This should be fairly straight-forward, but refer to google and post the results please!
    Next, pop your tablet into APX mode - plug in microUSB, hold the RESET button, and press power for around 4 sec. Windows gave me a 'usb detected' noise but Ubuntu just don't care.
    Now run the following commands (assuming same root terminal permissions. If not run sudo su beforehand)
    the terminal window should spit back to you a 15 character UID if everythings correct. 0x123456789ABCDEF (yours should be different combos of those hex values)
    Proceed to guard this with your life! (although now you know how to retrieve again provided APX works)
    now visit /en/home/leaving?target=http%3A%2F%2Fvache-android.com%2Fv1%2Findex.php%3Fsite%3Dsbk" class="Popup and enter your UID. The website should spit back a series of 4, 8 character keys known as your SKB. Guard that too in case the website ever disappears.
    Hard parts over. The tablet will live on now. Next - choose how to recover!
    I  used a file called:
    V8-UNL-ICS-HC-bootloader-MULTI-cwm.zip   32MB MD5: 33D6692A997649111995CB690EF73213
    I sadly lost the link to this package but im sure if you search google/this forum you will find it.
    It uses nvflash. Amazing program. Theres also A500APXflash, based off nvflash. The rest mainly require ADB or USB debugging which you can't set as the tablet won't boot so don't waste your time with proggies like afterota (which won't work if you only have APX) You can also do everything in ubuntu with nvflash and the terminal. just read the commands from the batch, they should be nearly identical commands in either environment.
    I booted back to windows, ran the V8.bat file, and followed instructions. In 30 seconds my iconia was booting recovery again and that ROM I initially tried to install worked perfect!
    After it booted, I realized I used 44% of my battery attempting to recover the tablet. This whole process takes maybe 30 minutes first-time through, getting ubuntu packages took the longest. LiveBoot will want to update everything as well, which I never considered, and usually fails (due to live install). Everything should be installed from Terminal if possible if using a live distro. It should be one command-line for the packages, reference exact package names in the package manager maybe. My nandroid backup was still on the flash though! I knew enough that a 'hard reset' wasn't going to fix anything, so I never erased any userdata ironically, but botched the ROM and recovery.
    This is the 100% fool-proof way to get your UID using APX. If its your only method this is your only option.

This discussion has been closed.

Who's Online295

+284 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!


Maintenance Notice:

The Acer Community Maintenance has ended! We apologize for the delay and would like to thank everyone for their patience. We're still ironing out some details but you're more than welcome to explore! Stay tuned to the Announcements section as we'll be updating it regularly to keep you informed about the changes.

New Here?

New to Acer Community?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 760

Total Points:147

Total Accepted Answers: 0