Acer aspire a515-43 RAM upgrade issue

SPhaze
SPhaze Member Posts: 2 New User
So I have an acer aspire(a515-43) which came with 2 sticks of 4gb 1RX16 PC4-2666V and have decided to upgrade to 16gb (2 x 8gb sticks 2666V). Everything went smoothly when putting them in but I loaded it up when I was done putting the 2x8gb sticks in and it still says I’m only running 8gb of installed RAM at a speed of 2400Mhz and not 16gb even tho I have both 8gb sticks in it. I’ve tried most solutions I could find on the internet but none have worked. Have I done something wrong or bought the wrong sticks or something? I bought the 2x8gb 2666V sticks as my 2x4gb ones that was in the laptop when I bought it was also 2666V. 

I haven’t tried opening the laptop back up to check anything since putting them in so if I can do anything on that part then please let me know.

Best Answer

FAQ & Answers

Assistance by Acer


The opinions expressed on Acer Community are the personal opinions of the authors, not of Acer. By using this site, you accept Acer's Privacy Policy and the Acer Community User Agreement.

  • swiftevopoweron-tertiarybanner_620x335
    Swift Series Intel® Evo™

    Power On

  • xbox-agw-tertiary-banner-620
    Game Pass

    Game Pass

  • win-11-pro-banner
    Windows 11 Pro

    Windows 11 Pro for Acer business laptops

  • chromebook-gaming
    Gaming on Chromebook

    Gaming on Chromebook