Nitro 5 How can I boot from my external SSD?

timucintimucin Member Posts: 1 New User
edited November 2021 in Windows 11
Some Information:
- UEFI Mode
- Acer Nitro 5 (3Months old)
- Satamode = AHCI
- SSD is formatted in GPT
- Linux system ist on the ssd

First i formatted it in GPT and after i installed Linux (Grub Loader is also on the ext.SSD).
I have set all of this on my internal harddrive with Windows 11. Please help me, i am very desperate. Have read throught many Forums - No success.

I just want a properly installed Linux system on the external ssd to boot from.

FAQ & Answers

  • AnhEZ28AnhEZ28 ACE, Member Posts: 2,732 Pathfinder
    @timucin firstly, you go to the BIOS, on the Main tab, enable F12 boot menu. So you can choose the external SSD to boot.
    Please remember to include @AnhEZ28 when you want to reply back to my comment so that I can check your response.
    Thank you and have a nice day!
  • billseybillsey ACE Posts: 27,023 Trailblazer
    Verify that during the install the EFI partition was created for booting. If not you may have to enter the mount point for the Linux installation to the Windows boot manager.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • EaswarEaswar Member Posts: 6,728 Guru
    Hi @timucin,

    1. Download the related installation ISO file from Microsoft and connect the hard drive to your computer.
    2. Go to "Control Panel" and find "Windows To Go".
    3. Choose the external hard drive and click "Next".
    4. Click "Add search location" to search for the ISO file.
    5. Select the ISO file to make the external hard drive bootable.
  • padgettpadgett ACE Posts: 4,532 Pathfinder
    Have you tried hitting F12 while booting and select the external drive. Works on many Acer devices.
  • padgettpadgett ACE Posts: 4,532 Pathfinder
    edited December 2021
    May need to enable the F12 boot selection in the BIOS. If external drive is a bootable GPT may also need to add the signature to the Bios UEFI database or change the BIOS boot to Legacy.
  • billseybillsey ACE Posts: 27,023 Trailblazer
    Don't change the boot mode to Legacy! That will totally break booting on any modern computer. You do need to have the F12 boot menu enabled and Secure boot either enabled with the EFI set to allow that image or Secure Boot needs to be disabled. In the long term it will be safer to have Secure Boot enabled and the needed EFI file set as allowed.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
Sign In or Register to comment.

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer

Drivers &