Acer Aspire 5250-BZ873 (P5WE6) Slow to POST Issue

Kajolic Member Posts: 1

I have obtained an Acer Aspire 5250-BZ873 (Model #: P5WE6 from back label) from a friend to see if I couldn't get it working.


Issue I have encountered:

  • Long (~5+ Minute) wait for even the "Acer" logo or the POST to show up.  I get a solid black screen with a non-blinking Underscore in the upper-left corner during this time.  Also, the laptop exhast fan is at 100% during this time.

I was able to get into BIOS via F2 spam.  Reset the BIOS to defaults and selected the DVD drive at boot #1 and HDD as #2 and attempted to place an obtained copy of Windows 7 Home Prem. (Source) and I have successfully installed Windows 7 Home Prem. via their copy.


Steps taken so far to resolve to long black screen:

  • Removed Battery and A/C Plug and held Power down for 1 minute and reconnected via A/C Plug.
  • Was able to get into BIOS to reset to defaults.
  • Replaced BIOS battery.
  • Removed DVD-ROM and HDD and booted the computer to the BIOS, same ~5+ minute screen.
  • Swtiched the DIMM slot for the RAM, same result.
  • Cleared all dust (was very little) from the inside.
  • Updated the BIOS from 1.01 to 1.08, same result.
  • Attempted to press 'Esc' or 'Space' to bypass the suggest "RAM Test" it may be doing at bootup, doesn't seem to be the case.  **Will note that pressing 'Esc' makes the underscore on the black screen larger ont he screen.



Any suggestions?  I'm curious more on the long wait before POST or even "Acer" logo at this time.  Open to suggestion to try to get the laptop working again.


Thanks in advance!



[Edit] - If I reboot while in Windows 7, it will POST like it should. (Couldn't repeat the quick restart, it acts the same as a fresh bootup)  It seems only when you are booting after the laptop was been off it takes a very long time to get to POST/"Acer" logo.  Windows 7 actually loads up fast, no issue with Windows.

Also, no BIOS warnings at all.  Motherboard speaker does work because if I unplug the A/C Adapter, it will beep to inform it is now on Battery Power.


  • stanley82
    stanley82 Member Posts: 1

    I fixed mine, it was due to the bluetooth dongle I had fitted to the usb port.  Ian.

  • johnYu
    johnYu Member Posts: 1

    I had the similar issue with Acer extensa 5235. It boots to BIOS but very slow. Information shown on BIOS screen correctly and all settings are working fine. 


    However the laptop does not boot from internal HDD or CD rom, but it is able to boot from USB with DOS or USB cdrom.


    Any suggetions are welcome.



This discussion has been closed.