Examples: Monday, today, last week, Mar 26, 3/26/04

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

Acer Iconia W700 Wi-Fi problem

veragtiveragti Posts: 3Member

Hi everyone,

 

Yesterday, I bought an Acer Iconia W700 tablet and for some reason, the wi-fi disconnets all the time. If I have the tablet really close to the wi-fi spot, it work fine but when I go to my living room, the internet disconnets or it get's limited. The farest thing I can do is open google and search for something. Then the internet crashes..

It's frustrating these situation... And I was wondering if I have to return it or if there is any thing I can do to fix it. I also saw other users online complaining about the same problem...

 

Thanks for the help!

Answers

  • tpaige0991tpaige0991 Posts: 98Member

    You should probably call technical support, maybe they can help you get it worked otu since it is still under warranty. 

  • Joshua188Joshua188 Posts: 523Member

    Well You could always try and use (Windows key and X) click on the Device manager then go under the network adapters and right click the wireless card and uninstall the driver (do no click the check box) and reboot and allow it to reinstall the driver. this may help.

  • mengpomengpo Posts: 2Member

    Hey there,

    The wifi problem (random deconnections) is mainly caused by the sleep mode and the wifi 802.11n.

    All you have to do is to force the connection to a 802.11g from your tablet and your internet spot. It worked for me Smiley Wink

    I don't know whether my explanations are clear enough or not sorry my bad english.

  • muldermulder Posts: 1Member

    I have the same problem.  I will try to play with the settings and see what happens.

  • ZeroHackeRZeroHackeR Posts: 1Member

    Hi all,

     

    I'm having the same issue.

    I've tried all the suggestions from another web link and didn't work thus far.

    So, how do I force my device to use only in G mode?

    I could change from my router but it will affect all other devices which is something I do not desire.

     

     

    Sources:

    http://answers.microsoft.com/en-us/windows/forum/windows_8-networking/wi-fi-connection-repeatedly-goeslimited-on-windows/eec795c0-9a33-4060-9200-c9d865ae31e3?tm=1353773399139

  • ilzk521ilzk521 Posts: 1Member

    hi,maybe you speak chinese? i guess from your name . i tried the new driver from acer but it doesnt work . could you tell me how to force the connexion to 802.11g ,as in the advanced property of wifi adapter ,i cant find any option of wifi mode.and by the way ,i cant change the mode of router...i dont think this is caused by the sleeping policy,as i am downloading somgthing,it can become limited...

  • veragtiveragti Posts: 3Member

    hi again,

     

    my router connection is 802.11b/g. it's a thomson tg784. i already updated the antheros software to the new version that acer released on 23th november but the problem stays the same.... no connection when i'm away from the modem... 

    most likely i will return the tablet.

     

  • kailbkailb Posts: 2Member

    This solution from Microsoft's Windows 8 support community seems to have fixed the issue for me:

     

    i went to acer and downloaded the wifi drivers, uninstalled the device in device manger, restart pc, went back to device mmanager and looked for the unknown device. i then right click unknown device and installed the driver from acer.

     

    http://answers.microsoft.com/en-us/windows/forum/windows_8-networking/wi-fi-connection-repeatedly-goeslimited-on-windows/eec795c0-9a33-4060-9200-c9d865ae31e3

  • Jeffd10Jeffd10 Posts: 1Member

    Same issue here..I updated the drivers and only get internet within 2 feet of my router. Called support and they want me to send them the tablet...sorry but it is going back..not dealing with all of this. The biggest thing a tablet needs and it dont even work. Nice QA you al have over there!!! Dont you even check this stuff out before you put a us through this?

  • PlinkoPlinko Posts: 12Member

    I've got the same issue on my W510 I received yesterday.  No drivers for this device listed in downloads yet...

  • farkingdomfarkingdom Posts: 13Member

    I''m looking forward for a proper fix. The issue is bugging me and my iconia W700 is only two days old (brand new).

    I reside in Malaysia so my model is the one with a Sandy Bridge i3.

     

  • mncpamncpa Posts: 1Member

    Just want to say 2 day old Iconia W700 here with wifi AND bluetooth keyboard connectivity problems. This is unacceptable and ridiculous. I'm going to weite up Amazon/Newegg reviews are going to warn others away from this terrible product. Edit : Also, cradle usb ports do not work. Seriously? This sucks.

     

  • veragtiveragti Posts: 3Member

    Hi there again,

     

    I am sorry to ear that I am not the only one here with these problem.
    I went to Acer and they told me that the Tablet was working fine and that I was the first to complaine about the wifi problem. Tested 3 internet connections and actually, mine was the only one with connectivity problems..

    Well....Since I know how things work around here in Portugal...It's never There fault and the one that gots screwed is always the final costumer...I went to Media Market and returned the Tablet Smiley Happy So....My problem is solved. Finnally!

    But I do believe the problem is not with the Acer product.. And that those who still have the Tablet will see there problem solved sometime soon. Good luck

  • shupiuiumashupiuiuma Posts: 1Member

    I confirm the problem exists for me as well. Lastest drivers installed (from 23th) and still the same. Problem is especially visible when I start to transfer files with high speed from another PC in the network. Then a see a drop every minute.

    I really expect this will be solved soon, because now my only USB port is taken by a WiFi adapter.

  • number2number2 Posts: 1Member

    Where is the ‘Acer’ response to this?  Under ‘Acer Tablets’ this thread has the most responses and views yet Acer has no fix or comment?  Even an acknowledgement of the issue would be nice.  We were going to replace our Dell laptops with these for frequent travelers, but I can’t recommend something this unreliable.  Everything else works great but doesn’t if you can’t connect…

     

    Latest WiFi driver from 11/23, power settings change for the tablet and WiFi adaptor per prior postings and still having issues.

    Where are you Acer!

  • spkrgeekspkrgeek Posts: 3Member

    I just received my W700-6691 last Friday and have this issue too.  The wifi connection seems to stop every 6-10 minutes.  

     

    I've tried installing the latest Atheros BT / WLAN driver (v10.0.0.217 from 11/23/2012) but this does not fix the issue.  I've also tried setting the power options for the WLAN to HighPerformance always. 

     

    The problem is expecially noticable when streaming content to the tablet (e.g. when streaming music files off my home server or when downloading a big file from the iternet.)   I can reproduce the problem whether the tablet is 5 feet or 60 + feet way from the wireless router.  I have tried multiple wireless networks at home (D-Link DIR-655, Buffalo WZR-HP-G300NH) and at the office (Cisco) and each has the issue.

     

    I also tried a signal strength utility (Buffalo Client Manager V) and it seems like this is not a reception issue.  The signal strength seems to be very good, but the network adaptor just stops responding.  I've noticed that the network connection does seem to "reset" itself within 2-3 minutes.  I can also immediately disconnect and then reconnect.

     

    I'm going to try running through a Windows 8 update and see if that helps.

     

    Has anyone still reading this thread actually solved their issue? 

     

     

     

  • hyrusmilehyrusmile Posts: 3Member

    I also have the disconnecting problems and It appears to be a flaw in the system.  I cannot get it to work with drivers or settings for the adapter.  I am currently using a third party adapter and I will also be warning would be purchasers of this flaw on Amazon as its very serious.

     

    Acer please let me know when there is a fix for this.  Its debilitation to your well thought out device.

     

    Thanks

  • spkrgeekspkrgeek Posts: 3Member

    Hyrusmile, do you have the same issue using an external wifo adaptor?  I will try that too.  If the problen persists with an external wifi adaptor, then it must be a wifi driver / OS problem. 

     

    Has anyone else tried an external wifo adaptor? 

     

    Does anyone feel that have a permanent fix for this?   Several people said that they thought the new driver fixed their issue.  Is this still true? 

     

     

  • hyrusmilehyrusmile Posts: 3Member

    The USB wifi is working so far.  I have updated the driver and it still will go "limited connectificy" erroneously for me on the built in wifi.

  • RaffiRaffi Posts: 59Member

    Hi All,

     

    This worked for me.

     

     

    Open network and sharing  > change adapter settings > wifi adaptor properties > configure > power management > uncheck "allow the computer to turn off this device to save power"

     then go to your battery settings

    Battery icon > more power options > power saving / balanced / high performance > change plan settings > change advanced power settings > wireless adaptor settings  > power saving mode  > on battery >  change to low or medium power saving (although troubleshoot says medium power saving should fix the problem, I chose the low power saving, so far no hiccups with the "limited" connectivity.)

  • spkrgeekspkrgeek Posts: 3Member

    Thanks Raffi.  I did try your suggestion earlier and still no luck.  The built in Qualcomm Atheros wifi connection still drops every 5-10 minutes.

     

    Here is a complete list of the changes I've made:

    1. Downloaded the latest Qualcomm Atheros wifi / BT driver from the Acer support site.
    2. Ran WIndows Update to update  Windows 8 with all recommneded patches
    3. Set Device Manger > Network Adaptors > Qualcomm Atheros AR5BMD222 > Power Managerment > "Allow the computer to turn off this device to save power" to unchecked.
    4. Set Battery icon > more power options > power saving / balanced / high performance > change plan settings > change advanced power settings > wireless adaptor settings  > power saving mode  > on battery to "Maximum Performance" (I tried the other options as well)
    5. I'v tried a total of 4 different WiFI networks at home / work and the problem happens on each.

    I did try a USB Wireless N Adaptor from D-link and the network connection using the USB adaptor has been stable for about 2 hours now.  I think this indicates that the problem is with the built-in Qualcomm Atheros adaptor and not with Win 8.   

     

    I'm going to try to completely remove and then reinstall the Qualcomm Atheros drivers.   

  • ChrisChris Posts: 84Member
    Accepted Answer

    I would like to contribute to this thread.

     

    I have tried the following steps which have resolved the issue for me:

     

    Download the latest driver from Acer Support site.

     

    - Please make sure the version of the Wirelesss Lan Driver to be downloaded  is: 10.0.0.217

    As this is a combo dirver it will also upgrade the bluetooth to 8.0.0.214. Hence the big filesize 220MB.

    - Go into control panel and remove the current wireless lan + bluetooth drivers.

    - Once removed you can go through and install the newest downloaded driver.

    - Restart tablet after installation

     

     

     

  • Crazy9000Crazy9000 Posts: 4Member

    My W700 has been working without interuption for the past half hour now. I did not try Asus' driver after some people in this thread said that didn't work, so I found an alternative version. Maybe some people still having problems could try what I did:

     

    -Google " Qualcomm Atheros AR5BMD222"

    -The first result is a http://www.atheros.cz/atheros-wireless-download.php?chipset=72&system=6 , so go there

    - Click the "click for download" button, which takes a few mins then gives the download

    - Uninstall the wireless card via device manager, and select the option to delete driver from the PC

    - Scan device manager for hardware changes to get it to show up again

    - Point device manager to the download (extract it first)

     

    In case that page changes in the future, the file I used is named "win78-10.0.0.75-whql.zip". It sounds like it's an older version, but it seems to be working which is all I care about.

  • RaffiRaffi Posts: 59Member

    After reinstall the driver,if the issue is not fixed,Reinstall the OS if the issue persists

    Tablet has to be sent in for warranty repair...

This discussion has been closed.

Who's Online151

AdelinB
AdelinB
AdityaShinde
AdityaShinde
cardsharp
cardsharp
HelghastPredator
HelghastPredator
JordanB
JordanB
kickirik
kickirik
Kno63
Kno63
MannyCalavera
MannyCalavera
peterplus
peterplus
rasel123
rasel123
Reinalddo
Reinalddo
ryuuichie
ryuuichie
SeanbDonovan
SeanbDonovan
ven98
ven98
+137 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Five Year Anniversary

Acer Community turned 5 years old this week! I would say that's a reason to celebrate!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 1048

Total Points:589

Total Accepted Answers: 91

ven98 Seasoned Specialist