After i reset my settings with out deleting files i had an extrem fps drop in helios 300

Options
Mhmd122
Mhmd122 Member Posts: 1 New User
edited February 2021 in Predator Laptops
My acer predator helios 300 rtx 2060 and core i7 10750H 

Answers

  • Jack22
    Jack22 ACE Posts: 3,784 Pathfinder
    Options
    @Mhmd122
    Mostly the complete reinstall of the OS will make things to work on the laptop.
    So please try doing the reset with deleting all the files, please take the back up of the data before doing it and than try to play and check.
    Click on 'Yes' if the comment answers your question!
  • christy1
    christy1 Member Posts: 1,619 Community Aficionado WiFi Icon
    Options
    Mhmd122 said:
    My acer predator helios 300 rtx 2060 and core i7 10750H 

    Please perform the following steps and check the CPU usage :
    >>>Power Reset
    Disconnect the charger. Please check for a battery reset PIN hole at the bottom of the device. The reset hole would have a battery symbol next to it. Insert a paperclip into the hole and press for four seconds. Let the computer sit for 5 minutes with no power. Reconnect and monitorthe CPU usage.


    >>>End Task of running programs and Disable Startup program in task manager. This fix can help you quickly end high CPU usage issue when your device becomes extremely slow or even get stuck with running programs:

    Press Ctrl + Alt + Del keys at the same time to bring up Task Manager; 
    Select Task Manager > Check and select programs that are taking high memory and CPU usage > Click End Task to close selected programs or apps. 
    Click on Startup on Task Manager > Select and right-click on unnecessary programs or apps > Select Disable to stop them running from Startup.


    >>>Run DISM command to decrease high CPU usage

    Right-click on Start and select Command Prompt (Admin), sign in with your administrator account;

    Type: DISM.exe /Online /Cleanup-image /Restorehealth and hit Enter;

    Type: DISM.exe /Online /Cleanup-Image /RestoreHealth /Source:C:RepairSourceWindows /LimitAccess and hit Enter;

    Type: sfc /scannow and hit Enter.


    >>>Disable Superfetch and Windows services to fix Windows high CPU usage 

    Press Ctrl + Shift + Esc to open Task Manager;

    Go to Services tab and click Open services;

    Navigate and locate Superfetch, right click on it and select Properties;

    Click Stop to end the Superfetch service and click OK to confirm the change.


    >>>Press Win + R to open Run dialog > Type: msconfig and click OK;

    Check Hide all Microsoft services under Services tab > Uncheck all other remaining services > OK to save all changes;

    Restart Windows > Enable any services individually and reboot PC > Repeat the process till Windows high CPU usage issue gets fixed by then.

    Accept if its Helpful.   B)