Aspire One Happy 2 ZE6 slow networks

PeterHodgsonPeterHodgson Member Posts: 19 Troubleshooter
Hi
I have a Happy 2 ZE6 with 2GB ram and a Lexar SSD running Windows 7 up to date with packs and patches. The wireless is an Atheros AR5B95 with the latest Atheros driver 9.2.1.459 and the lan is the onboard Realtek PCIe FE with the Realtek driver 7.37.1229.2010
Its talking to a HUAEWI router from TalkTalk which supports all the usual 802.11 protocols.
The general performance of the laptop is ok, not lightning quick as you'd expect from an Atom N455, but ok, but the internet connection is really bad. Other devices (iphone, ipad, desktop with Windows 10) get downloads speeds of 60-70 mps either wired or wireless, but the Aspire only gets 5-10 wireless and 10-15 wired.
I've run all the usual troubleshooters in Win7, switched off everything except IPv4 on the adaptors, but nothing seems to improve the speed.
Is it just the processor limitations of the Happy 2 ?
Thanks
Peter

FAQ & Answers

  • PeterHodgsonPeterHodgson Member Posts: 19 Troubleshooter
    Should have added, using Chrome's internet speed checker. Edge reports something similar. 
  • PeterHodgsonPeterHodgson Member Posts: 19 Troubleshooter
    Ok, update. I downloaded the Ookla desktop app for Win7, and it reports 59mps, so it's a browser issue, right ?
  • billseybillsey ACE Posts: 18,147 Trailblazer
    That's what it sounds like... Maybe the browsers use just enough memory to get you into disk swap out mode... Use Task Manager to see what memory use is like with and without the browser loaded. 2G is pretty small these days.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • StevenGenStevenGen ACE Posts: 2,151 Pathfinder
    edited February 3
    Hi
    I have a Happy 2 ZE6 with 2GB ram and a Lexar SSD running Windows 7 up to date with packs and patches. The wireless is an Atheros AR5B95 with the latest Atheros driver 9.2.1.459 and the lan is the onboard Realtek PCIe FE with the Realtek driver 7.37.1229.2010
    Its talking to a HUAEWI router from TalkTalk which supports all the usual 802.11 protocols.
    The general performance of the laptop is ok, not lightning quick as you'd expect from an Atom N455, but ok, but the internet connection is really bad. Other devices (iphone, ipad, desktop with Windows 10) get downloads speeds of 60-70 mps either wired or wireless, but the Aspire only gets 5-10 wireless and 10-15 wired.
    I've run all the usual troubleshooters in Win7, switched off everything except IPv4 on the adaptors, but nothing seems to improve the speed.
    Is it just the processor limitations of the Happy 2 ?
    Thanks
    Peter

    I have owned and have experienced the Happy2 frustrations and there sure not Happy 1 or 2 =) with my Aspire Happy2-N57DQpp that I've owned for 10 years, my Happy2 has the Intel Atom N570 @ 1.667GHz – 1.67GHz2GB, 2GB DDR3-1333MHz upgraded from its 1GB of ram and running an EVO 850 SSD and have run it on Win-7 Basic (and as you said, it’s not lightning quick as you'd expect) and have also tried to run it on Windows 10 Home 64bit and it was a pretty slow and frustrating platform.

    With 2GB memory things get pretty messy once anything needs memory (as billsey is saying) also, it could be a hardware problem, uninstall the LAN driver (yes I know you have the latest driver) and reinstall it again, as 5-10 speeds are very low. Also and another solution is to get a new WiFi/BT cad and see if its not hardware related? As it could be that your old Atheros AR9285-AR5B95 card (might be faulty) that you have and also the Atheros AR9285-AR5B95 card is a single chip 2.5G WiFi only card, replace the card with the Atheros AR9462-AR5B22 "Dual Band" Wireless N (2.4GHz and 5.0GHz) + Bluetooth BT 4.0” type card (which is cheap and I’ve done) and see if that solves your problem? As I've never ever had the problems that you have with either Win-7 or Win-10 OS, yes the Happy2 is slow but not that slow and the wireless and BT worked perfectly and very quick, I never ever got such low “5-10 wireless and 10-15 wired” signals. 

    Btw, you can download all the newest and appropriate Quallcom Atheros drivers for the Atheros AR9285-AR5B95 for Win-7 to Win-10 at this link, the WiFi Atheros AR9285-AR5B95 driver version is this one win7-10.0.0.336-whql.zip and the BT driver is this one bt-8.0.1.314-win7881.zipgood luck and hope this was helpful to you.


  • PeterHodgsonPeterHodgson Member Posts: 19 Troubleshooter
    Thanks for the responses. I think the ZE6 can only take 2gb ram max, it has the latest 1.15 bios but i think this is the max. the wireless cards seems ok as the wireless network connection status windows shows the link speed as 65 mbps and the ookla app shows 60mbps. its just browsing thats slow. i checked task manager and resource monitor and neither show memory being maxed out, but both show cpu at 100% with chrome open and browsing. i tried turning the windows 7 firewall off and ran chrome speed test but it made no difference, still only 10 over wireless. very strange.
  • PeterHodgsonPeterHodgson Member Posts: 19 Troubleshooter
    I swapped out the atheros wireless card for a broadcom and the result is roughly the same, 50mbps via ookla desktop and 72mbps shown in the network details screen, but only 15 mbps via chrome internet speed checker. So it wasn't the atheros card that was the problem.
  • billseybillsey ACE Posts: 18,147 Trailblazer
    Typically on a system that is short on memory the 100% disk usage is showing that you have run low on physical memory so it's swapping to disk. I'm pretty sure that is exactly what you are seeing.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
Sign In or Register to comment.

Who's Online1.4K

Acer-Erick
Acer-Erick
Acer-Ingrid
Acer-Ingrid
Acer-Jose
Acer-Jose
Acer-Manny
Acer-Manny
amarever
amarever
AnhEZ28
AnhEZ28
atonement
atonement
Batareika007
Batareika007
brummyfan2
brummyfan2
damonmoore
damonmoore
dar3nz3
dar3nz3
dosleemy
dosleemy
Easwar
Easwar
felipemelo001br
felipemelo001br
GAMING6698
GAMING6698
Gawain
Gawain
Hayatuddeen
Hayatuddeen
JackE
JackE
jcurin89
jcurin89
LavanyaSahu
LavanyaSahu
Leostat
Leostat
MarcosZy
MarcosZy
MAXST
MAXST
msmafra
msmafra
Peregrino69
Peregrino69
Protector330
Protector330
Rayminster
Rayminster
RenanVilela
RenanVilela
Sam_2004
Sam_2004
WestonB
WestonB
xapim
xapim
zakblayde
zakblayde
+1.4K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1728

Total Points:5367

Total Accepted Answers: 204

Leostat Community Aficionado