Immediate shutdown when charger disconnected (E5-575)

Options
djw1674
djw1674 Member Posts: 11

Tinkerer

edited October 2023 in 2020 Archives
My Aspie E5-575 dies instantly when the charger is disconnected.....even though the battery level shows 98% available. Anyone have any suggestions what my problem might be? I usually leave the charger connected, but occasionally unplug and run on battery power just to make sure it's still available if I need it.

Best Answer

  • StevenGen
    StevenGen ACE Posts: 10,342 Trailblazer
    edited December 2020 Answer ✓
    Options
    djw1674 said:
    My Aspie E5-575 dies instantly when the charger is disconnected.....even though the battery level shows 98% available. Anyone have any suggestions what my problem might be? I usually leave the charger connected, but occasionally unplug and run on battery power just to make sure it's still available if I need it.
    Is the battery the OEM battery or have you replaced it? As the battery and/or the plug from the battery to the mobo could have corrosion or its not making perfect contact. Take the battery out, check its voltage and its plug and clean the plug and reseat it properly and try that.


    Check this plug 

Answers

  • StevenGen
    StevenGen ACE Posts: 10,342 Trailblazer
    edited December 2020 Answer ✓
    Options
    djw1674 said:
    My Aspie E5-575 dies instantly when the charger is disconnected.....even though the battery level shows 98% available. Anyone have any suggestions what my problem might be? I usually leave the charger connected, but occasionally unplug and run on battery power just to make sure it's still available if I need it.
    Is the battery the OEM battery or have you replaced it? As the battery and/or the plug from the battery to the mobo could have corrosion or its not making perfect contact. Take the battery out, check its voltage and its plug and clean the plug and reseat it properly and try that.


    Check this plug 
  • djw1674
    djw1674 Member Posts: 11

    Tinkerer

    edited December 2020
    Options
    StevenGen said:
    djw1674 said:
    My Aspie E5-575 dies instantly when the charger is disconnected.....even though the battery level shows 98% available. Anyone have any suggestions what my problem might be? I usually leave the charger connected, but occasionally unplug and run on battery power just to make sure it's still available if I need it.
    Is the battery the OEM battery or have you replaced it? As the battery and/or the plug from the battery to the mobo could have corrosion or its not making perfect contact. Take the battery out, check its voltage and its plug and clean the plug and reseat it properly and try that.


    Check this plug 
    Original battery from 2016. Finally got the bottom off the case and check the plug. Everything looked fine. No corrosion. Plugged it back in and closed everything up. Booted right up on battery power! Guess it just needed to renew it's connection. Think I'll let it run down before I plug the charger back in.
    Appreciate your help StevenGen!! 
  • DiogoCarvalho
    DiogoCarvalho Member Posts: 1 New User
    Options
    djw1674 said:
    StevenGen said:
    djw1674 said:
    My Aspie E5-575 dies instantly when the charger is disconnected.....even though the battery level shows 98% available. Anyone have any suggestions what my problem might be? I usually leave the charger connected, but occasionally unplug and run on battery power just to make sure it's still available if I need it.
    Is the battery the OEM battery or have you replaced it? As the battery and/or the plug from the battery to the mobo could have corrosion or its not making perfect contact. Take the battery out, check its voltage and its plug and clean the plug and reseat it properly and try that.


    Check this plug 
    Original battery from 2016. Finally got the bottom off the case and check the plug. Everything looked fine. No corrosion. Plugged it back in and closed everything up. Booted right up on battery power! Guess it just needed to renew it's connection. Think I'll let it run down before I plug the charger back in.
    Appreciate your help StevenGen!! 
    Hi, i had the same problem 2 days ago and i did what StevenGen suggested because i thougth that myself, but today it came back to that. Did your problem ever turned back again??
    Other thing, can u confirm the volts and Wh of your battery? idk if mines original and i want to buy a new one.
  • djw1674
    djw1674 Member Posts: 11

    Tinkerer

    Options
    The problem has not returned....knock on wood. I didn't check the voltage or capacity when I had the case open. Sorry. Post your specific model info and I'm sure someone here can point you in the right direction for a replacement battery.