Acer Chromebook Spin 11 CP311 Touchscreen won't work

gmmillergmmiller Member Posts: 5 New User
edited November 2020 in Chromebooks
Hello, we purchased an Acer Chromebook Spin 11 CP3111HNC2DV 116 Refurbished NXGVFAA001 from Staples a few months ago. It has been working like new, except that suddenly the touchscreen will only respond to the stylus (which works perfectly), but it will NOT respond to fingers at all. The screen is "Antimicrobial Corning Gorilla Glass."

__We cleaned the screen
__It is completely updated/restarted 
__We switched modes and the touchscreen does not work with fingers at all, flipped in tablet mode or in the regular laptop mode, but stylus works in both.
__We have a tried a powerwash using "Press and hold Ctrl + Alt + Shift + r"
__We have tried putting the chromebook on the debugging channel to toggle the touchscreen back on using Search+Shift+t.
__We have tried a hardware rest using "Press and hold Refresh + tap Power"

Any other suggestions? Would replacing the screen or another item solve this? Thanks!

FAQ & Answers

  • gmmillergmmiller Member Posts: 5 New User
    We also did a full recovery of chrome now. 
  • billseybillsey ACE Posts: 26,229 Trailblazer
    Do you know which CP311 model you have? It should be something like CP311-xxN-xxxx...
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • jakecolajakecola Member Posts: 8

    Tinkerer

    I am also having the same issue, so if anyone has suggestions I'd be happy to hear them.

    I've done a full Chrome OS recovery and checked the settings to make sure the touch screen wasn't toggled off with a keystroke combination. I've also opened up the back and disconnected the battery, held down the power button for 30 seconds, and then reconnected the battery. Touch screen does not work in either clamshell or tablet mode. My Chromebook is an Acer CP311 Spin, CP311-1HN-C2DV manufactured in 2019.

  • billseybillsey ACE Posts: 26,229 Trailblazer
    edited October 2022

    Just in case it's been disabled rather than actually not working, you can go through a few hoops to enable or disable:

    Go to chrome://flags/

    Enable debugging keyboard shortcuts (a reboot will be required)

    You should then be able to toggle with the search-shift-t key combination

    If that doesn't toggle it on then there is likely a hardware issue. :(

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
Sign In or Register to comment.

Who's Online1.6K

BayZ
BayZ
chugzilla
chugzilla
Hosoo
Hosoo
Majekaz
Majekaz
Nailaspire7
Nailaspire7
ryljay
ryljay
StevenGen
StevenGen
+1.6K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers