Wifi disconnects randomly Predator Helios 300

Options
Chelbel
Chelbel Member Posts: 3 New User
edited November 2023 in 2020 Archives
I got my Predator Helios 300 a month ago, and almost since the first day I've had this issue where my Wifi connection just randomly disconnects. This has never happened before with any other product that is connected to our network. There is no error message that pops up, it just disconnects and takes another minute or two before it is able to reconnect again. This is driving me up the wall and I have no idea how to fix it. Please help! Attached is a picture of what my wifi looks like when it disconnects.
 

Answers

  • sri369
    sri369 ACE Posts: 2,623 Pathfinder
    Options
    Is your laptop connecting to other wifi networks?
    Karma...
    LIKE - if helpful
    ACCEPT - if helped resolve
    ---------
    Nitro 7 - AN715-51 - user benchmark: https://www.userbenchmark.com/UserRun/37631045
  • StevenGen
    StevenGen ACE Posts: 10,300 Trailblazer
    edited April 2020
    Options
    Firstly and its a bit hard to give you any advice if you don't give us the exact model of your Predator Helios 300 and better still, the WiFi/BT card model! 

    Do this first > press the F3 key or the Fn and F3 keys together, and see if that activates your WiFi/BT when its disconnected? If not go to Device Manager > Network adapters and uninstall the WiFi driver try to just reboot and see if that fixes this issue? If it does not, download the WiFi/BT drivers from the Acer site and uninstall both WiFi/BT drivers completley (in Device Manager) and reinstall the new WiFi/BT drivers again and reboot, this should fix your problem!
  • Chelbel
    Chelbel Member Posts: 3 New User
    Options
    sri369 said:
    Is your laptop connecting to other wifi networks?
    Nope, just completely disconnecting. 
  • Chelbel
    Chelbel Member Posts: 3 New User
    Options
    StevenGen said:
    Firstly and its a bit hard to give you any advice if you don't give us the exact model of your Predator Helios 300 and better still, the WiFi/BT card model! 

    Do this first > press the F3 key or the Fn and F3 keys together, and see if that activates your WiFi/BT when its disconnected? If not go to Device Manager > Network adapters and uninstall the WiFi driver try to just reboot and see if that fixes this issue? If it does not, download the WiFi/BT drivers from the Acer site and uninstall both WiFi/BT drivers completley (in Device Manager) and reinstall the new WiFi/BT drivers again and reboot, this should fix your problem!
    Ah sorry! I haven't really done this before :s
    System Model Predator PH315-52
    I think this is the WiFi card?? Killer(R) Wi-Fi AX 1650x 160MHz Wireless Network Adapter (200NGW)

    I'll try what you suggested next time! 

  • GAMING6698
    GAMING6698 ACE Posts: 6,470 Pathfinder
    Options
    @Chelbel
    1)go to device manager →expand network adapters →right click on your killer wireless driver then click on uninstall driver then restart your system.
    After restart again go to device manager now again right click on killer wireless network then click on update driver.it will update if available.

    Now again right click on killer wireless driver go to properties then click on power management tab and uncheck the setting called allow the computer to turn off this device to save power then ok.

    windows 10/11 optimization guide for gaming 
    Windows 10/11 optimization guide for gaming — Acer Community

    My AN515-43 laptop UserBenchmark-
    https://www.userbenchmark.com/UserRun/51514566
  • askevv
    askevv Member Posts: 5

    Tinkerer

    Options
    Chelbel said:
    I got my Predator Helios 300 a month ago, and almost since the first day I've had this issue where my Wifi connection just randomly disconnects. This has never happened before with any other product that is connected to our network. There is no error message that pops up, it just disconnects and takes another minute or two before it is able to reconnect again. This is driving me up the wall and I have no idea how to fix it. Please help! Attached is a picture of what my wifi looks like when it disconnects.
     
    https://www.youtube.com/watch?v=frYWkIOCOlM&t=190s

    This video helped me with Solution 2. Hope it helps you too!
  • Icenhart
    Icenhart Member Posts: 3 New User
    Options
    Chelbel said:
    I got my Predator Helios 300 a month ago, and almost since the first day I've had this issue where my Wifi connection just randomly disconnects. This has never happened before with any other product that is connected to our network. There is no error message that pops up, it just disconnects and takes another minute or two before it is able to reconnect again. This is driving me up the wall and I have no idea how to fix it. Please help! Attached is a picture of what my wifi looks like when it disconnects.
     
    Did you manage to solve this issue? I am also having the same problem on my Helios 300.