Examples: Monday, today, last week, Mar 26, 3/26/04

No access to internal SSD, when outside Win10 on an Acer Swift 5 SF514-54T

I have a brand new Acer Swift 5.
I need to install a second OS (linux). 
I have a SSD as C: in Win10.

I try to access the SSD when booting a USB live with Kubuntu18.03, but the SSD does not appear in the command line by the df command. 
I only see the USB drive and other external drives.

The same thing happens when i try to backup the whole SSD drive via Clonezilla(on USB live). 
The internal SSD does not appear there either.

I have entered a Supervisor password.
I have disabled Secure boot, to be able to boot a live USB.
I have tried both enabled and disabled TPM(TCM) state in bios.

So how can I access the internal SSD outside Win10?

i7-1065G7
Bios version 1.02 InsydeH20
Gop Version Intel(R)GOP Driver[14.0.1023]
SSD(WDC PC SDAPNUW-512G1014) 512GB
16GB 
Serial No/product no NXHHYED001
Product name Swift SF514-54T
W10 home.

Best Answer

  • JackEJackE Posts: 18,084 Trailblazer
    Accepted Answer
    Yes leave in AHCI mode. Did you put isos on GPT partition FAT32 format USBs for UEFI bootstrap or Legacy BIOS using Rufus? Jack E/NJ  

FAQ & Answers

  • JackEJackE Posts: 18,084ACE Trailblazer
    Please check what SATA modes are set in BIOS information and main tabs. Jack E/NJ
  • Kristian_AKristian_A Posts: 4Member New User
    Thank for your answer.
    Original settings was
    Bios Information tab: 
    Sata mode: Optane without RAID

    Bios Main tab:
    Sata mode: Optane without RAID

    I tried ACHI mode, but it gave basically the same result. The main SSD(512GB) is missing when running:
    -Kubuntu installer on USB Live
    -Clonezilla on USB live
    - Kubuntu live on USB.

    I have tried different Linux commands: df, lshw, fdisk -l and they all confims no detection of the internal SSD.

    But the internal SSD works well inside Win10

  • JackEJackE Posts: 18,084ACE Trailblazer
    Accepted Answer
    Yes leave in AHCI mode. Did you put isos on GPT partition FAT32 format USBs for UEFI bootstrap or Legacy BIOS using Rufus? Jack E/NJ  
  • Kristian_AKristian_A Posts: 4Member New User
    JackE, Thank you very much. It made the trick!!!
    Lessons learned for USB Live use:
    use Rufus 3.8 + GPT + UEFI(non CSM = non legacy) settings.
    use BIOS SATA mode="ACHI" in Laptop(InsydeH2O BIOS)

    Win10 needs Laptop Bios SATA mode ="Optane without RAID" to boot properly into Win10.



  • JackEJackE Posts: 18,084ACE Trailblazer
    Congrats. Optane memory should be semi-useful with a mechanical drive, and fairly useless with a SSD. Your Win10 setup probably was also used for machines with mechanical drive. Jack E/NJ   
  • thermatherma Posts: 1Member New User
    Hi Kristian,

    Just got my Acer Swift 5 and got same issue installing Ubuntu: SDD is not visible.

    May I ask you how you changed Optane for AHCI?
    I don't see any modifiable parameter for that in the BIOS.

    Following screenshots of my bios







  • Kristian_AKristian_A Posts: 4Member New User
    HI thema, see pcs for my bios settings.
    I see the SSDs are different.
    I have a bootable USB attached. It is prepared as described above.
    I see you are missing the Sata mode in the Main tab.
    The Bios and the GOP version are different.
    I don't know if the Intel VTX does matter in the Advanced tab.
    I do not understand your computers behaviour.
    /Kristian_A


  • Press ctrl+s in main tab @therma
    Oi! Eu não sou sou a cortana! Mas estou aqui para ajudar! Hi! I'm not the cortana! But I'm here to help!
    Se você gostou da minha resposta, marque como solução clicando em sim! If you liked my answer, mark it as a solution by clicking on yes!
    Aceite somente a resposta que ajudou a solucionar o seu problema! Please accept only the response that helped to solve your problem!
    Detection tool click here to find the serial number or partnumber of your model!                                                          

               
      egydiocoelho Trailblazer
     
    ProductKey clique aqui para descobrir o serial do windows! click here to discover the windows serial!
    Para usuários da comunidade inglesa, espanhola, francesa e alemã, usarei o google tradutor! :)
    For users of the English, Spanish, French and German community, I will be using google translator! :) 
Sign In or Register to comment.

Who's Online145

145 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.