Examples: Monday, today, last week, Mar 26, 3/26/04

Acer E380 android upgrade

Jon1001Jon1001 Posts: 2Member New User
My E380 has Android 4.2.2, I need to upgrade Android. When I use the Acer Live updater, I get the message 'failed to update due to network or server problem', even though I have internet connection.
So I went to the Acer download area, followed the instructions and downloaded OS_Acer_Acer.AV0K0.E380.1.004.00.EMEA.GEN1s_A44K_A on to a desktop pc.
According to the instructions, I should then run setup.exe on the pc. But there is no such file - the nearest is SetupWizard.apk.
That is an Android program.
So what should I do?
Jon

FAQ & Answers

  • Tom2019Tom2019 Posts: 228Ally
    Hi @Jon1001
    The below mentioned steps  should fix “Network error, please try again later” error.

    >>>Go to Settings > Applications > Google Drive. Here, tap on “Storage” and then tap on “Clear Data” to reset Google Drive data. 

    >>> Also, try to grant it Storage rights. Go into Settings > Apps. Click three dot menu at top right and choose System. Scroll to Acer Live Updater and grant it Storage rights. After do that run the update and works fine.

    >>>Go to Settings > Applications > Select ALL > Tap the Acer Live updater application > tap on clear data (if available) and tap on clear cache
    tap on force stop
    then go to settings/about tablet
    tap on System updates and check now

    >>> if it still crash, you can try a factory reset too (backup all your personal data first)
    Go to settings/Backup & reset - factory data reset
    Once done, don't install any application but check about updates
    then go to settings/about tablet
    tap on System updates and check now.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!
  • Jon1001Jon1001 Posts: 2Member New User
    Hi Tom

    Thanks very much for your suggestions.

    I have done a factory reset twice. The first time I did it, it asked for my Google login, which I gave. I logged in to wifi. When I tried for a system update, I got the error message. So I did a factory reset again, and this time I did not give the google login. It asked for my Acer login, which I did not have, so I skipped that. I logged in to wifi. Again, when I tried for a system update, I got the error message.

    I don't have a sim in this phone, as I just want to use it for listening to podcasts. But I can't get the BBC Sounds app, as it needs a later version of Android than the one I have. Does the lack of a sim make any difference?

    Thanks
    Jon

Sign In or Register to comment.

Who's Online in this Category0

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.