Solving the problem with Synaptics Touchpad when migrate to Windows 10 - Aspire E5

Ricardo65Br Member Posts: 2 New User
I migrate an Aspire E5-571 from W7 to W10 but  I couldn´t access the device properties to the touchpad. Installed the driver indicated on support site and nothing happens.

 As I could´t find a Driver on Synaptics, I tryed a Dell Synaptics and it works in some options. Ok! On that moment I realized that the problem wasn´t W10 or hardware.  I uninstalled the Dell driver and install the "Acer Aspire V5-472 Synaptics Touchpad Driver for Windows 10 64-bit" that can be found at "". It WORKS! But not so easy

Step by step.
1) Download the driver 
2) Uninstall any other synaptics or third parts mouse program on  Control Panel -  Programs and resource
3) boot the machine and press F2 to run Setup.  On mouse options DON´T put the Advance option. Be sure about this. Save and boot.
4) Run the instalation program from the new Driver and boot the machine.
5) You will not see any change. Don´t worry. 
6) Here comes the "magic". Open Control Panel and click on Mouse.
7) Click on Hardware -> properties ->  change configuration -> Driver -> actualize driver
8) Select the option search driver on computer -> Allow select drivers on my computer -> 
9) UNSELECT   show compatible hardware
10) Select Synaptics and model Synaptics PS/2 Port Touchpad 
11) Install and re-boot
12) open again Control Panel -> Mouse -> and you will see the Icon of Synaptics. Click on It and configure as you wish your touchpad.

Sorry for my English. My windows is in Portuguese and the options may be not exactly as I described.

Good Luck,


  • MaClane
    MaClane ACE Posts: 35,598 Trailblazer
    Good Morning Ricardo65Br !

    Excellent contribution.
    Will help users who have the same problem!

    Se minha resposta foi útil, deixe um Curtir, marque como Solucionado e clique em Promover!
    Caso contrario, fico a disposição para tentarmos sanar suas duvidas e resolver seus problemas!
    Atenciosamente:  J. MaClane™

    If my answer was helpful, leave a Like, flag as Fixed and click Promote!
    Otherwise, I am willing to try to heal your doubts and solve your problems!
    Sincerely, J. MaClane ™

    For users of the English, Spanish, French and German Community, I will be using Google Translate!
    JAGJAG Member Posts: 1 New User
    Thanks, your post helped me realize my problem. In case others have the same problem, let me share the way to try first.

    So, when I installed Win10, the touchpad worked somewhat, but didn't support two-finger-scroll or right click. Looking in the device manager I had some errors on PCI devices and no Symantec driver installed. Do you see any HID\VEN_SYNA&DEV_7DB5&Col01 - HID-compliant mouse ?

    For my Aspire E5-774G I did find drivers here:
    Installing Serial IO and Card Reader and Wireless LAN did clear the errors, but the Touchpad driver didn't make any difference.
    Under touchpad settings, nothing but sensitivity was available. I'm now guessing that installing those drivers weren't necessary 

    1) boot the machine and press F2 to run Setup. 
    b) Or rather, search for "BIOS" in start menu and select the "advanced start options" to go into UEFI settings.
    c) If you're asked for a password you don't know, give the wrong password three times and then get the correct password from
    2) In BIOS/UEFI: On touchpad options DO select the Advanced mode.
    3) Save and boot.
    4) It probably works now!
    a) open again Control Panel -> Mouse -> and maybe you won't see the Icon of Synaptics.
    b) In my case Windows chose the Windows driver (MOUHID.SYS) rather than the Synaptics one (from 2016) but probably no loss.

    This may not be the solution to the original poster, but may help others. I probably caused this myself when I changed settings to run Linux before.