PREDATOR DEN

 

Share your setup and talk about your favorite games, benchmark results, upcoming events, or anything related to Predator gaming products.

image

ThrottleStop Undervolt Profiles Pre-Made

12425262830

Comments

  • engr146engr146 Member Posts: 20 Networker
    Night & Day difference since I installed almost 2 yrs. ago playing ARMA3
  • SpybotSpybot Member Posts: 3 New User
    Hey,
    Tried the preset for i5-8300H and i have to say that i'm speechless. Geting around 70 degree celsius in Gta5 without loss of performance
    Also, having my fans maxxed out, i was getting around 99-100 degrees. So thanks alot! You should retweak them with the newer ThrrotleStop app, maybe y'all could get better results.
    Cheers!
  • xapimxapim ACE Posts: 7,176 Pathfinder
    edited January 12
    engr146 said:
    Night & Day difference since I installed almost 2 yrs. ago playing ARMA3
    Spybot said:
    Hey,
    Tried the preset for i5-8300H and i have to say that i'm speechless. Geting around 70 degree celsius in Gta5 without loss of performance
    Also, having my fans maxxed out, i was getting around 99-100 degrees. So thanks alot! You should retweak them with the newer ThrrotleStop app, maybe y'all could get better results.
    Cheers!
    Thats great to hear it works without repasting enjoy also no need for the new TS wont give u better results the new TS only added compatibility features to new cpu generations nothing else wont have any advantage over 7/8 and even 9th gen for ex :)


    https://www.userbenchmark.com/UserRun/11532543

    UserBenchmarks: Game 43%, Desk 61%, Work 40%
    CPU: Intel Core i5-7300HQ - 63.5%
    GPU: Nvidia GTX 1050-Ti (Mobile) - 41.9%
    SSD: WDC WDS200T2B0B-00YS70 2TB - 71.4%
    HDD: WD WD10SPZX-00HKTT0 1TB - 93.7%
    RAM: Kingston HyperX DDR4 2666 C15 2x16GB - 76.8%
    MBD: Acer Predator G3-572

    I'm not an Acer employee. (just here to help in the best way i can)
    If my answer fixed you issue please accept it for any other users who search for it would find it quickly thanks :)
    If you want to learn more about undervolting/optimizing windows join the Predator fb group and youtube channel:

    Owner/Admin (HOTEL HERO/Red-Sand/Opoka Opoka)
    https://www.facebook.com/groups/PredatorHelios300
    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    Acer support:
    https://www.acer.com/ac/en/US/content/service-contact
    http://www.acer.com/worldwide/support/  


  • MarkicadMarkicad Member Posts: 1 New User
    hello, anyone has a preset for i5-9300h?
  • SpybotSpybot Member Posts: 3 New User
    I see i'm having some issues running the app. Sometimes it doesn't do anything, like i see it just gets hot. 
    And when i set it to auto load on windows startup i get a blue screen with:
     How To Fix The 39Page Fault in Non-Paged Area39 BSOD In Windows 10  Tom39s  Hardware
    And basically it's stuck in a loop. I have to stop the task before it runs so i can use the laptop. 
    Do you have any ideas?
    Thanks!
  • Ezio06Ezio06 Member Posts: 3 New User
    Hello,

    I'm using PH317-53-750A with i7 9750H. When I downloaded/extracted the files and ran ThrottleStop.exe I get "Could not open WinRing0.dll" error. What am I doing wrong?


    My full specs are:

    ACER PREDATOR CORE İ7 9750H 2.6GHZ-32GB-1TB+256SSD-17.3"-RTX 2070 8GB-W10

    Thank you,
    Hey man! Can you share the ThrottleStop .rar file with me? I have the same chip but Google Drive does not let me download it again Thanks a lot man!
  • xapimxapim ACE Posts: 7,176 Pathfinder
    Ezio06 said:
    Hello,

    I'm using PH317-53-750A with i7 9750H. When I downloaded/extracted the files and ran ThrottleStop.exe I get "Could not open WinRing0.dll" error. What am I doing wrong?


    My full specs are:

    ACER PREDATOR CORE İ7 9750H 2.6GHZ-32GB-1TB+256SSD-17.3"-RTX 2070 8GB-W10

    Thank you,
    Hey man! Can you share the ThrottleStop .rar file with me? I have the same chip but Google Drive does not let me download it again Thanks a lot man!
    it's in this thread an updated working version 


    https://www.userbenchmark.com/UserRun/11532543

    UserBenchmarks: Game 43%, Desk 61%, Work 40%
    CPU: Intel Core i5-7300HQ - 63.5%
    GPU: Nvidia GTX 1050-Ti (Mobile) - 41.9%
    SSD: WDC WDS200T2B0B-00YS70 2TB - 71.4%
    HDD: WD WD10SPZX-00HKTT0 1TB - 93.7%
    RAM: Kingston HyperX DDR4 2666 C15 2x16GB - 76.8%
    MBD: Acer Predator G3-572

    I'm not an Acer employee. (just here to help in the best way i can)
    If my answer fixed you issue please accept it for any other users who search for it would find it quickly thanks :)
    If you want to learn more about undervolting/optimizing windows join the Predator fb group and youtube channel:

    Owner/Admin (HOTEL HERO/Red-Sand/Opoka Opoka)
    https://www.facebook.com/groups/PredatorHelios300
    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    Acer support:
    https://www.acer.com/ac/en/US/content/service-contact
    http://www.acer.com/worldwide/support/  


  • Ezio06Ezio06 Member Posts: 3 New User
    xapim said:
    Ezio06 said:
    Hello,

    I'm using PH317-53-750A with i7 9750H. When I downloaded/extracted the files and ran ThrottleStop.exe I get "Could not open WinRing0.dll" error. What am I doing wrong?


    My full specs are:

    ACER PREDATOR CORE İ7 9750H 2.6GHZ-32GB-1TB+256SSD-17.3"-RTX 2070 8GB-W10

    Thank you,
    Hey man! Can you share the ThrottleStop .rar file with me? I have the same chip but Google Drive does not let me download it again Thanks a lot man!
    it's in this thread an updated working version 
    Hey! I tried running that but the thermals still seem to be on the higher side. We are just siupposed to extract it to our My Documents folder and run the .exe, that's it, right?
    I'm new to this so I am not aware if we have to do anything else.
  • Ezio06Ezio06 Member Posts: 3 New User
    Ezio06 said:
    xapim said:
    Ezio06 said:
    Hello,

    I'm using PH317-53-750A with i7 9750H. When I downloaded/extracted the files and ran ThrottleStop.exe I get "Could not open WinRing0.dll" error. What am I doing wrong?


    My full specs are:

    ACER PREDATOR CORE İ7 9750H 2.6GHZ-32GB-1TB+256SSD-17.3"-RTX 2070 8GB-W10

    Thank you,
    Hey man! Can you share the ThrottleStop .rar file with me? I have the same chip but Google Drive does not let me download it again Thanks a lot man!
    it's in this thread an updated working version 
    Hey! I tried running that but the thermals still seem to be on the higher side. We are just supposed to extract it to our My Documents folder and run the .exe, that's it, right?
    I'm new to this so I am not aware if we have to do anything else.
    supposed*
  • SpybotSpybot Member Posts: 3 New User
    Spybot said:
    I see i'm having some issues running the app. Sometimes it doesn't do anything, like i see it just gets hot. 
    And when i set it to auto load on windows startup i get a blue screen with:
     How To Fix The 39Page Fault in Non-Paged Area39 BSOD In Windows 10  Tom39s  Hardware
    And basically it's stuck in a loop. I have to stop the task before it runs so i can use the laptop. 
    Do you have any ideas?
    Thanks!
    Hello,
    Finally found out that throttlestop won't work anymore on Windows11 if you have Hyper-V and some other configs enabled on your system.
    I found out PowerMonkey but it's kinda hard to config. 
    Hope this information is going to help someone out
  • jelogamingjelogaming Member Posts: 1 New User
    Is there a new link for the i7 9750H? I cant seem to access the orig one (pic of the issue below).


  • HumanitarianGrenaidHumanitarianGrenaid Member Posts: 2 New User
    My dear sir, this is magic.
    You shaved off more than ten degrees for the GPU and CPU temps without any significant drop in percentage utilisation(as shown by Nitrosense).
  • WhoIsJimmyWhoIsJimmy Member Posts: 5

    Tinkerer

    Hey I have the predator helios 300 PH 317 52 and i was using the i8750h throttlestop link and it was working for me to stop overheating but after a few days it just crashes the laptop (BSOD) when i try to open throttle stop. To fix this i go to bios and setup default. Then i can open throttlestop again but eventually it will start giving me BSOD again. Throttlestop can help me with overheating issues but it also makes games like SkaterXL and Forza Horizon 5 sutter badly and i know its throttle stop because as soon as i close the program the stuttering goes away and game plays smooth until it overheats and thermal throttles... The battery will also drain when im playing games and its plugged in.. Keep in mind i get same results with games graphics are on high or low.

    I have tried dropping the offset voltage on Intel XTU -140 but it doesnt seem to be working as the laptop still overheats. I hit apply, am i doing something wrong?
    HWMonitor is showing that i have a -0.143 voltage even when i dont have intel XTU or throttlestop or any undervolt program running. I do not have predator sense installed on my laptop but from what ive read on these threads the laptop comes undervolted already? thats why i am seeing it HWMonitor at -143?
    When using throttlestop my temps were low 70s but without it, it pushes into the 90s and thermal throttles and has done this since i first bought it back in 2018...


    Anyways TL/DR  Basically i want to know what to do so i can play games without overheating, without BSOD and without stuttering lol. Throttlestop helps my overheating problem but seems to cause certain games to stutter. Intel XTU im trying to figure out. I copy the same settings from throttlestop to intel XTU but dont get the same temp results.

    If anyone has a Intel XTU undervolt profile for i8750h or a screenshot of the numbers to input itd be greatly appreciated. Thanks for any help



  • xapimxapim ACE Posts: 7,176 Pathfinder
    edited February 7
    WhoIsJimmy if its crashing its probably too much undervolt (silicone lottery) reduce it see if it stops crashing and check the bsod errors with bluescreenviewer might not even be TS causing it there are only 2/3 bsod errors that are caused by TS also xtu its garbage you would be probably better cleaning it properly and repasting it with kryonaout or similar as you can di it yourself  as im assuming your warranty its long gone by now  as its an 8th gen cpu also only the 2019 predators came factory pre undervolted not the older 2017/18 good luck :)


    https://www.userbenchmark.com/UserRun/11532543

    UserBenchmarks: Game 43%, Desk 61%, Work 40%
    CPU: Intel Core i5-7300HQ - 63.5%
    GPU: Nvidia GTX 1050-Ti (Mobile) - 41.9%
    SSD: WDC WDS200T2B0B-00YS70 2TB - 71.4%
    HDD: WD WD10SPZX-00HKTT0 1TB - 93.7%
    RAM: Kingston HyperX DDR4 2666 C15 2x16GB - 76.8%
    MBD: Acer Predator G3-572

    I'm not an Acer employee. (just here to help in the best way i can)
    If my answer fixed you issue please accept it for any other users who search for it would find it quickly thanks :)
    If you want to learn more about undervolting/optimizing windows join the Predator fb group and youtube channel:

    Owner/Admin (HOTEL HERO/Red-Sand/Opoka Opoka)
    https://www.facebook.com/groups/PredatorHelios300
    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    Acer support:
    https://www.acer.com/ac/en/US/content/service-contact
    http://www.acer.com/worldwide/support/  


  • WhoIsJimmyWhoIsJimmy Member Posts: 5

    Tinkerer

    @xapim Hey thanks for quick reply, do u have a trick for getting it open easy last time i opened it it was so stiff i accidently cracked a piece of plastic on the piece u pull off. lol whoops. Also i deleted and reinstalled throttle stop, reset the bios to default, the profile for the i8750h that i downloaded from OP would show up that  IA Offset -.123, GT Offset -.052, LLC -.123 and system agent offset -.072 were all being undervolted. After reinstalling i undervolted it putting in the numbers myself this time and only the IA offset and the LLC are showing up in hwMonitor being undervolted now and it doesnt crash anymore, temps are low around 70-80 it seems to be working and even games that were stuttering like skaterXL dont seem to be anymore. Getting good 120fps playing skaterXL and Mass Effect Legendary Edition but NOW my issue is the battery is draining while its plugged in lol. Its fine at first but if battery drops low enough u see it start to effect performance. I updated the bios before all this to the most recent to see if that would fix the blue screens it didnt, i dunno if that would have any effect? Its popping up in red letters POWER next to where it says Prochot 95 on TS now ive never seen it do that before i googled it and it says its power throttling? task manager says nothing is power throttling so im a little confused. I can also hear a clicking noising coming from inside the laptop i dunno if im just paranoid now and it always made that noise or if its related but every couple seconds i hear a loud click inside laptop.
    Ill attach a photo thats got my TS settings so you can see the offset voltage and the turbo ratio limits and what not that i have set up
    TL/DR TS seems to being working now with the settings i put in i got low temps and good performance but my battery is draining while plugged in playing games. Its weird becuz sometimes i think the laptop has a mind of its own haha itll work amazing for week or so then something happens or changes and it blue screens or performance drops but thanks so much for any help appreciate you taking the time!
  • xapimxapim ACE Posts: 7,176 Pathfinder
    edited February 8
    @xapim Hey thanks for quick reply, do u have a trick for getting it open easy last time i opened it it was so stiff i accidently cracked a piece of plastic on the piece u pull off. lol whoops. Also i deleted and reinstalled throttle stop, reset the bios to default, the profile for the i8750h that i downloaded from OP would show up that  IA Offset -.123, GT Offset -.052, LLC -.123 and system agent offset -.072 were all being undervolted. After reinstalling i undervolted it putting in the numbers myself this time and only the IA offset and the LLC are showing up in hwMonitor being undervolted now and it doesnt crash anymore, temps are low around 70-80 it seems to be working and even games that were stuttering like skaterXL dont seem to be anymore. Getting good 120fps playing skaterXL and Mass Effect Legendary Edition but NOW my issue is the battery is draining while its plugged in lol. Its fine at first but if battery drops low enough u see it start to effect performance. I updated the bios before all this to the most recent to see if that would fix the blue screens it didnt, i dunno if that would have any effect? Its popping up in red letters POWER next to where it says Prochot 95 on TS now ive never seen it do that before i googled it and it says its power throttling? task manager says nothing is power throttling so im a little confused. I can also hear a clicking noising coming from inside the laptop i dunno if im just paranoid now and it always made that noise or if its related but every couple seconds i hear a loud click inside laptop.
    Ill attach a photo thats got my TS settings so you can see the offset voltage and the turbo ratio limits and what not that i have set up
    TL/DR TS seems to being working now with the settings i put in i got low temps and good performance but my battery is draining while plugged in playing games. Its weird becuz sometimes i think the laptop has a mind of its own haha itll work amazing for week or so then something happens or changes and it blue screens or performance drops but thanks so much for any help appreciate you taking the time!

    WhoIsJimmy your TS its not even turned on ??? by the pic you have posted or  have u turned it off on purpose  also in order to open it to clean it/repaste etc you need to get some pry tools and a good kit with all the proper screw drivers i recommend probably i fix it if your in the US/CA (think they will also ship worldwide) but if your temps are fine by just undervolting it i would just clean the fans and exit airflow for now and make sure you lift the back 2/3" for a proper airflow either way its up to you  regarding the battery draining its normal when gaming for a long period of time as the battery main purpose its to aid teh adapter with more power when this one cant provide enough but you can check your battery wear with hwinfo or battery bar pro if more than 15/20% consider replacing it as its faulty the cells arent holding the designed charge anymore also if the battery drops under 40% the adapter will automatically try to regharge it and you will loose all performance at this point you need to stop whatever youre doing and let it recharge you can also try a battery powerdrain followed by a bios setup defaults  and recalibrate it let it discharge completely and recharge (powered off) repeat the process 3 times for a proper calibration but if the cells are damaged theres no point only a new one  good luck :) 

    I have one of these

    https://www.amazon.com/MMOBIEL-Professional-Precision-Screwdriver-Extension/dp/B01BNNBE2A?th=1

    but you can get one with everything including pry tools or buy the pry tools in separate 

    https://www.amazon.com/XOOL-Screwdriver-Insulation-Professional-Electronics/dp/B08GPMM3JP


    https://www.userbenchmark.com/UserRun/11532543

    UserBenchmarks: Game 43%, Desk 61%, Work 40%
    CPU: Intel Core i5-7300HQ - 63.5%
    GPU: Nvidia GTX 1050-Ti (Mobile) - 41.9%
    SSD: WDC WDS200T2B0B-00YS70 2TB - 71.4%
    HDD: WD WD10SPZX-00HKTT0 1TB - 93.7%
    RAM: Kingston HyperX DDR4 2666 C15 2x16GB - 76.8%
    MBD: Acer Predator G3-572

    I'm not an Acer employee. (just here to help in the best way i can)
    If my answer fixed you issue please accept it for any other users who search for it would find it quickly thanks :)
    If you want to learn more about undervolting/optimizing windows join the Predator fb group and youtube channel:

    Owner/Admin (HOTEL HERO/Red-Sand/Opoka Opoka)
    https://www.facebook.com/groups/PredatorHelios300
    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    Acer support:
    https://www.acer.com/ac/en/US/content/service-contact
    http://www.acer.com/worldwide/support/  


  • WhoIsJimmyWhoIsJimmy Member Posts: 5

    Tinkerer

    @xapim used snipping tool to put everything on the pic, its just not turned on in the picture i normally turn it on but ive also noticed TS seems to work even if i dont press the turn on button or at least i think it does because it shows up as undervolted in the hwMonitor and my temps stay down even when I dont click the turn on button. Should it just show up as IA offset and LLC that are undervolted or should GT offset and system agent offset be below 0 aswell? And do u kno why my battery is draining while im playing or if its related to how i undervolted it? its the ADP180 charger so im assuming thats not the issue? Im using the newest version of throttlestop 9.4 not the beta.
    Thanks again appreciate your time
  • xapimxapim ACE Posts: 7,176 Pathfinder
    edited February 8
    @xapim used snipping tool to put everything on the pic, its just not turned on in the picture i normally turn it on but ive also noticed TS seems to work even if i dont press the turn on button or at least i think it does because it shows up as undervolted in the hwMonitor and my temps stay down even when I dont click the turn on button. Should it just show up as IA offset and LLC that are undervolted or should GT offset and system agent offset be below 0 aswell? And do u kno why my battery is draining while im playing or if its related to how i undervolted it? its the ADP180 charger so im assuming thats not the issue? Im using the newest version of throttlestop 9.4 not the beta.
    Thanks again appreciate your time
    WhoIsJimmy you need to undervolt the IGPU also no need to use the latest TS the old ones work fine you laptops its form 2018 the new TS was designed for the latest cpus nothing new for yours and as i mentioned above check your battery wear

    these are my settings on the aspire 5 10th gen



    An these are on my G3-572








    https://www.userbenchmark.com/UserRun/11532543

    UserBenchmarks: Game 43%, Desk 61%, Work 40%
    CPU: Intel Core i5-7300HQ - 63.5%
    GPU: Nvidia GTX 1050-Ti (Mobile) - 41.9%
    SSD: WDC WDS200T2B0B-00YS70 2TB - 71.4%
    HDD: WD WD10SPZX-00HKTT0 1TB - 93.7%
    RAM: Kingston HyperX DDR4 2666 C15 2x16GB - 76.8%
    MBD: Acer Predator G3-572

    I'm not an Acer employee. (just here to help in the best way i can)
    If my answer fixed you issue please accept it for any other users who search for it would find it quickly thanks :)
    If you want to learn more about undervolting/optimizing windows join the Predator fb group and youtube channel:

    Owner/Admin (HOTEL HERO/Red-Sand/Opoka Opoka)
    https://www.facebook.com/groups/PredatorHelios300
    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    Acer support:
    https://www.acer.com/ac/en/US/content/service-contact
    http://www.acer.com/worldwide/support/  


  • WhoIsJimmyWhoIsJimmy Member Posts: 5

    Tinkerer

    @xapim battery wear is at 75% i never knew u could check that interesting, is 75% bad? also My mistake i know im suppose to undervolt the intel GPU but i completely forgot to do it lol, would that be why my battery is draining? going to test it now thanks boss
  • WhoIsJimmyWhoIsJimmy Member Posts: 5

    Tinkerer

    @xapim on hwMonitor it says 25%. so is my battery 3/4 wear or only a 1/4 wear? Seems to be working better tho im gna stress test with a few more demanding games leave it on for couple hours see if the battery drains. thanks so much for your time and help @xapim i owe u a beer!
Sign In or Register to comment.

Who's Online1.6K

Acer-Monica
Acer-Monica
ArnLay67
ArnLay67
Benkij
Benkij
bet3
bet3
billsey
billsey
BND
BND
Dipson
Dipson
egydiocoelho
egydiocoelho
EllyElenna
EllyElenna
EvidentRecker
EvidentRecker
IbrahimJibril
IbrahimJibril
ircop37
ircop37
JackE
JackE
JayWalkerLeo
JayWalkerLeo
Jose_Manuel
Jose_Manuel
LinkSlotGacor
LinkSlotGacor
magi605
magi605
Mikarch
Mikarch
milsabords
milsabords
ReecerPeecer833
ReecerPeecer833
RenanVilela
RenanVilela
Rickodain
Rickodain
sanusaj007
sanusaj007
theeldestgeek
theeldestgeek
+1.6K Guests