Examples: Monday, today, last week, Mar 26, 3/26/04

Cellular modem detects SIM, accepts APN information, but reports "no service" Swift 3 SF313-51

msalsburymsalsbury Posts: 3Member New User
I recently purchased an Acer Swift 3 SF313-51 with built-in cellular modem.  I fired it up and it spend hours doing updates.  When it finally finished, I shut it down and popped in a SIM card for my Google Fi cellular account. 

The SIM had been working in an Android device in the same physical location.  In the Swift 3, Windows 10 reports that it's connected to T-Mobile but also shows "No service" below that, so it would seem that Windows 10 is seeing the cellular modem and the SIM card, and talking to the SIM enough to be able to recognize that it's on T-Mobile (Google Fi leverages T-Mobile and other networks).  

I thought perhaps it was missing APN information for Fi, so I added that to the Windows 10 settings using the same info I've used for Android devices.  This did not change anything.  Windows 10 still reports "No service".

Elsewhere online, I've seen people report that they were unable to make a cellular connection from their laptops with the built-in Windows to CDC MBIM drivers and had to revert to the drivers provided by the laptop manufacturer.  I've downloaded those drivers from Acer and tried to install them, but Windows refuses to use them, always preferring the built-in Microsoft driver over the Fibocomm driver provided by Acer.  

So far, I've tried without success:
1. Rebooting the laptop (multiple times).
2. Removing and reinsert the SIM.
3. Attempting (and failing repeatedly) to load the Fibocomm 4G drivers from the Acer support site for this model.  Windows always says it couldn't find a relevant driver or that it had a better one already.
4. Adding APN information, and when that didn't work, changing the few settings there are to see if that made a difference (e.g., IPV4 to IPV4V6).
5. Verifying that all the latest Windows updates are applied.

If anyone out there has successfully connected their Swift 3 to Google Fi, I'd appreciate some guidance...

FAQ & Answers

  • JackEJackE Posts: 17,015ACE Trailblazer
    So what suggestions or responses have you gotten so far on this issue from the t-mobile forums https://support.t-mobile.com/community/community ?

    Jack E/NJ

  • msalsburymsalsbury Posts: 3Member New User
    Since I'm not technically a T-Mobile customer but a Google Fi customer, I didn't post on their forums.  Google doesn't provide much in the way of support for devices they do not specifically sell, so I can't post there either.  Since it's an Acer product, and since the SIM card in question has worked in another device, this seemed like the right place to start. (I'm a desktop system admin by day, so I'm familiar with researching problems online.)

    The advice I've found on Internet searches in general boils down to:
    • Maybe you have a bad SIM:  This SIM works in other devices, so I tentatively rule that out.
    • Maybe the SIM socket is bad:  Since the Swift is identifying the network and signal level, that seems unlikely.
    • Maybe you need to load the specific drivers for the SIM reader in the Swift 3:  As noted above, I can't get Windows 10 to accept the drivers downloaded from Acer's support site in favor of the drivers built into Windows, so I can't confirm that this does or does not help.
    • Maybe you need to enter the APN information for Google Fi:  As noted above, I did that.  It made no difference.
    • Maybe the Acer Swift 3's 4G LTE modem can't support the bands used by Google Fi:  Based on the info available on the web, the Google Fi network supports the following bands:  B2 (1900 PCS), B4 (1700/2100 AWS 1), B12 (700 ac), B25 (1900+), B26 (850+), B41 (TD 2500), BC1 (1900 PCS), BC10 (Secondary 800 MHz).  According to CNET, the Swift 3 uses the FIBOCOM L850-GL-05 chipset.  That chipset provides support for B2, B4, B12, B26, and B41. That means it has support for nearly all the bands that Google Fi uses (it appears to lack support for B25, BC1, and BC10 but covers the rest).  So as best I can tell, its cellular modem shouldn't have much trouble finding a Fi signal or a T-Mobile signal.
    • Maybe you're in an area without coverage:  I show at least three of four bars of signal on T-Mobile/Fi networks, so it would appear that the Swift is finding a compatible frequency shared between its modem and the cellular network. My cell phone and a tablet with LTE capability are able to obtain signals in that same location. 
    So what it boils down to is that the Swift sees the SIM card. It sees the network I am trying to connect to. It's getting a signal on that network, but it's coming back as "no service"... 

    In one search I did, a forum poster with a totally different make and model of laptop reported this same kind of issue after a Windows 10 update.  In their case, they were able to correct the problem by loading the factory driver (for a totally different laptop model) instead of the Microsoft driver, and by replacing some obscure file in Windows 10 with the same file from the Windows.old directory from the previous Windows 10 update.  I haven't been able to locate that post again, and as I've said above, I cannot get Windows to load the Acer-supplied driver in place of the generic Windows driver.

    Since that makes it sound far more like an Acer driver problem than a Google Fi/T-Mobile problem, I posted here instead of somewhere else.  
  • JackEJackE Posts: 17,015ACE Trailblazer
    >>> I cannot get Windows to load the Acer-supplied driver in place of the generic Windows driver.>>>

    What link did you use to download the ACER driver that wouldn't install? Jack E/NJ
  • msalsburymsalsbury Posts: 3Member New User
    I went to the Acer web site, looked up the model number, and found the only driver available for the Fibocom LTE device.  Windows claimed that it already had a better driver than that installed and would always defer to that.

    This morning, frustrated with the whole thing, I decided to see what other laptops on the market used the same hardware.  I found a Lenovo model with the same device and tried loading their driver for it. The cellular connection completely vanished from Windows 10 at that point. Rebooting did not resolve the issue.

    I then used the Recovery feature in Windows 10 to do a clean reinstallation of Windows.  When Windows came back up after the reinstallation, suddenly the cellular connection was working and I was able to access the Internet through it.

    Interestingly, after this clean reinstall, the Device Manager shows the Fibocom L850-GL adapter now instead of the generic CDC MBIM driver it had loaded before.

    I can't tell you if perhaps the installation of that Lenovo packaged driver did anything, or if it was just the clean reinstall, but the LTE connection is working now on the Google Fi (T-Mobile MVNO) network, so all is well.

    Thanks for trying to provide some help.
  • JackEJackE Posts: 17,015ACE Trailblazer
    A Win10 update likely loaded the generic driver and screwed things up. Accordingly, make sure Control Panel's restore point app has the System Protection option turned on so you can recover from the update and temporarily hide it till a future update fixes the issue. Jack E/NJ. 
  • MangofcMangofc Posts: 1Member New User
    Yesterday i had the same problem after update windows. After contact with Acer they have send me a new driver. Problem solved!
    driver Fibocom_LTE_Driver_SF313-51
Sign In or Register to comment.

Who's Online141

Akhil_lone
Akhil_lone
aposlay
aposlay
harveyspecterseo
harveyspecterseo
Kno63
Kno63
shayan_48
shayan_48
TooQik
TooQik
Vlok
Vlok
+134 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.