Examples: Monday, today, last week, Mar 26, 3/26/04

Overdrive setting on XG270HU doesn't do anything

PoteriePoterie Posts: 1Member New User
Hi, I have an XG270HU (omidpx) with firmware version 15 05 06 -01, and the overdrive setting does absolutely nothing at all. I've tested using blurbuster's ufotest (the ghosting/pursuit camera one) as well as PixPerAn and it appears that overdrive is OFF even when set to Normal or Extreme. (using tftcentral's review's pictures as a reference: http://www.tftcentral.co.uk/reviews/acer_xg270hu.htm#response_times). I have tried using DVI, HDMI, and DisplayPort. I am using a 1080 ti so no FreeSync support, though I wish I could test with FreeSync enabled to see if overdrive is still broken.

It seems like it could be a firmware bug, does anyone else with this firmware version experience this problem? Is there any solution? I am disappointed that this feature does not work.

Thanks
Sign In or Register to comment.

Who's Online164

alienated
alienated
CassioBenati
CassioBenati
Jameshowlett
Jameshowlett
KingPanda
KingPanda
lyousy2k3
lyousy2k3
madev_sp
madev_sp
TA1b3a40
TA1b3a40
Vanildinho
Vanildinho
YerayRG
YerayRG
+155 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.