Examples: Monday, today, last week, Mar 26, 3/26/04

My laptop is at 95% charge, but when I am charging it is it showing fully charged. Please help!

neo4evrneo4evr Posts: 6Member

Tinkerer

Hi,
Today I was using my new Helios 300 laptop. When the battery depleted to 95% I tried to plug in the charger. But it is displaying "100% fully charged" and the charge indicator is blue (not charging). However, when it depleted to 94% and I tried to plug in the charger, it is charging. What might be the problem? Is this normal?

Also, after shutting down windows, when I started it after says 3 hours later, the charge indicator shows 98% available. 2% depleted just for starting windows? What is creating this problem?

I have not fully depleted the battery since first use. Should I do that?

Comments

  • sri369sri369 Posts: 1,920ACE Pathfinder
    Batteries tend to stop charging when level is between 95 n 100. Once level goes below 95, it will charge full to 100. This is cos when left, even with laptop turned off, batteries tend to be used in trickle pull their charge below 100. This kind of blocking charging between 95-100 reduces the many-a-times battery being charged situation... increasing its life.
    Karma...
    LIKE - if helpful
    ACCEPT - if helped resolve
    ---------
    I am not an Acer employee.
    Your issue could get better coverage and more answers if posted in forums than in a message to me.

    ---------
    User benchmark: https://www.userbenchmark.com/UserRun/10977437


  • xapimxapim Posts: 4,353ACE Pathfinder
    edited October 2018
    neo4evr said:
    Hi,
    Today I was using my new Helios 300 laptop. When the battery depleted to 95% I tried to plug in the charger. But it is displaying "100% fully charged" and the charge indicator is blue (not charging). However, when it depleted to 94% and I tried to plug in the charger, it is charging. What might be the problem? Is this normal?

    Also, after shutting down windows, when I started it after says 3 hours later, the charge indicator shows 98% available. 2% depleted just for starting windows? What is creating this problem?

    I have not fully depleted the battery since first use. Should I do that?
    You should let the battery discharge completely at least once every 3 months and let it recharge to full again (this if you are always on A/C like me and many)


    https://www.userbenchmark.com/UserRun/11532543

    UserBenchmarks: Game 43%, Desk 61%, Work 40%
    CPU: Intel Core i5-7300HQ - 63.5%
    GPU: Nvidia GTX 1050-Ti (Mobile) - 41.9%
    SSD: WDC WDS200T2B0B-00YS70 2TB - 71.4%
    HDD: WD WD10SPZX-00HKTT0 1TB - 93.7%
    RAM: Kingston HyperX DDR4 2666 C15 2x16GB - 76.8%
    MBD: Acer Predator G3-572

    I'm not an Acer employee. (just here to help in the best way i can)
    If my answer fixed you issue please accept it for any other users who search for it would find it quickly thanks :)
    If you want to learn more about undervolting/optimizing windows join the Predator fb group and youtube channel:

    Owner/Admin (HOTEL HERO/Red-Sand/Opoka Opoka)
    https://www.facebook.com/groups/1969145569968592/
    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    Acer support:
    https://www.acer.com/ac/en/US/content/service-contact
    http://www.acer.com/worldwide/support/  


Sign In or Register to comment.

Who's Online in this Category3

DavidM12
DavidM12
MartinJohn00001
MartinJohn00001
Shicko
Shicko

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos