Aspire 5733 - unable to change screen brightness

Options
2»

Answers

  • Commodore_1995#
    Options
    @robstopperYou can use the driverbooster program to update drivers! Make sure that in the device manager, the monitor is configured as generic pnp! Sorry for my English, so I'm the google translator!
    Oi! Eu não sou sou a cortana! Mas estou aqui para ajudar! Hi! I'm not the cortana! But I'm here to help!
    Se você gostou da minha resposta, marque como solução clicando em sim! If you liked my answer, mark it as a solution by clicking on yes!
    Aceite somente a resposta que ajudou a solucionar o seu problema! Please accept only the response that helped to solve your problem!
    Detection tool click here to find the serial number or partnumber of your model!                                                          
                                                      
                                                     egydiocoelho Trailblazer
     
    ProductKey clique aqui para descobrir o serial do windows! click here to discover the windows serial!
    Para usuários da comunidade inglesa, espanhola, francesa e alemã, usarei o google tradutor! :)
    For users of the English, Spanish, French and German community, I will be using google translator! :) 
  • JordanB
    JordanB ACE Posts: 3,729 Pathfinder
    Answer ✓
    Options
    Microsoft did release an update yesterday that supposedly fixes brightness control on some laptops.

    https://support.microsoft.com/en-us/help/4284835/windows-10-update-kb4284835
    I'm not an Acer employee.
  • Robstopper
    Robstopper Member Posts: 11 New User
    Options
    Top man, thanks Jordan, that did the trick!! All sorted, screen dims on request, and when I switch to battery from mains power
  • personsomeone
    personsomeone Member Posts: 1 New User
    Options
    I had the same issue for Acer aspire VX 15, and I managed to fix it, so I created this account to post it here
    (None of the answers above worked, also none of the answers from other forums worked, although they gave me a hint) 

    Here is what I did: 
    1. Go to the Acer driver page for my model: https://www.acer.com/ac/en/US/content/support-product/7094?b=1
    2. Download the VGA model for Intel (not Nvidia!!). 
    3. Install it, restart PC. It now works. 

    I tried the same with Nvidia drivers and also tried from their website etc., but Nvidia is a terrible company of unrivalled incompetence and so it didn't work whatsoever.