Examples: Monday, today, last week, Mar 26, 3/26/04

x34p flickering

phawkins633phawkins633 Posts: 4Member New User
I just got off the phone to Acer Technical Support. I'm awaiting a shipping label, as I am going to RMA it. Not happy. The problem is unfortunately with most X34P models. It is fine with native 100 hz. As soon as I overclock it, it starts blinking/flickering. I was in 120hz rock solid heaven for about 2 weeks. Then it just started blinking. Tried everything, from re-setting the monitor to various software configurations. Nothing worked. Gotta pack this big assed thing back up to send. I will only do this once, as I'm pretty sure it's a consistent problem, addressed ONLY on a hardware level. I'm hoping that its just a matter of a "monitor lottery", so perhaps my replacement will not flicker..not very confident however. I will follow up and let you know. And no, changing the driver to "sync" does nothing, as it is a hardware problem.

FAQ & Answers

  • KamalikaKamalika Posts: 424Ally

    Hi,

    This definitely seems to be a hardware issue. Good to know that you are sending the computer for repair. That should take care of the issue.


    If I answered your question, please mark my post "accept" to make it easier for others to find the answer!
  • phawkins633phawkins633 Posts: 4Member New User
    OK, don't know if anyone is reading this, but hrer's an update. Repair has had it for 10 days now, with no update. I chatted with the online guy, but all they can do is access the exact same status as I can online. He was apologetic, and said that they have have a lot of monitors come back and they are waiting a response from the engineers, so apparently they are having quite a flickering issue with the X34P when overclocked. I still love the monitor, and wouldn't really mind the wait, if the tech support "chat" guy was more helpful. So, we go into week 3. Including time in transit to Acer, they will soon have possession of the monitor for longer than I have...lol
  • LKNANMLLKNANML Posts: 2Member New User
    I've had mine since June 1st and last night it started flickering. In the blink of an eye I get lines across the center of the screen. It's random time wise. It does not appear to blink when booting up. Soon as win 10 starts loading it will flicker. Seems to happen more when just the desktop is up. When a game is going it will happen less often. I've tried everything. New drivers, set refresh in win, in the display, OC on off all rates, different cable, different computer, different power source. All I can say is I am extremely disappointed. Back light bleed is almost nonexistent and I had zero dead pixels. It just happened late last night so I have a few more option to try but it doesn't look good.
  • MartiMarti Posts: 1Member New User
    Hi, is there any update to this? I bought an Acer preadator x34p and Iva had it for about 2 weeks and put it in overclocked mode, now it starts with the flickering like you describe. If I turn off the overclock it works fine but its very disappointing. It should be in the marketing that you can overclock it, but only for meager 2 weeks of its lifespan lol... If this continues I hope I can return it
  • Yabafrust91Yabafrust91 Posts: 1Member New User
    edited August 2018
    I have the same flickering problem on the left half of screen when Oc'ed to 120Hz with Gsync on, but I only get flickering when a game is running below 90 fps. Between 90 and 95 fps its barely noticable or there is no flickering. Above 100 fps, no problems.
  • JosephChuJosephChu Posts: 1Member New User
    Hi, is any news from all your problem? I bought an x34p for about 1 month and put it in overclocked mode. now it starts with the flickering like all you describe. If I turn off the overclock it works fine, I am very disappointing too. I would like to return it but it seems take very very long time. Any suggest for me?
  • EAKHawkEyeEAKHawkEye Posts: 2Member New User
    I, too, would like an update on this as my issue has been ongoing since April. I'm unable to be without the monitor so I've set it to 100Hz. But waiting 1.5y and spending the extra money, I'm hoping to utilize the 120Hz.
  • Twisted3DTwisted3D Posts: 1Member New User
    OK, don't know if anyone is reading this, but hrer's an update. Repair has had it for 10 days now, with no update. I chatted with the online guy, but all they can do is access the exact same status as I can online. He was apologetic, and said that they have have a lot of monitors come back and they are waiting a response from the engineers, so apparently they are having quite a flickering issue with the X34P when overclocked. I still love the monitor, and wouldn't really mind the wait, if the tech support "chat" guy was more helpful. So, we go into week 3. Including time in transit to Acer, they will soon have possession of the monitor for longer than I have...lol
    Was this fixed? I have only just had mine for 13 days with same issue and they offered to repair it for me not that I am happy with a repair on a brand new product after less than 2 weeks but did the RMA actually repair the flicker at 120hz?
  • JeffothedonJeffothedon Posts: 3Member New User
    I have a flicker of lines across my monitor and it only happens on desktop when overclocked. There are no issues at all when gaming, I can run at 120hz with no issues. Dont know if it’s the same issue you guys are having but sounds the same. Any more news on the returned units.
  • EzzyduzzitEzzyduzzit Posts: 2Member New User
    Bough the monitor in November and just now started getting this flickering issue, do we need to RMA it?
  • JeffothedonJeffothedon Posts: 3Member New User
    I’ve dropped mine down to 115hz and all is ok, I’m going to hang on to the monitor for now as I don’t want to without the monitor then be given a reconditioned one in return. If you try this remember to reboot the monitor as indicated. I’ll post back if I get any more issues.
  • Jaydawgx7Jaydawgx7 Posts: 2Member New User
    I just got my second X34P a week and a half ago after sending my first one back for the same flickering issue... Today when I got home from work, I woke up my monitor and this new one started doing it too... I'm not sure what to do now. I feel that I've gotten lucky twice with no back light bleed or dead pixels. This monitor is way too expensive to just deal with it (since it usually stops after a few minutes), but there really aren't any other 120hz 1440 options for the ultrawide. The Alienware and the Asus use the same display, so they have the same issues. I absolutely love this monitor, I'm just afraid it'll get worse if I don't send it back again. And if I do, how many times am I going to have to send it back until I get a good one?...
  • JeffothedonJeffothedon Posts: 3Member New User
    Jaydawgx7 said:
    I just got my second X34P a week and a half ago after sending my first one back for the same flickering issue... Today when I got home from work, I woke up my monitor and this new one started doing it too... I'm not sure what to do now. I feel that I've gotten lucky twice with no back light bleed or dead pixels. This monitor is way too expensive to just deal with it (since it usually stops after a few minutes), but there really aren't any other 120hz 1440 options for the ultrawide. The Alienware and the Asus use the same display, so they have the same issues. I absolutely love this monitor, I'm just afraid it'll get worse if I don't send it back again. And if I do, how many times am I going to have to send it back until I get a good one?...
    How long did it take for you to get a new monitor from Acer. Is the issue only when it is overclocked if have you tried running at a lower hz. I have two in the house as my son has one too with no issues. Just out of curiosity what gpu do you have as this could also be driver/ hardware issues. I have tried mine on my sons computer and it has the same issue but he also has a 2080ti the same as me.
  • DevjamDevjam Posts: 1Member New User
    edited January 15
    I got the Monitor 20 days ago. Its start flickering  with 120hz OC i have changed the DP cable to different brands ( wasted more then 120 Suisse Franks ) same issue. All the suggestion with : driver update - clean install of the GPU driver - different port on the GPU - still the same issue with OC 120hz 
    I got this screen because of the 120hz and also the GPU for this resulution and Gsync. If i use 115hz its the same flickering issue. If i use 110hz it works but i dont know for how long. In additional i have a pixel issue in the middle left side of the screen i think its a dead one you can see it extremly good with a white background like in google. I have build my PC arround this Screen and the RGB but now this 2 issues on that price class!? Acer is not answering or taking position for this issue.

    I can trigger RMA over the Vendor here in Switzerland but if i get the same issue again what is the sense for the RMA? Every RMA i have to drop 10% from the price...because the Box is open. I would maybe hardly accept that 110hz or 100hz but the pixel issue ...every time i see it  => my Brain starts spinning you pay 1200 bucks for this  screen and i have a very VERY DISAPOINTING Feeling....
    Maybe there is fix with a Firmware update for the 120hz flickering issue... MAYBE but this would not fix the pixel issue  on my Brand New 1200 Bucks screen!

    Maybe one Acer Employee with the right attention will help us out here ?!
    Any Suggestion from any side ?


    Sorry for my emotion but i am really not feeling well about this screen on that price lv and such a BIG Brand and no reaction... !

    Greetings from Switzerland :) 
  • Jaydawgx7Jaydawgx7 Posts: 2Member New User
    How long did it take for you to get a new monitor from Acer. Is the issue only when it is overclocked if have you tried running at a lower hz. I have two in the house as my son has one too with no issues. Just out of curiosity what gpu do you have as this could also be driver/ hardware issues. I have tried mine on my sons computer and it has the same issue but he also has a 2080ti the same as me.
    I returned / repurchased through Amazon, so I didn't have to wait. My first monitor would flicker without OC. With the new one, it started to flicker at 120Hz, so I lowered it to 115Hz and it was fine for a couple days.  Then it started flickering at 115, so I lowered to 110. Same results. After a few days it started to flicker again, so I turned off OC. It's only been 2 days, but so far there is no flickering at 100Hz. I'm going to attempt one more return and hope for the best. I am currently running a 1080ti
Sign In or Register to comment.

Who's Online203

Acer-Manny
Acer-Manny
AChaves
AChaves
Aneiryn
Aneiryn
busybsonya
busybsonya
egydiocoelho
egydiocoelho
Hariku
Hariku
Jack22
Jack22
joydeep
joydeep
kimkarlo
kimkarlo
LegendaryAlex4
LegendaryAlex4
MaClane
MaClane
MechDragon
MechDragon
Panchojulio
Panchojulio
Psotty
Psotty
ven98
ven98
+188 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Acer Community is now available in French! We are delighted to announce the addition of French to the list of supported languages in order to reach more users and expand on our mission to break the barriers between people and technology. You can access the French community from the drop down language menu located next to your username on the top right corner.


Participez aux discussions !

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.