Examples: Monday, today, last week, Mar 26, 3/26/04

Predator Helios 300 PH317-51-779L is slow and does not run games as it should

SleikenSleiken Posts: 5Member

Tinkerer

edited April 2018 in Predator Laptops
Ok guys, so you are my last hope now i've tried a loooot of things, still the same issue
When i'm running games like ARK or PUBG i'm feeling like i'm on a GTX8XX or lower !
But i have this laptop
Acer Predator Helios 300 PH317-51-779L 17" Intel Core i7, 16 GoRAM, 1 To + SSD 256 Go, NVIDIA GeForce GTX 1060, Windows 10
I did all my drivers update, tried to touch to every nvidia control panels settings, follow the Skelomorph's advices on this forum.
But still when i'm running pubg for exemple, if i don't put the setting to very low, i'm at 40/50fps max (even on low settings, and of course it's even worse on medium, high and ultra)
Or ARK, when the put the settings on "High" (wich is recommended for GTX970) i'm still running the game at 50fps or even lower on some maps
But a game like Black Desert Online is running well on ULTRA settings, weird ? I already tried to put my games on the SSD, still the same problem
I did a benchmark test, the test is "good" : http://www.userbenchmark.com/UserRun/8103170
I also tried to verify my disks with CrystalDisk, apparently no problems.
Can you help ?






FAQ & Answers

  • Posts: 21Member Networker
    Have you tried to dedicate the game directly to the GPU? 
  • SleikenSleiken Posts: 5Member

    Tinkerer

    In the Nvidia Control Panel ?
    In the 3D settings i set "use the High Performance NVIDIA processor"
    But in the PhysX settings, laptop screen is on the Intel graphic card, impossible to change it, i don't know if this is the problem.
  • SleikenSleiken Posts: 5Member

    Tinkerer

    Anyone ? :s losing hope ^^
  • SleikenSleiken Posts: 5Member

    Tinkerer

    Well, no one can help me, so i'll just send it back, thanks anyway.
  • SkelomorphSkelomorph Posts: 463ACE Pioneer
    Sleiken said:
    Well, no one can help me, so i'll just send it back, thanks anyway.
    Well first, they never made GTX 8 series. lol.

    Second, have you tried just disabling VSync and Triple Buffering? Some/all settings differ for different games.

    As for PhysX, it has nothing to do with a laptop gaming on a single screen. Any settings you will want to pick are in Manage 3D settings. Make sure your games use the GTX 1060 are the default GPU and not the iGPU.

    Skelo
    Please quote me so I get a notification of your reply!
    If I helped you, like my post and/or select my post as 'Solved'.
    Please put your laptop model in your signature so we can know what device you have.

    Product: Acer Predator Helios 300
    Model: G3-571
    "Don't cry because its over, smile because it happened."
    - Dr. Seuss
  • SleikenSleiken Posts: 5Member

    Tinkerer

    I already did all of this stuff, changed everything it was possible to change, tried overclock, no overclock, disable triple buffering, vsync, the game uses the GPU, i know about 3D settings, did everything that i had to do, nothing. truly i tested everything, welll i guess i did ! (GTX8 series was a wink ;) ^^)
  • tolgaatolgaa Posts: 3Member New User
    hey ı ve same  predator and  ı ve same problems what u say all of them
  • yaugenkayaugenka Posts: 4Member New User
    hey I face the same problem with my Predator PH315-51. Has anyone found a solution?
  • It could be a great many things causing the game to not run optimumly.

    Could be windows background services hogging resources.
    Or a Nvidia control panel graphic setting conflicting with the games graphic setting cause the Nvidia isnt set to let 3d aplication decide.

    Even the driver version plays a role.
    I've found driver version 388.31 for all Helios 300 models gives a consistent 5-6% increase in performance.

    It's most definately a snag in a setting somewhere as I can run PUBG on all ultra except shadows on high and maintain 60-90 fps throughout my play time.
    - Hotel Hero
  • Please check out the videos on this channel. It is dedicated (currently) to the Helios 300.

    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    - Hotel Hero
  • yaugenkayaugenka Posts: 4Member New User
    edited September 2018
    https://community.acer.com/en/discussion/543534/windows-version-1803-update-problems
    Windows 10 v1803 turned to be the root of all these problems. Reverting to 1709 got things back on track.
  • yaugenkayaugenka Posts: 4Member New User
    If anyone finds out what exactly (some driver or software etc.) from the 1803 update is causing the issue please let us know.
  • bizen92bizen92 Posts: 12Member New User
    Sleiken said:
    Ok guys, so you are my last hope now i've tried a loooot of things, still the same issue
    When i'm running games like ARK or PUBG i'm feeling like i'm on a GTX8XX or lower !
    But i have this laptop
    Acer Predator Helios 300 PH317-51-779L 17" Intel Core i7, 16 GoRAM, 1 To + SSD 256 Go, NVIDIA GeForce GTX 1060, Windows 10
    I did all my drivers update, tried to touch to every nvidia control panels settings, follow the Skelomorph's advices on this forum.
    But still when i'm running pubg for exemple, if i don't put the setting to very low, i'm at 40/50fps max (even on low settings, and of course it's even worse on medium, high and ultra)
    Or ARK, when the put the settings on "High" (wich is recommended for GTX970) i'm still running the game at 50fps or even lower on some maps
    But a game like Black Desert Online is running well on ULTRA settings, weird ? I already tried to put my games on the SSD, still the same problem
    I did a benchmark test, the test is "good" : http://www.userbenchmark.com/UserRun/8103170
    I also tried to verify my disks with CrystalDisk, apparently no problems.
    Can you help ?






    i'm having the same kinds of problems. i barely reach 100 fps in dota 2 and in cs go i get 100 to 150 fps regardless of the setting level. but in fortnite i get 80- 120 fps in high settings. i have the 2018 model(gtx 1060 i7 8750h) .
    the fps i'm getting is way lower than the benchmarks. i've tried everything from updating and downgrading drivers, all nvidia settings, vsync is off and even reset my pc. running out of ideas...
  • Ashish1999Ashish1999 Posts: 1Member New User
    I was buying just few days ago predator helios 300 Nvidia GTX 1060 6G when i try to play pubg mobile emulator fps was to low not working smoothly  
  • yaugenkayaugenka Posts: 4Member New User
    edited February 4
    I was facing minor glitches when playing online games and once noticed that my hdd was doing something while I was not browsing it. Then I found out that Windows 10 OS which is installed on ssd is automatically configured to place the pagefile onto hdd instead of ssd and that was the cause of those minor gliches because hdd works considerably slower than ssd. You can reallocate the pagefile to an ssd disk via system options -> performance -> virtual memory settings to make the system work faster but WARNING: your ssd lifecycle will get reduced considerably!
  • JohnnyBravooooJohnnyBravoooo Posts: 20Member Troubleshooter
    late here but same problem except its gotten worse today, i have a helios 300 PH217-51 i7 7700HQ gtx 1060 16 g of ram 60 hz model
    fortnite, was running above 60 fps usually at 1080p but couple drops so i moved down to 1600x900 which ran good, although for €1,399 pretty ***** {building a PC soon but tempting to sell laptop as its dogshit sadly] and now it cant even run 1600x900 at 60 fps, everything at lowest settings, even put res at 470x200 not even 60 fps, and yes, i had the laptop for a whole year and a half now, [dont mean to be rude here] dont BS me with *v-sync* and is your charger plugged in, i have litarally commented on reddit, and on here so many times and have waited so many times and looked at performance videos on youtube which arnt that good and yes, i am using my GPU not my integrated graphics
    its reall frustrating, as i do not have my own income and it was my parents gift for christmas and they dont know much about PC*s so they got whatever they thaught was good
    ive seen many youtube videos of near this exact model exept with a 7700k instead, and it had a 100fps increase in fortnite [example] for a simple cpu change which i find really weird [ i understand diffrent CPU's are better at certain things like 7700K is better than a 7700HQ for gaming]
    but a 100fps increase is really weird, aswell minecraft a game i got back into, onyl runs at max 200 fps, but can go lowest to 20 when doing random stuff, and now stays at 40-80 but usually dips at 60 constantly and again dont know why
    Fallout 4, somebody with same model at medium to high settings 1080p 60+ fps constantly, me i go lowest settinsg 1080p and usually dips under 60 fps
    nobody has helped me find a problem after a year and a half of trying, this laptop even went into repair for a broken fan, [issues started when i got the laptop] and they said nothing else was wrong with it, sorry for the long post, but can somebody help with this bs, sure many other people have the same problem ;/
  • JohnnyBravooooJohnnyBravoooo Posts: 20Member Troubleshooter
    also playing mc with integrated graphics even with mods out preforms my 1060 ;/
Sign In or Register to comment.

Who's Online111

Acer-Laura
Acer-Laura
brummyfan2
brummyfan2
Hiruni
Hiruni
isilver
isilver
Laurence23
Laurence23
Lukasz369ns
Lukasz369ns
nyirishman1877
nyirishman1877
raccoonking101
raccoonking101
+103 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.