Is it possible for an acer aspire switch 10 to boot on Linux ? Aspire Switch 10 (SW5-012)

AxelotoAxeloto Member Posts: 2 New User
edited January 5 in Switch Series
Hello and thanks for reading me.
I'm trying for a long time to install Linux on my Acer Aspire Switch 10 (SW5-012), it's a 64x CPU but the UEFI is 86x (first problem) I will explain you my tries and my failures during this very long trip.
I first wanted to install Ubuntu on this laptop, if possible with windows in a dual boot but after a lot of research, I managed to install it. I could see it was installed on the HDD but it was impossible for me to boot on Ubuntu. I thought the problem came from grub because once I uninstalled Windows, the pc displayed "no bootable device". I set a password for the UEFI, I disabled the secure boot and the FTPM support, but the error was still the same. I tried to boot on the Ubuntu live USB, and when grub asked me which system should boot (Try Ubuntu, Install Ubuntu or OEM Install), I opened a grub command line. I tried to install grub on the computer but there was always an error (the shell is different from Linux's so I did not know all the commands, even though I found a list on the internet). Because I couldn't install grub from grub itself, I booted on the live USB and pressed "try ubuntu", I tried from ubuntu to install grub with a package, and commands which were always successful but I never was able to see grub on booting. I tried to add the grubia.efi file on the trusted sources on the UEFI, but it was still the same: "no bootable device". Then I cleaned the HDD and forgot all of that.
But I still really wanted to get Linux on my pc so I choose another distribution: Debian. I installed it on a USB key with another computer with Rufus and "LinuxLive USB Creator 2.9.4" when I opened the key on the Acer, I saw a file named "setup.exe", I clicked on it, it opened a website and an installer. When the short installation finished, it asked me to restart the computer and choose between "Windows" and "Debian: finish installation". When I choose windows, it boots on Windows normally. But when I choose the Debian option, the computer seems to restart, the Acer logo appears (I'm happy because I think it will work, silly me), and then a screen shows up with the following : (it may not be the real words because my computer is not in English and I'm translating, that's why I don't post any screenshots).
 Windows boot manager :
Windows were unable to boot. A recent modification of the software may be the cause of this incident. To fix the problem :
    1. Insert the windows installation disk and restart the computer.
    2. Choose language settings and select "next"
    3. Click "Repair the computer" (This is not a link...)
File : \g2ldr.mbr
State : 0xc000007b
Information : The OS could not boot because a required file is missing or contains errors.

Press the Windows button to switch to the next OS.

Now I'm starting to think we can't change the OS on this computer.
Does anyone have any ideas to fix it? I tried to contact the Acer support but they won't help me because the product is out of warranty.
Thanks, Axel.

Best Answer

  • JackEJackE ACE Posts: 25,709 Trailblazer
    Accepted Answer
    If the machine won't boot into anything right now, you can try to repair or reset the machine to factory Win10 default, then start a Linux installation again. Follow this video Jack E/NJ



    Jack E/NJ

FAQ & Answers

Sign In or Register to comment.

Who's Online1.3K

brummyfan2
brummyfan2
DS549
DS549
egydiocoelho
egydiocoelho
Fefe_du_973
Fefe_du_973
gaaragirl
gaaragirl
GreenTR2
GreenTR2
Omerlutfiunsal
Omerlutfiunsal
Pádua
Pádua
+1.3K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos