Brand New Spin 5 i5-7200 terrible download speeds

Options
chopsueycop
chopsueycop Member Posts: 6

Tinkerer

edited March 2023 in 2017 Archives
Hello all,

My brand new Spin 5 (Kabylake processor) purchased a few days ago had really slow download speeds out of the box (between 3-5 Mbps when my WiFi gets 20-30Mbps with my other devices and computers). It took over 24 hours to install a Windows 10 update.

I decided to then do a Windows 10 “Fresh Start” to wipe the computer clean of all bloatware.  This did not help.  Same problems.  I tried updating the drivers from Acer’s website.  No change.  I tried updating the Wireless LAN drivers from Windows directly.  No help.  Even downloading the drivers takes painfully long, so I haven’t downloaded others yet besides the Wireless LAN. 

Can anyone help?  I’ve tried googling and can’t find much.

Thanks,
Carl

Answers

  • jamess35
    jamess35 Member Posts: 4 New User
    Options
    Hi Carl - seems to be similar to my post on my new Acer Swift 5. My solution was in power settings - look at the advanced settings of the balanced setting or whatever it is on, try changing the wireless adapter settings to maximum performance on battery and when plugged in. Seems to have worked for me although has taken hours to work out what the problem was. 
    Good luck,
    James
  • chopsueycop
    chopsueycop Member Posts: 6

    Tinkerer

    Options
    jamess35 said:
    Hi Carl - seems to be similar to my post on my new Acer Swift 5. My solution was in power settings - look at the advanced settings of the balanced setting or whatever it is on, try changing the wireless adapter settings to maximum performance on battery and when plugged in. Seems to have worked for me although has taken hours to work out what the problem was. 
    Good luck,
    James
    James,
    Thanks for the reply and help but unfortunately I already have that set to maximum. So that’s not it. I just did another fresh start. Is it possible I just have a lemon for a network card and need to return the machine?
  • JackE
    JackE ACE Posts: 44,622 Trailblazer
    Options
    If you haven't done so already, try to reset via the cold boot method here https://www.youtube.com/watch?v=NuljT0a8F7I

    If it's still slow, then re-try James' suggestion. If still no joy, return the machine for a refund or exchange ASAP. Jack E/NJ

    Jack E/NJ

  • chopsueycop
    chopsueycop Member Posts: 6

    Tinkerer

    Options
    JackE said:
    If you haven't done so already, try to reset via the cold boot method here
    If it's still slow, then re-try James' suggestion. If still no joy, return the machine for a refund or exchange ASAP. Jack E/N

    I tried that too, Jack, thanks for the help.  It did not work.  I called Acer and they had me try a few things that didn’t work.  It looks like I will have to send in for repairs (under warranty), unless anyone has any other ideas.  Thanks.
  • JackE
    JackE ACE Posts: 44,622 Trailblazer
    Options
    >>>My brand new Spin 5 (Kabylake processor) purchased a few days ago >>>

    Return it to your store or online vendor ASAP for a refund or replacement so as to avoid the longer-wait warranty process. Jack E/NJ

    Jack E/NJ

  • chopsueycop
    chopsueycop Member Posts: 6

    Tinkerer

    Options
    JackE said:
    >>>My brand new Spin 5 (Kabylake processor) purchased a few days ago >>>

    Return it to your store or online vendor ASAP for a refund or replacement so as to avoid the longer-wait warranty process. Jack E/NJ

    Yup already working on it.

    This is so sad - I was excited about this model and it so disappointed.
  • JackE
    JackE ACE Posts: 44,622 Trailblazer
    Options
    Lemons happen. 8^( Jack E/NJ

    Jack E/NJ

  • JordanB
    JordanB ACE Posts: 3,729 Pathfinder
    Options
    @chopsueycop

    If you have Verizon FIOS, supposedly the workaround is to go in to your router settings and disable WMM.  I wouldn't automatically assume that the problem is the laptop.  I would be more inclined to think that you need to update the firmware on your wireless router......or use a different wireless router.

    Try going to a friend's house.  Or a neighbor.  Or even a coffee shop.  Try a different wireless router.

    https://www.amazon.com/Acer-Touch-Windows-Convertible-SP513-51-53FC/dp/B01NH2Z5MX
    I'm not an Acer employee.
  • chopsueycop
    chopsueycop Member Posts: 6

    Tinkerer

    Options
    JordanB said:
    @chopsueycop

    If you have Verizon FIOS, supposedly the workaround is to go in to your router settings and disable WMM.  I wouldn't automatically assume that the problem is the laptop.  I would be more inclined to think that you need to update the firmware on your wireless router......or use a different wireless router.

    Try going to a friend's house.  Or a neighbor.  Or even a coffee shop.  Try a different wireless router.

    I do have Verizon FIOS, but all of my other devices work fine with 20-30 Mbps download speeds.  Will disabling the WMM mess anything up with those?  I understand that WMM is good for streaming video.
  • JordanB
    JordanB ACE Posts: 3,729 Pathfinder
    Options
    @chopsueycop

    I think you can disable WMM on your FIOS router.  If it causes problems, then simply re-enable it.  You could also call Verizon and ask them if they have a different (newer) model of FIOS wireless router.

    You could also ask the Amazon customer in link below if he/she had any problems after disabling WMM.

    https://www.amazon.com/Acer-Touch-Windows-Convertible-SP513-51-53FC/dp/B01NH2Z5MX





    I'm not an Acer employee.