image

Can't get into BIOS after Linux install attempt

2»

FAQ & Answers

  • RigacciOrgRigacciOrg Member Posts: 2 New User
    Problem solved for me. I was lucky enough beacause the notebook is bootable in GNU/Linux and I have another identical notebook to copy the missing softare from.
    It seems that the "missing" BIOS (solid white cursor in upper-left black screen) is caused by the installation procedure I used, which wiped out all the partitions from the disk, even the first one containing the BOOT/ESP. The Debian installation just installed its boot code, into the /EFI/debian/ directory.
    From the running notebook I copied the other subdirectories: /EFI/Boot/, /EFI/Microsoft/ and /EFI/OEM/ and placed them into the BIOS-missing notebook (when booted in GNU/Linux the FAT32 partition in mounted under /boot/efi/). After that, the F2 BIOS returned operational.
    I suppose that the actually required directory is /EFI/OEM/, I suppose also that it is possibile to register Debian as a boot option, remove Microsoft Windows from boot options (it is no longer present on the hard disk) and finally enable the secure boot. But for the moment I'm happy to have F2 working and GNU/Linux bootable.
  • brothersbrothers Member Posts: 3 New User
    Have the same issue "black screen with cursor" when hit F2 to get to UEFI menu after installing Debian 10.

    I have a ACER NITRO 5 - an515-54

    I solved the problem updating the firmware ("BIOS update") to version 1.30:
    1.Add panel N156HRA-EA1 C1. 2.Fix linux sku BIOS boot up menu issue.

    You can get the update here (ONLY for an515-54):
    https://www.acer.com/ac/pt/BR/content/support-product/7964?b=1


    Hope this helps.

    Regards.

  • klausinwichainklausinwichain Member Posts: 1 Newbie
    I have just got this problem after installing XUbuntu 20.04. Sometimes I can get into bios, though. I did a fresh disk install with new efi fat sector and ext4 for Xubuntu so wiped off all the previous info incl windows and windows recovery partitions so not sure why it will not work. I have now loaded refind into the ubuntu folder and deleted all the other folders which takes me directly to xubuntu without grub. The refind interface has the option to restart the machine into bios. Yes enable F12 bootloader just in case. Also I would recommend supergrub installation to thumb drive if you mess up the efi folders or grub installation at the end of xubuntu installation (it has never fully worked in past installations) so you can get directly to xubuntu via usb. Xubuntu loads very quickly now and is a good match for the 64GB drive (no need for cloud). Acer possibly get a discount on Windows for making it awkward to load other OS???? Refind will also pick up on operating systems and efi on thumb drive if you can't get in any other way (ie F12 not enabled and no bios access) so worth having for that. Note you can sudo filesystem (thunar in Xubuntu) in terminal and manually delete, rename files in the the EFI system to get refind in there but easy to stop the machine booting so you do need to back up to thumb drive and have supergrub for rescue.
Sign In or Register to comment.

Who's Online905

Acer-Edwige
Acer-Edwige
Acer-Samuel
Acer-Samuel
Hayleyb40
Hayleyb40
JackBlack
JackBlack
jeffreyac
jeffreyac
medieval78
medieval78
muditm8
muditm8
Xcartia
Xcartia
+897 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers