Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Spin One - battery not working after upgrade

MrBlueZAMrBlueZA Posts: 3Member New User
Hi everyone,

I recently purchased an Acer Spin One SP111-31-C039. It came with 2GB of RAM and a 500GB hard drive. I decided to upgrade this myself to 4GB of RAM and a 120GB SSD.

I received the laptop and started installing Windows without doing any installation. The laptop would not turn on without the power cable. I plugged the power cable in, installed Windows. As soon as I removed the power cable, the laptop died. Again this was before any upgrades or even opening it. I turned it back on, and it seemed to run okay from battery. It seemed to not need the power cable.

I then proceeded to install the upgrades, both of them. However, after this, the laptop would not run from battery at all. It would run fine from the AC adaptor. In the BIOS, I could see the new hardware so it was installed properly. I switched back to the stock hardware - 2GB of RAM and the 500GB hard drive. Again, it still would not run from battery. It would boot into Windows and everything worked fine. I did not mess up the upgrades. But, it would not run from battery at all.

I contacted the vendor and arranged to have the laptop returned. They replaced it with a new one.

Again I installed Windows on the stock hardware. After the installation was finished, I unplugged the power cable. As soon as I did that, the laptop hibernated or something. The screen went dark but it did not shut down. I was able to get back into Windows. I restarted the machine twice on battery power to make sure that the battery was okay. I then performed the upgrade again. However, the same issue occurred - the battery ceased to work despite me not touching it at all.

I was even able to install Windows onto the new SSD. However, the battery still does not function at all. If I unplug the power cable, the laptop shuts off instantly. Windows detects the battery and says it is plugged in but not charging.

I have tried the following:
PIN battery reset (two or three times)
Plugging in and unplugging the charger
Removing the Microsoft ACPI Control Method Battery from the Batteries interface and adding it back again

Please can someone advise me on what to do. To my mind, a laptop that breaks as soon as it is upgraded is a faulty laptop. Again, the upgrades that I performed are picked up and read correctly. It is just that, in 2 out of 2 cases, the battery was somehow affected. I do not know how as both times I did not touch it at all. I did not unplug any cables or wires or touch anything of it.

I do not know what to do. I just want the thing to work. These issues might be why Acer has taken this product off the market despite it being so new.

FAQ & Answers

  • MrBlueZAMrBlueZA Posts: 3Member New User
    edited December 2017
    I just wanted to give an update on this - I found the solution. There is another post on this forum that contained the answer, unfortunately I am too new to link to it.

    Acer - this has to be some of the worst engineering I have ever seen.

    There is a switch that will disconnect the battery as soon as the case is opened. The problem is, this switch then does not get pressed down again when the case is closed. It looks like there are two loose little rubber tabs that come off. There is a larger rubber pad that stays put, but there are also these thin little guys that come loose. My guess is that they are necessary for the battery to function.

    So you open the case, these thin little rubber tabs fall out, and you have no idea what they are for or where they came from. Good thing I didn't throw them away. When you then close the case again, your laptop now does not work and you have no idea why. Acer, was this designed to make people use your service centres and give you extra money? This makes them a lot less serviceable if you don't know about this little trick.

    So how did I fix it? I folded some paper in half and stuck it on top of the rubber pad (which is too short by the way) with sticky tape.

    Terrible engineering and probably the last time I will buy an Acer.

    Some more detail on what Acer did since I am not sure I have explained it well.

    On the motherboard, near the ram, is a switch. When this switch is pressed down, the battery works. When the switch is not pressed down, the battery does not work. On the case, there is a plastic box above this button. Inside the plastic box is a rubber pad. The rubber pad is too short to go all the way to the top of the plastic box. The box is maybe 8mm by 8mm, something like that. So is the rubber pad.

    With just the rubber pad in the plastic box, there is a gap between the rubber pad and the switch. When you close the lid, the rubber pad does not press the switch and the battery does not work. There needs to be something else in between the rubber pad and the switch for it to work. I believe that something else is two rubber/plastic tabs, about 1mm wide and 8mm long. I am not sure how exactly they would fit in, but they come loose when you open the case. And after you open the case, the battery will not work again unless you know about this little trick.
Sign In or Register to comment.

Who's Online131

19XLR95
19XLR95
brummyfan2
brummyfan2
Csilla8820
Csilla8820
gautam2009
gautam2009
Magedeid
Magedeid
Mags0
Mags0
mayu08
mayu08
Skree
Skree
+123 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Acer Store Deutschland


KOSTENLOSER VERSAND - AUSGEZEICHNETER SERVICE

IFA 2018

IFA 2018

IFA 2018

IFA 2018

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.