Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Spin 1 SP111-32N ... can't boot any linux from USB

KmihaljKmihalj Posts: 15Member Troubleshooter
edited February 2018 in Linux
I got new Acer Spin 1 SP111-32N (N4200, 4 GB, 64 GB eMMC, InsydeH20 v1.03, W10H 64bit).
I tryed booting linux from USB (3 different sticks, writing them with Rufus (DD and ISO mode), FedoraMedia Writer, uNetBootIN, LinuxLive USB Creator) with SecureBoot ON and OFF, adding EFI entires as trusted, NetworkBoot enabled and disabled, etc... and every distribution fail to boot (Debian, Manjaro, Fedora, Ubuntu, Mint, Suse, OpenSuse) ... only Arch Linux USB was able to boot... but I don't won't Arch.
I was able to boot rEFInd from one stick ... and select distributions from there which was on other stick, but also no luck ....

All I get when hiting F12 and selecting USB, or EFI entires which I added as trusted is underscore in upper left corner with rest screen blank.... (If I added USB or EFI entries on top of boot list, i get underscore in upper left corner with ACER logo in middle of screen).

Is there any linux distro which can boot on Spin 1 SP111-32N ? .... Are there any other way to boot USB stick and install linux on HDD which I didn't mention here ?

«1

FAQ & Answers

  • KmihaljKmihalj Posts: 15Member Troubleshooter
    Antergos is booting :) ... now burnin KaOS to USB to try (all Arch based)
  • KmihaljKmihalj Posts: 15Member Troubleshooter
    edited December 2017
    I succeed to boot Fedora 27 Live .... I created live USB media using Fedora MediaWriter .... then mounted CentOS 7 minimal install, .... and replaced BOOTIA32.EFI, BOOTX64.EFI, grubia32.efi, grubx64.efi, mmia32.efi, mmx64.efi on Live Fedora (ANACONDA drive) with thoose found on CentOS mounted media (since CentOS is booting correctly) .... and voila, Fedora Booted as it should ....

    I installed fedora on external SSD (Plextor EX1 256GB) to verify that all is working, .... but after reboot I cannot boot Fedora .... so I repeated procedure described above .... I replaced files on efi partition with ones found on CentOS minimal install .... and it boot's correctly. Now updating.... and since GRUB is also on update list, I'll see does it boots afther update.

    Fedora 27 ... all is working, touchscreen, Wifi, SDCard, touchpad, keyboard, camera
    Settings, ... SecureBoot disabled, F12 and NetworkBoot enabled.
  • KmihaljKmihalj Posts: 15Member Troubleshooter
    Well, after update I cannot boot so I repeated process of mentioned in above post, and boot is OK. ...
    It's PITA but atleast I can have linux on machine...
  • xanderickxanderick Posts: 1Member New User
    With the factory BIOS (I forget the number) I was able to install Ubuntu just fine (well I had to fiddle with BIOS settings but eventually it worked)

    Updated to V1.07 and all everything I tried failed (Fedora, Ubuntu/Xubuntu/PopOS/Mint) except for Manjaro (Arch derivative).
    Dowgraded to V1.05, same story.

    What I've noticed is that everything fails when trying to install the Grub v2.02 bootloader.  Only Manjaro/Arch uses the latest Grub v2.03.  My theory is that BIOS v1.05+ has problems with Grub v2.02.  I'm going to contact support and ask if they can provide an earlier BIOS, like v1.01.  That one takes longer to boot but at least allowed me to use my preferred distro.
  • KmihaljKmihalj Posts: 15Member Troubleshooter
    How did you downgrade BIOS ? ... for me I't said that I have newer BIOS and it won't downgrade.
  • KmihaljKmihalj Posts: 15Member Troubleshooter
    Well .... I'll wait till bug affecting Insyde BIOSes is solved .... I don't wonna brick my computer.. Bug is documented here and Ubuntu 17.10 is now not avaliable for download.
  • KmihaljKmihalj Posts: 15Member Troubleshooter
    aha ... post from yesterday is not posted .... here it is:

    I found that grub does not support Apollo Lake processors .... so no boot with grub, but rEFInd as a boot manager should work.
    I found way for Ubuntu derivates here, and also manual actions for Fedora 26 here. I'll try both tomorrow but I'll be using fedora 27 and report results here.
  • gilles34gilles34 Posts: 1Member New User
    edited January 2018
    In the bios : define a password superuser for SecureBoot disabled

    Install default :
    Ubuntu 17.10 --> no boot
    Mint 18.3 --> no boot
    Majaro 17.1.3 --> all hardware test OK 
    Solus OS version ?? last (2018-01) --> all hardware test OK

    Good Install
  • padgettpadgett Posts: 4,012ACE Pathfinder

    Been working with another thread but this seems more appropriate. Did not know Acer had a Linux group.

    Have used various Unix and Linux distros over the years but not recently & currently have a lot more knowledge about Windows.

    That said there are quite a few devices out there, many from Acer, with 32GB non-upgradable SSDs that are not really suited to Windows 10.

    Problem is that most of the insructions require already having LINUX running. I have found a way using secure boot to add the efi files using Setup>security but the installation USB drive must already be in the port.

    That said for the other distros it looks like rEFInd is the answer but as yet I have not found a refind.cfg template that works (do not have a cdrom drive) 

  • UlrikeZUlrikeZ Posts: 1Member New User
    I tried to configure a USB stick with Linux Mint 18.3 in the way Kmihalj described for Ubuntu derivates but I failed.... @Kmihalj: did you succeed in one of the ways you linked in your posting last time?

    @gilles34: how did you do the installation for Majaro?

    Thanks for your help... I really would appreciate running linux on my Acer Spin 1....
  • padgettpadgett Posts: 4,012ACE Pathfinder
    edited February 2018

    FWIW I succeeded with Majaro by creating the USB, inserting in the spin1, going to SETUP>SECURITY>ADD FILE (have to create a security password first)and scrolling through  USB0 (boot>efi) until the bootx64.efi displayed, then gave it the name "MBOOT" and saved it (OK). Also enable the F12 boot. Then it would boot without the "Security Boot Fail" error message. If the menu appears, you have it.

    However I also have Ubuntu, Mint, CentOS, and Kali none of which I have gotten to boot. Am downloading Fedora 27 at the moment.


    Two hours later - downloaded and tried Fedora 27 live both with the Fedora media creator and Win32DiskImager. Looks like it uses the older GRUB and fails.

    Answer may be rEFInd but I am just not understanding the rEFInd.conf file particularly the menu entries & keep winding up with something missing when invoked.

  • MegaParsecMegaParsec Posts: 100Member Skilled Fixer
    edited February 2018
    Hello,

    here is a guide how to install Ubuntu/Debian based distros on Apollo Lake devices which do not have the function "Select an uefi file as trusted" in the UEFI.

    1.       Boot into live system

    2.       Install Ubunut without GRUB -> open terminal

    sudo ubiquity –b

    3.       finish the installation and open terminal

    4.       Now install Grub into the installed system:

    sudo mount /dev/sda2 /mnt

    sudo mkdir /mnt/boot/efi

    sudo mount /dev/sda1 /mnt/boot/efi

    for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done

    sudo modprobe efivars

    sudo apt-get install --reinstall grub-efi-amd64

    sudo grub-install —no-nvram —root-directory=/mnt

    sudo chroot /mnt

    sudo update-grub

     5.       Rename bootloader and folder, so that it will later appear in the boot menu.

    sudo mount /dev/sda1 /mnt

    cd /mnt/EFI

    sudo mv ubuntu BOOT

    cd BOOT

    sudo mv grubx64.efi bootx64.efi

     In this guide sda2 is / and sda1 is the ESP partition. You can check this with

    fdisk –l

    Reboot and it should work now...



  • padgettpadgett Posts: 4,012ACE Pathfinder
    Have seen many methods from Unix/Linux, need one that works from Windows.
  • MegaParsecMegaParsec Posts: 100Member Skilled Fixer
    Hi

    to create a live usb-stick with windows I would recommend the tool Rufus.

    https://rufus.akeo.ie/?locale=en_US


  • padgettpadgett Posts: 4,012ACE Pathfinder
    I have Rufus and having the same problems which seems to be the version of Grub. Still trying to understand rEFInd.confg
  • CupOfTeaCupOfTea Posts: 4Member New User
        Acer Spin 1 SP111-32N

        Kubuntu 17.10.1

           Hangs immeadiatly on boot.  Cursor at top left Acer splash still on screen.
           Pretty sure I tried every Bios/uefi/Rufus combo.... no go.

        Got there eventually.... forgotten most of the process now but fwiw

           installed kubuntu 16.04.4

           Created bootable USB with Rufus GPT UEFI
           Installed overwriting Win10 partitions
           Installation tells me it should finish soon... but it hangs
           dpkg --configure -a  and  kill -9 (pid of fsop | grep dpkg) and apt upgrade
           and reboot (having sett trusted file in bios)
           hopeing remaining problems will go away after upgradeing to 17.10.1    
           set upgrade type to normal instead of lts and  do-release-upgradeing
           Installation tells me it should finish soon... but it hangs
           Clean up dpkg again

     **
           eventually just have the hang which I tracked to 30_uefi-firmware in /etc/grub.d
           google told me there was a known fault but i'd had enough
           I commented out everything after  if [ -e "$OsIndications" ] && \
           uninstalled fwupdate
           Clean up dpkg again
           and i appear to have a 99.9% working kubuntu 17.10.1 on my laptop

           Sorry I can't give more precise info...  or show proper respect for firmware updates.....    but it can be done


  • padgettpadgett Posts: 4,012ACE Pathfinder
    Do a search on Apollo Lake for a lot of information. Basically the only two Linux distros I have found that boot are Manjaro (17.1.7), and Kali (not 2018-1 but weekly after 2018-W09).
  • CupOfTeaCupOfTea Posts: 4Member New User
    Ubuntu on Acer Spin 1 SP111-32N

     my post april 11 above....  ignore it

    Just do this https://community.acer.com/en/discussion/comment/480966/#Comment_480966

    You can boot to live on usb with 16.04 or 18.04 just follow the instructions in the link above to fix the grub2 error.
    Make sure you have the right number of spaces and hyphens... it's hard to see em on the small screen.


  • CupOfTeaCupOfTea Posts: 4Member New User
      rotated left and locked with [special]+o keys,  so I could do the install the right way round
     
    for perminant correct orietation and auto rotate
    https://github.com/hadess/iio-sensor-proxy
    https://forum.manjaro.org/t/manjaro-on-an-acer-spin-1-sp111-32n-convertible-2-in-1-laptop/41035
    https://www.aixin.fr/jipeblog/?p=119

    I got away with this on ubuntu 18.04
    create  /lib/udev/hwdb.d/61-sensor-local.hwdb
    add to it the two lines below
    sensor:modalias:acpi:BOSC0200*:dmi:*svn*Acer*:*pn*Spin*SP111-32N*
     ACCEL_MOUNT_MATRIX=0, 1, 0; 1, 0, 0; 0, 0, 1
    then as root
    systemd-hwdb --usr update
    udevadm trigger
    udevadm info -export-db | grep ACCEL
    then reboot

    still cant get auto-rotate in plasma though






  • CupOfTeaCupOfTea Posts: 4Member New User
    they've released 18.04 officially now and I reinstalled from scratch and realised that I failed to mention that
    when you are doing  https://community.acer.com/en/discussion/comment/480966/#Comment_480966

    when doing the mounts  sda1 is mmcblk1 and sda2 mmcblk2 on the sp111-32n 

Sign In or Register to comment.

Who's Online156

Jhjh6980
Jhjh6980
Kaiserlol
Kaiserlol
Kno63
Kno63
MArhEV
MArhEV
SilentMarket
SilentMarket
+151 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

We would like to feature andylb as a outstanding member in the Acer Community. With his dedication and support efforts, andylb has become a Valued Contributor . On behalf of the Acer Community team and all our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1229

Total Points:3032

Total Accepted Answers: 155

andylb Overclocked Contributor
Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.