Aspire V5-591G: Certain Keyboard Keys Don't Work

TommyVercetti
TommyVercetti Member Posts: 3 New User
edited March 2023 in 2017 Archives
Hi everyone. About 4 days ago, several keys on my Aspire V5-591G stopped working while I was using my laptop. Among them were the Control, I, O, and Backspace keys, and several of the number keys. For the record, I have never spilled anything onto my laptop keys, and I've blown our the keyboard with compressed air several times. I've also done multiple virus scans, I reinstalled my keyboard drivers, and used System Restore, yet none of these solutions have worked. I also notice that none of these keys work in BIOS, either. (I tried using a Live USB to boot into a Linux OS. I wasn't able to get it to run properly, but I was able to open the GRUB2 command line. And once again, none of the keys I listed worked.) I went so far as to open up my laptop to ensure that the ribbon cable between the motherboard and the keyboard was still connected, and it was. So, I'm pretty stumped here. Any advice? (If it helps you guys any, I got this laptop around the summer or fall of last year, and I have never experienced any major problems until a few days ago, when this happened.)

Answers

  • TommyVercetti
    TommyVercetti Member Posts: 3 New User

    I should probably add this here: I have yet to check my computer completely for viruses. Normally, I boot into a Linux-based operating system from a live USB and then scan for viruses from there. However, I've had difficulty booting into live USBs on here, even after I disabled secure boot mode. I'm not entirely sure why I'm having trouble. I'll try again to boot into another environment and scan for viruses there. Until I do so, I haven't completely ruled viruses out.

  • TommyVercetti
    TommyVercetti Member Posts: 3 New User
    So here's another update: the problem is not from a virus. I have thoroughly scanned my system, and no trace of any virus was found. Further, I now am having issues with the built-in microphone on my laptop. Now it's stopped working as well, and I have no idea why.
  • brummyfan2
    brummyfan2 ACE Posts: 28,080 Trailblazer
    Hi,
    Have you tried a USB keyboard? You could also try a battery reset, there's is an outside chance but give it a go:https://us.answers.acer.com/app/answers/detail/a_id/34843/~/acer-internal-battery-reset
  • SlavKor
    SlavKor Member Posts: 2 New User
    3 days ago have got the same issue. The key A did not respond. Unfortunately, this model done so that you cannot open keyboard as it is fully closed and not accessible. All other keys are work well.
    What I Did? I have re-assign one of the keys which I rarely use for A. you can do that with CMD as admin and remapkey.exe

    Here you can find correct instructions: http://ccm.net/faq/1197-keyboard-re-assigning-of-a-key 

    It is temporary measure but at least I can type some text without using a virtual keyboard.