Laptop (Aspire V5-591G) won't detect my mobile device when connected via USB

XelaRaliuga Member Posts: 2 New User
edited March 2023 in 2017 Archives

So I normally connect my LG K7 to my Acer Aspire V5-591G (running Windows 10 Home Edition) via USB tethering for transferring music, photos, and to enable internet use using my mobile devices functionalities. I noticed a few days ago when I connected my phone to my laptop, initially just to charge it, I opened my "File Explore" application and clicked on the This PC tab only to find that the icon to access my mobile device was not on display as it normally does. I updated the USB controller Drivers (only Realtek USB 2.0 Card Reader required it) using Device Manager and after restarting the laptop the issue remained unresolved. I proceeded to update the laptop with a Universal Mobile Drivers obtained from LG's website that are "designed to work with all LG Mobile devices" and after doing so then restarting my computer, the issue is still unresolved. My LG K7 has also been updated to the latest software version and this issue still persists. I tested connecting a separate mobile device to it and the computer did not recognize that device either, however, it did display that both my LG K7 and the other mobile device were still being charged whille being connected via USB.


Would anyone be able to assist me with this issue further because I am not adept with technology and am not certain where to go from here.


Thanks for reading.


  • Mono
    Mono Member Posts: 21 Networker

    Hai Buddy for that you have to install a application on "c" drive 


    Windows Button + E 

    Open the "C" drive  - windows folder - inf folder- 

    in the "inf" folder you can find the "wpdmtp" (setup information file ) Right click run that and restart the Notebook


    And on your smart Phone if it is androad check for developer options in setting in it you can find a Option called usb debugging enable it


    there you go now you can connect the Smart phone in windows 10 Unit ...!!!!