Brand New Acer Aspire E5-575G-53VG stuck on "Just a moment..." screen?

cafeleblanc Member Posts: 1 New User
edited March 2023 in 2017 Archives
Hello. Apologies if I posted in the wrong forum - this is my first time posting here...
I just received a laptop (Acer Aspire E5-575G-53VG, Windows 10) as a gift last night. I began to set it up, however, upon exiting setup (after setting up the computer's password and setting preferences) the setup crashed and showed the Smiley Sad We've run into a problem, and need to restart! screen (or whatever it says, I can't remember completely!).
Once I restarted, the computer popped up with a "Just a moment..." screen, with those cyclic dots. The screen is hot pink (unlike the regular sky blue??) and my mouse responds when I move it on the trackpad. That is the only sign of response I've gotten inside that screen.
I have forced a restart, and it comes back up with this screen. I also tried Alt+F10 upon booting up and it comes up with the "Choose an option" screen but there is nothing under that menu that would help me, I tried everything.
I searched everywhere, and have yet to find a solution that works with my computer. Are there possible solutions?
EDIT: I should note, I'm not the most tech savvy person... LOL


  • IronFly
    IronFly ACE Posts: 18,413 Trailblazer

    i would suggest you to contact Acer support service, this is not a normal behaviour.

    I'm not an Acer employee.