ASPIRE V5=571 the screen is black, no sounds, no nothing

Options
allokusa
allokusa Member Posts: 2 New User
edited January 2023 in Legacy Laptops and Netbooks

Hi. I am one of the many whose laptop will not start when the power button is pressed. the screen is black, no sounds, no nothing. Only the blue light on power button and front of laptop.

 

I can boot up by removing the battery and poer supply and holding power button down for about 30 seonds. This does not work every time but with patience I can get it to start.

 

Can some one please tell me what needs to be done to remedy this sitiation.

Thank You

 

 

[Edited the thread to add issue detail]

Answers

  • IronFly
    IronFly ACE Posts: 18,413 Trailblazer
    Options

    check and update your BIOS version if any is available:

    https://www.acer.com/ac/en/US/content/support-product/4251?b=1

     

    How can i understand which version i need to download?

    Laptop versions:
    1.xx can only be updated using 1.xx versions
    2.xx can only be updated using 2.xx versions (normally 2.xx version are labeled "not for upgrades")

    I'm not an Acer employee.
  • allokusa
    allokusa Member Posts: 2 New User
    Options

    Thanks for your reply.

    The laptop keyboard has many keys that do not work properly so I’ll need to install

    an external keyboard before attempting the BIOS update.

  • wolsty
    wolsty Member Posts: 1 New User
    Options

     

    Hello allokusa

    Did you find a solution for your 'no power button & dead screen' issue in the end ?
    I hope that you did, but if you haven't found an answer yet and I'm not too late, you could consider this.

     

    I bought the same model 2nd hand 2 months ago and it sat dormant with an almost identical problem for a month whilst I tried every possible software solution from the darkest depths of the internet, through Microsoft, Acer, Intel, ATI and Nvidia support pages and many tech forums, scratching my head and getting annoyed, angry (Machines can't win, I wont allow it, WE decide if and when they're old or useless, by postmortum if it dies with a full on diagnosis.. and maybe an Inquiry if it's a mystery.. lol)  I digress.
    Anyway it turned out to be had nothing to do with SOFTWARE,  BIOS or FIRMWARE.
    It was Mechanical

     

    I had decided to open her up, it's the begining of the end, I'm thinking parts and salvage now, RAM, HDD, CHIP, RWDVD, WIFI and a definate diagnosis of what she died of fully expecting to be throwing out the board, but adding more duplicate parts to "Computerbox" like an overflowing casket of mismatched body parts already filled with existing spares that I won't use or ever need, sat in the corner of the spare room.

     

    I Took all the screws out ready for full dismantlement, done the HDD, RAM, DVD, just the keyboard, wifi and processor chips were all she was wearing, practically naked. LOL
    It was when I lifted her keyboard off that I found that her ribbon cable which connects the PWRbutton to the M/board, running sandwiched between the base of the keyboard and the metal protective M/Board cover plate seemed to look a bit crooked and it came completely loose when I lifted the keyboard out it had detached itself at the PWRbutton end which, clearly it shouldn't. It should be securely clipped in.
    Then upon closer inspection I found that the other end of the cable wasn't seated straight either.
    ... and that's when it hit me.. Of course..
    It made perfect sense as soon as I saw it....
    Everything fell into place. It clicked in my head..
    My brain did a reboot... You could almost hear my light bulb come on..

     

    A whole bloody month and all that brainache for a flippin loose connection.. That was why the blue power light indicator was showing but nothing else was working. It wasn't set home in it's clip correctly after someone had taken it apart or they'd pulled the cable out when the keyboard was going back on.

    So... if your machine has been dissassebled or the keyboard has been previously lifted for repairs or a replacement at some point then this maybe what's causing your failure.

     

    So it turns out that the cable is actually made to be very tight fitting, it's only just the right length, no room for error. It's really tricky. There's 2 plastic clips, one at either end to house and connect the cable but they're very tiny, extremely fiddly and quite flimsy and it took me several (at least 10) attemps over a couple of hours to re-seat the k/board without accidently pulling out or catching the cable crooked at either one end or the other, sometimes pulling both out from their clips. ...AND what's worse is.. you cant see if the cable is coming loose or detached when you put the keyboard back on, so you cant tell if it's good until you've put it back together, plugged it back in and pressed the damned PWRbutton.
    It wasn't easy, nor was it fun... but it was really satisfying to see it light up like it'd just been taken out of the box.

     

    Also, those cables, if manipulated too much, can start to crease and wear thin so it's possible that the cable might be damaged and shorting on the case if the plastic coating has worn off it anywhere. (check the cable where it folds)
    A small piece of electrical tape or cellotape is an easy fix slotted inbetween IT and the metal case so long as the ribbon has no physical breaks in metal film inside. 

     

    I might be wrong, it could be that the BIOS update IS what you needed and that THIS is just a coincidence.

    Who knows... You know computers..

    It's one symptom... several possible causes. 

     

    (alternatively, if you give up -coz it's really hard- you could just plug in the ribbon cable with no effort, leave the keyboard off and plug in a USB KEYB instead)


    wolsty

  • Lo155
    Lo155 Member Posts: 1 New User
    Options

    My wireless capability is not turning on

  • billsey
    billsey ACE Posts: 32,267 Trailblazer
    Options

    @Lo155 your question doesn't seem to match the topic, and this thread is many years old. Please start a new thread with your question, include your full model number and what you have tried so far.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.