Examples: Monday, today, last week, Mar 26, 3/26/04

TravelMate P449-G2-MG Can not install Linux

VanchurovVanchurov Posts: 1Member New User

Hello, I've just got this computer yesterday and unfortunately I can't seem to be able to install anything but Windows on it, even though it came with Linpus out the box. I have tried installing Ubuntu 17.04, Mint 18.1 and Centos 7 with pretty much zero success. 

 

OK, so here is what I did, I've tried with three different distros, all of which were written on different USB drives in three ways, under CentOS with dd and under Windows with Rufus using GPT and MBR. That makes a grand total of 9 different images, no difference whatsoever. First, I've tried booting with Legacy settings in the BIOS Boot menu but on each distro it gave me either a Kernel Panic or would lock up completely. Then I've tried UEFI with secure boot on, that got me somewhere on Mint and Ubuntu, Centos was still panicking. On a few occasions I was able to "try" before installing for some time before both locked up and I had to hold down the power button. After that I've disabled secure boot, that went a little better, I was able to install Ubuntu about 4 times and Mint 3 times. On some occasions, after attempting a reboot, the computer just hung and I had to hold down the power button, on others it rebooted properly and a screen saying No boot device came up. In order to remedy this, I had to enable secure boot and add the relevant *.efi file to the boot options in order for grub to even attempt loading something. On a few occasions I was able to boot into the OS but after no more than 5 minutes, irrelevant if it was the Graphics environment or CLI, it froze, forcing another hard shutdown. On other occasions it simply froze on the splash screen. I've tried removing the second hard drive, doing a fresh install of Mint and one of Ubuntu with just the nvme present but with the exact same results. Please note that I've only tried installing the OS on the SSD. 

 

I'm typing this on the laptop with Windows 10 running like a dream, I reckon that rules out a hardware issue. Having spent the better part of 10 hours trying to figure it out I am completely out of ideas and I hope to hear something back from you.

 

PS I've read all the threads here, on reddit and on the ubuntu and mint communities.

PPS There is no BIOS update available for this machine.

FAQ & Answers

  • BetaZilianiBetaZiliani Posts: 4Member

    I managed to "Try Ubuntu" by disabling ACPI in the boot options:

     

    https://askubuntu.com/questions/162075/my-computer-boots-to-a-black-screen-what-options-do-i-have-to-fix-it

     

    However, the trackpad doesn't work. And not having ACPI is a pretty bad thing for a notebook! So I guess we are pretty much ....ed. I need linux to work, so I just got a very expensive paperweight...

  • Wulf4096Wulf4096 Posts: 11Member

    I've got a P459-G2-M and managed to install Ubuntu 17.04. Then boot into safe mode and upgrade kernel to 4.12.

     

  • BetaZilianiBetaZiliani Posts: 4Member

    Wulf4096, do you know what is the difference in the BIOS between the P449 and P549? Did you also disabled ACPI to install it? Or how did you do it? Thanks!

  • Wulf4096Wulf4096 Posts: 11Member

    No idea about BIOS differences. But I assume they should be quite similar.

     

    In BIOS, enable UEFI, disable secure boot.

    Grab installer files from http://archive.ubuntu.com/ubuntu/dists/zesty/main/installer-amd64/current/images/netboot/ and read any manual on how to setup dhcp, tftp, etc.

    That installer isn't using uefi, so I got the efi+grub files from http://ftp.nl.debian.org/debian/dists/sid/main/installer-amd64/current/images/netboot/debian-installer/amd64/

     

    in grub.cfg I added acpi=off (you can also do this manually once grub boots).

    In grub select install, install Ubuntu. Nothing special here.

    Near the very end of the install, before rebooting, grab new kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.12/ and install the amd64 packages into /target. (Mount /target/sys first or dpkg / postinst will complain).

     

    Reboot, back to bios. Disable network+usb boot, enable secure boot, erase/reset all secure boot mode settings, reboot, select "shimx64.efi" as trusted.

     

    So far my laptop is mostly functional and didn't crash yet.

     

    I think I should write down detailed and easier to understand instructions...

  • Wulf4096Wulf4096 Posts: 11Member

    https://github.com/joernheissler/ubuntu-pxe

     

    Please let me know if this works.

  • dwidnigdwidnig Posts: 3Member New User

    Hi Vanchurov,

     

    I had the same issue with the P449-MG-56T6 and the steps below worked for me.

     

    I did the following steps:

     

    1. In Windows, download the latest BIOS version from ACE, install it and reboot.
    2. Press F2 (for BIOS access)
    3. In "Main" tab,
      1. enable the "F12 Boot Menu"
    4. In "Boot Options" tab,
      1. set the Boot Mode to "UEFI" (if it is not already)
      2. set "Secure Boot" to "Disabled"
    5. In "Advanced" tab,
      1. check if "USB Boot" is "Enabled"
    6. Insert your USB Boot Medium (in my case it was Ubuntu 16.04)
    7. Press F10 to save and exit BIOS changes
    8. When it reboots press F12 until the boot menu appears
      1. Select your USB Boot Medium
    9. Now the Ubuntu Installation screen should appear ("Try Ubuntu ..., "Install Ubuntu",...)
    10. Go to "Install Ubuntu" (do not press Enter)
      1. Type "e" (for editing)
      2. Several lines will appear
      3. Go with the cursor the line with the "linux" command
      4. After /capser/vmlinux.efi insert acpi=off as an additional parameter
      5. Press F10 to boot
    11. The installation should start
      1. Due to acpi=off some hardware components may not work
      2. in my case it was the touchpad: Ensure you have an extra mouse (but installation can be done with Keyboard also)
      3. Finish the installation with Ubuntu alonside Windows option
      4. Remove usb install medium and restart
    12. Do not expect that you can now boot in Ubuntu on start up Smiley Happy
    13. Press F2 for BIOS access again
      1. In "Boot" tab, enable "Secure Boot"
      2. In the "Security" tab, go to "Select an UEFI file as trusted for executing:
        1. Press Enter, "HDD0" appears
        2. Press Enter, "<EFI>" appears
        3. Press Enter, several entries appear, select "<ubuntu>"
        4. Press Enter, several entries appear, select "<grubx64.efi>"
        5. A dialog appear ("Add an new file")
          1. Give it a description, e.g. "grubx64" and select "Yes"
      3. Press F10 to save changes, exit BIOS and reboot
    14. Press F2 for accessing BIOS again
      1. In "Boot" tab, in the "Boot priority order" there is a new entry named:
        1. "EFI File Boot 0: grubx64" (the description we gave previously)
      2. With F6 rise the priority to be the first entry
      3. Press F10 to save changes, exit BIOS and reboot
    15. Now the grub menu should appear to boot "Ubuntu"
      1. Press "e" again for editing
        1. Again there is a "linux ..." command line with some parameters
        2. Insert acpi=off as an additional parameter
        3. Press F10 to boot
      2. Again, some HW may not work, but ubuntu should startup and you should be able to login
      3. Establish an internet connection
      4. Open a browser and visit: "http://kernel.ubuntu.com/~kernel-ppa/mainline/"
        1. Select the latest kernel version
          1. (in my case it was "v.4.13.-rc2")
        2. Depending on your system download
          1. "linux-headers-...._all.deb"
          2. "linux-headers...-generic...deb"
          3. "linux-image....-generic...deb"
        3. Note: you can also use a terminal with wget to download these resources
      5. Open a linux terminal
        1. cd to the downloaded .deb files
        2. Then type in:
          1. sudo dpkg -i linux-*deb
          2. sudo update-grub
          3. sudo reboot now
    16. Your system will reboot and you should now be able to boot ubuntu properly without any additional parameters
      1. Note: touchpad and other HW should now also work

     

    I hope this will help.

     

    BR

     

  • BetaZilianiBetaZiliani Posts: 4Member

    Hi Vanchurov,

     

    I'm following your instructions (just because I'm lazy to set up the network as required by @Wulf4096(. I got stuck at the first step: after downloading the latest BIOS and executing the program, Windows was restarted and the notebook is now stuck showing the acer splash screen of the BIOS. It's been several minutes already. Did you experience this? Should I reboot and cross fingers? :-O

     

    Thanks

  • dwidnigdwidnig Posts: 3Member New User

    Hi,

    I am not Vanchurov,

     

    but the BIOS installation worked for me without any issues, so I haven't experienced this behaviour. Not sure what to do in such a situation (Contacting Acer Support?). 

  • Wulf4096Wulf4096 Posts: 11Member

    That sounds exactly like http://community.acer.com/t5/Travelmate-and-Extensa/P459-G2-M-Bios-upgrade/m-p/513286#M1883

     

    The BIOS upgrade fails for reasons unknown to me, the error message is hidden behind the splash screen. That's as far as my theory goes.

    ctrl-alt-del should suffice.

     

     

  • dwidnigdwidnig Posts: 3Member New User

    You may not need to update the BIOS for the next steps, I just did it, because I was struggling around with the Ubuntu issue and tried several things from blogs/forums/etc. Therefore I have commented it in the steps.

  • BetaZilianiBetaZiliani Posts: 4Member

    Thanks guys! (sorry @dwidnig for the name confusion). I'm writing this now from my Ubuntu in TMP449 Smiley Happy There is a difference worth mentioning for other users: I couldn't install Ubuntu alonside Windows just like that. I had to go to Windows and shrink the partition (and it wouldn't allow me to shrink it all that much, I got less than half the disk for Ubuntu Smiley Sad ).That said, everything else went flawlessly.

  • AlyanaAlyana Posts: 1Member New User
    If anyone else has the problem, Here is how I successfully installed Linux Mint 18.3 Cinnamon without issues on a Travelmate P449-G2-M-55JR:



    1. In BIOS choose LEGACY boot instead of UEFI, and enable F12 Boot selection, or have the Linux Mint USB stick inserted and put it at #1 boot order
    2. Boot from Linux Mint, hit TAB during the automatic boot countdown
    3. Hit TAB again on the first boot option, and add ACPI=OFF directly behind ...capser (thanks @dwidnig for that :) )
    4. Linux Mint should successfully start, except the e.g. touchpad and Battery in tray, as pointed out before. External mouse works fine
    5. Install Linux Mint, I chose "Delete harddisk and Install Linux Mint" as my installation option (Only a deleted Windows 10 is a good Windows 10)
    6. Restart, and repeat steps 2 and 3
    7. In Linux Mint, choose Kernel 4.13 from the Update Manager and install it
    8. Reboot
    9. Everything is working like a charm now

    Thank you all very much for all the infos above!

    Cheers and have fun with Linux Mint
    Alyana

  • JackEJackE Posts: 16,714ACE Trailblazer
    Alyana>>>(Only a deleted Windows 10 is a good Windows 10)>>>

    Heh-heh. Yet some folks still prefer dual boot. Most, but not all, have usually succeeded with GPT installation media in UEFI mode. Jack E/NJ
  • dan_lawanddan_lawand Posts: 1Member New User
    Someone could do dual boot WITHOUT using acpi=off on TravelMate P449-G2-M?
  • JackEJackE Posts: 16,714ACE Trailblazer
    dan_lawand

    Please post a screenshot of your BIOS Information tab. Jack E/NJ
Sign In or Register to comment.

Who's Online143

Acer-Micha
Acer-Micha
ananta
ananta
aparveezsn
aparveezsn
ASCiiDiTY
ASCiiDiTY
bacterio
bacterio
Baekisizwe
Baekisizwe
Darcaut
Darcaut
Jhjh6980
Jhjh6980
KarunShaji
KarunShaji
loveyou
loveyou
LuckyJay
LuckyJay
oseofwar
oseofwar
sayysen
sayysen
xapim
xapim
+129 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.