image

Touchpad Not Working

I have an Acer Aspire ES1-111M (already upgraded to Windows 10 from 8.1) that was getting really sluggish, so I decided to reset it. I clicked Settings > Update & security > Recovery > Advanced starup > Use a device > USB > ... and I tried to click "Install Windows" but I noticed my touchpad wasn't working. At the time, I didn't think much of it. I just completed the rest of the install using only the keyboard. Eventually, Windows 10 finished installing and I noticed my touchpad still wasn't working. Since then, I've tried a few things to fix the problem, but nothing has worked so far.

 

Below are some random (or not-so-random) bits of information that might clarify my situation:

 

PS/2 Compatible Mouse:

In Device Manager, under Mice and Other Pointing Devices, a device called "PS/2 Compatible Mouse" suddenly showed up. It wasn't there at first.

Its Hardware ID is "ACPI\VEN_SYN&DEV_1B7D". I think it might be connected to Acer. But its Manufacturer, Driver Provider, and Digital Signer are all listed as Microsoft.

In Driver Details, two items are lised:

C:\WINDOWS\system32\DRIVERS\i8042prt.sys

C:\WINDOWS\system32\DRIVERS\mouclass.sys

 

Touchpad_Synaptics_19.0.7.34_W10x64_A:

I looked up my laptop on acer.com, downloaded the touchpad driver listed, and installed it. The setup was completed and the status was listed as "ready to use". I rebooted, but my touchpad still didn't work.

Looking further, I noticed that inside the "Touchpad_Synaptics_19.0.7.34_W10x64_A" folder there was a file called "SynRMIHID.sys"

 

BIOS Menu:

In the BIOS menu I switched the touchpad from advanced to basic, saved changes and exited, and restarted the computer. The touchpad still didn't work.

But I noticed, when switching from advanced to basic in the BIOS menu, there was text to the right that said something like the advanced setting wouldn't work unless the proper "I2C" driver was installed.

 

I2C:

In Device Manager, under System Devices, the following device is listed:

Intel(R) Atom(TM)/Celeron(R)/Pentium(R) Processor Serial IO (SIO) - I2C Port 1 0F41

What stuck out for me was the "I2C" before Port.

And also the words Intel Serial IO.

 

Intel Chipset driver and Intel Serial IO driver:

I keep coming across the phrases "Intel Chipset" and "Intel Serial IO". To be honest, I'm not 100% sure why.

 

Unknown Devices:

In Device Manager, under Other Devices, there are three "Unknown Device"s.

Also there is an Unknown USB Device under USB Controllers.

 

 

 

Right now, that's about all the information I have. I feel like I'm right on the edge of a solution with these pieces, but I'm not smart enough to figure it out. Could someone who is help me out?

 

FAQ & Answers

  • TrukntiggerTrukntigger Member Posts: 256 Mr. Fixit

    I will take a crack at it. Was working before OS reinstall so can be sure driver issue. Assume touchpad driver from win8 was carried over to Win10 due to reinstall losing functionality with Win10 default driver. Guess I would download the win8 driver from Acer, open the zip to get exe file. Open the exe with zip7 (the exe is another self extracting compressed file) then using the contents of that exe manually select that for touchpad using device manager update, manual, have disk, browse to file, use even if windows likes its current selection. Can't hurt and best guess based on info given. 

  • ChrisChan5555ChrisChan5555 Member Posts: 3

    Hey, thanks for the reply,

    Well, I downloaded the Win8.1 driver > unzipped > opened the exe with zip7 > update > manual > have disk > and I ended up with the following message:

     

    image

     

     Messing around with things a little more I either keep getting the above message or the following:

    "The best driver software for your device is already installed."

    "Windows has determined the driver software for your device is up to date."

     

    Silver lining, I didn't even realize the 8.1 drivers were available for download until you mentioned it.

     

  • TrukntiggerTrukntigger Member Posts: 256 Mr. Fixit

    In the package was a .ini file. Should be able to right click install. Win10 still has same bug win98 had...plug and pray. Convinced driver issue. Getting windows to use it harder.

  • ChrisChan5555ChrisChan5555 Member Posts: 3

    Alright, somehow someway I got my touchpad working again. I pretty much threw everything at the wall and something stuck. I'm not sure what. Smiley FrustratedAll I know is I'm not proud of how much time and effort I spent on this problem. Smiley Frustrated

    And also I'll never again take for granted the feel of a HeartworkingHeart touchpad...

Sign In or Register to comment.

Who's Online1K

Acer-Michi
Acer-Michi
at311
at311
LbRnt
LbRnt
SatySatsZB
SatySatsZB
Siva2606
Siva2606
Skywalker837
Skywalker837
YellampalliPrudhvi
YellampalliPrudhvi
Yunice
Yunice
+999 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos