Examples: Monday, today, last week, Mar 26, 3/26/04

Disable auto brightness adjustment

WulkanWulkan Posts: 1Member

My laptop screen keeps auto adjusting my screen brightness based on what I'm viewing and it's driving me insane! When I view dark things the screen gets so dark I can barely see anything, and when I view bright things the screen gets so bright it hurts.

 

I have disabled adaptive brightness in my power settings, I have disabled screen power saving in the Intel configuration settings. Why is it not working?

 

I found this: http://acer.custhelp.com/app/answers/detail/a_id/34068/related/1

But I don't have that option.

 

Please, help!

FAQ & Answers

  • If you don't have "Change Brightness automatically ...."option not available, that feature is not available with the driver provided by Windows or you don't have the sensor. You could try a different display driver or manually control the brightness.

    https://www.itsupportguides.com/windows-10/windows-10-how-to-disable-automatic-brightness-adjustments/

    Please don't click "Like" but click "Yes" for "Did this answer the question", if I resolve the problem.
  • IscrEyrOIscrEyrO Posts: 3Member New User

    Did you get a fix for this? I'm seeing the same thing and it's so annoying!

  • Sushi94Sushi94 Posts: 6Member

    Tinkerer

    I'm having the same issue on my Acer Aspire E15.

  • brummyfan2brummyfan2 Posts: 12,466ACE Trailblazer

    Hi,

    You could try Night light settings to help viewing bearable, it's not a total solution but might help.

    Go to Settings, Display and select Night light settings and change the time to suit you.

    Capture1.JPG

    Please don't click "Like" but click "Yes" for "Did this answer the question", if I resolve the problem.
  • Sushi94Sushi94 Posts: 6Member

    Tinkerer

    This seems to be the current workaround for the adaptive dimming on my end. Tried it for several days just to be sure along with restarting with the settings a few times.

  • IscrEyrOIscrEyrO Posts: 3Member New User

    The night light thing isn't the fix for me, the auto-dimming still happens but with everything tinged orange Smiley Sad It's the only major problem I have with this laptop, seems mad how hard this issue seems to be to fix.

  • IscrEyrOIscrEyrO Posts: 3Member New User

    I finally found a solution for this, credit to Miroslav Saracevic on SuperUser.

     

    https://superuser.com/questions/1170518/brightness-keeps-changing-in-windows-10-x64

     

    For me, I had to:

    - Go to the Desktop

    - Right click -> Intel Graphics Settings

    - Power

    - Tick Disable under Display Power Saving Technology

     

    I hope this helps someone else get rid of this needless annoying "feature".

  • Ben101Ben101 Posts: 1Member

    None of the options work for me, neither the Night Mode, Intel Control panel, etc. 

     

    It's ridiculous that Acer decides what content is dimmed, instead of leaving it up to the user.

    I hope this will get fixed soon, or I will never have faith in Acer products again.

     

  • Sushi94Sushi94 Posts: 6Member

    Tinkerer

    After an update...the adaptive brightness returns yet again... 
  • tim001tim001 Posts: 1Member New User
    Guys, this link saved my life - http://forum.notebookreview.com/threads/acer-brightness-auto-adjustment-disabling.633090/

    "Alright, the issue seems to be fixed by updating the intel graphic drivers then going into power options within intel's graphics properties and untick the 'Display Power Saving Technology' option (which wouldn't be there if the drivers aren't updated)."

    This issue caused a lot of trouble to me so if this solved your problem then share the original link- http://forum.notebookreview.com/threads/acer-brightness-auto-adjustment-disabling.633090/
  • JonathanAcerJonathanAcer Posts: 2Member New User
    Wow this actually worked for me thanks for whoever found out this method.
  • JonathanAcerJonathanAcer Posts: 2Member New User
    Acer_19 said:

    I finally found a solution for this, credit to Miroslav Saracevic on SuperUser.

     

    https://superuser.com/questions/1170518/brightness-keeps-changing-in-windows-10-x64

     

    For me, I had to:

    - Go to the Desktop

    - Right click -> Intel Graphics Settings

    - Power

    - Tick Disable under Display Power Saving Technology

     

    I hope this helps someone else get rid of this needless annoying "feature".

    Wow this actually worked for me thank you so much!!!!
  • This method works, but is glitchy. I have had it where in the Intel settings it was disabled and it still happened. Going to each power scheme under Intel Control Panel, if it says it is disabled, enable it, save, disable, save, repeat on the other plans.

    Skelo
    Please quote me so I get a notification of your reply!
    If I helped you, like my post and/or select my post as 'Solved'.
    Please put your laptop model in your signature so we can know what device you have.

    Product: Acer Predator Helios 300
    Model: G3-571
    "Don't cry because its over, smile because it happened."
    - Dr. Seuss
  • SaanSaan Posts: 2Member New User

    - Go to the Desktop

    - Right click -> Intel Graphics Settings

    - Power

    - Tick Disable under Display Power Saving Technology

    -Tick enable Extended battery life for gaming

    and change Plug in Setting>> Maximum Battery life :)


  • sekirosekiro Posts: 1Member New User
    edited May 28
    I was looking for a solution to this problem over the past few days after updating to Win10 v1903 from v1803, and I have finally resolved this issue for myself. Here's a summary of all(?) the possible root causes for this problem, and use the keywords to search for further details if you need:

    1. Try to disable Windows 10 built in adaptive brightness feature:
    keyword: Win10 adaptive brightness

    2. Try to disable built-in Intel HD Graphics driver's "DPST (Display Power Saving Technology) feature:
    There are several places that needs to be modified in order to turn this feature off, including the Registry and Intel Graphics Control Panel.
    keyword: Intel DPST, Intel Graphics Control Panel

    3. Any additional tweaking tools from the OEM (in this case, Acer). This is also the thing that solved the issue for me:
    If your laptop comes with an Acer utility called "Acer Quick Access", this might be your culprit. According to the link provided by the OP, there "may" be an option called "Adaptive Brightness" in the Acer Quick Access utility. For me however, the option is not there. But what I found that was causing the trouble for me was an option called "Color Intelligence". After turning that option off, together with the fixes to Win10 adaptive brightness and Intel DPST, I managed to solve the issue.

    Hopefully the summary may help anyone else that's also trying to fix this annoying behavior. Remember to search for how to disable each of the potential root cause features by using the keywords provided.
Sign In or Register to comment.

Who's Online177

Bigloo25
Bigloo25
Chiahao
Chiahao
Duder
Duder
gMaNiAc
gMaNiAc
Jasmin_Khimani
Jasmin_Khimani
Jego86
Jego86
Jhjh6980
Jhjh6980
Lynder063
Lynder063
Mamonster
Mamonster
Thor001
Thor001
xapim
xapim
+166 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.