E-15 ES1-512-P18H Keyboard acting like Filter Keys is On when it's not

dbsb3233dbsb3233 Member Posts: 2

Having a really strange keyboard/typing issue.  When pressing the same key consecutively, there's a delay in it recognizing consecutive keypresses.  But only on the same key.  For instance, I can type "abcdefgh" and it works just fine.  "xyxyxyxy" works fine too.  But if I try to type "aaaaaaaa", I get maybe 2 or 3 a's out of it.  It's only when pressing the same key consecutively.  Happens on all keys, even the backspace key, or the arrow keys.  If I simply click the Windows key, then hit the down arrow multiple times, it only takes the 1st one and maybe every 2nd or 3rd thereafter.  It's like there's a delay hanging it up only when pressing the same key consecutively.  Pressing any different key works fine, unless I press that key consecutive times (not holding down for repeat, but actual consecutive presses).

 

This is only on the laptop keyboard.  If I plug in and use an external USB keyboard, it works just fine.  It also doesn't matter what program I'm typing into.  Does the thing anywhere - Notepad, Firefox, even the test typing box in the Control Panel keyboard settings.

 

I've checked may times to make sure Filter Keys are unchecked.  I've even reset the laptop to reload Windows (but saving data) and it didn't fix the problem.  I've also uninstalled the keyboard driver and let Windows 10 reinstall the driver again.  No luck.

 

Any ideas?

FAQ & Answers

  • Acer-MaryAcer-Mary Acer Crew Posts: 871 Acer Crew

    It could be a hardware problem with the keyboard. You've done much of the troubleshooting we would have suggested. Assuming no liquid spill has occured, did it work in the past? Were there any changes made to the system just before this happened?

  • dbsb3233dbsb3233 Member Posts: 2

    Sorry, I missed the reply to this until now.

     

    Yes, it had worked for the first few months after purchasing the laptop.  Then suddenly it started doing this.  No spills or drops or anything like that with it.  I've since tried a full factory reset (erasing all files too) and it still does it.  I'm thinking it's probably a hardware problem too.

     

    I just realized I only have about 5 days left before the 1-year warranty is up (purchase days was 12/2/2015).  I guess I better figure out what the warranty claim process is.

  • Acer-MaryAcer-Mary Acer Crew Posts: 871 Acer Crew

    The contact information to get warranty service is posted at 

    http://www.acer.com/ac/en/US/content/service-contact

Sign In or Register to comment.

Who's Online999

Ahmed600ll
Ahmed600ll
andersonms
andersonms
another_user
another_user
Attorney
Attorney
batmalin
batmalin
crasher
crasher
dahleylama
dahleylama
Daniel1974
Daniel1974
DCAwesome94
DCAwesome94
dei1562
dei1562
EmersonNeves
EmersonNeves
Fabri95A
Fabri95A
Filipeoki
Filipeoki
FábioG
FábioG
IVAN_PC
IVAN_PC
JackE
JackE
JamBoost
JamBoost
JessicaReisDantas
JessicaReisDantas
JohnnyG
JohnnyG
Lionfast123
Lionfast123
mariascarv_
mariascarv_
Mulenick
Mulenick
NaderPredator
NaderPredator
PBalazs0921
PBalazs0921
philardn
philardn
ralppp
ralppp
RevolutionTYPER750
RevolutionTYPER750
RUSSOKGB
RUSSOKGB
Samuele
Samuele
+970 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos