Ubuntu on Swift 3 SF314-51-74FW - black screen after menu on Live USB

leoleoleoleo Member Posts: 4

I just bought an Acer Swift 3 (SF314-51-74FW) with an Intel HD 520, Intel Core i7-6500U processor, 14'' FHD LED LCD, and Windows 10 Home pre-installed. The default boot method is UEFI - Secure Boot.

 

I didn't find the SF serie laptop location for my post, so I put it in S and R series.

 

I created 120 GB free disk space by shrinking the Windows partition in Windows 10. I created a bootable USB stick using the Startup Disk Creator in Ubuntu with an ISO of Ubuntu 16.04 64-bit (the checksum is correct).

 

After having changed the boot order to have the USB stick first, I got the GRUB2 menu. After selecting 'Trying Ubuntu without installing', I got a blank/black screen. The 'working light' on the USB stick did not flash anymore, indicating that nothing was happening.

 

I tried the following proposed fixes, without success:

- Replacing 'quiet splash' with 'nomodeset' (assuming it was the graphic card)

- Using an external monitor (for the same reason, using both 'quiet splash' and 'nomodeset')

- Setting the boot method to 'Legacy' (no valid boot device was found)

- Disabling 'secure boot' in UEFI (still blank screen after grub)

- Adding the two files in BOOT/EFI (or was it EFI/BOOT..) to trusted boot methods and putting them on top of the boot order (still blank screen after grub)

 

In addition, I tried to run the live USB from another USB sticks. In all cases, after having selected an option from the menu, I got a black screen. Both the CPU and the graphic card are used in 'Ubuntu certified systems'.

 

My post voluntarily looks like the one of eelcoherder on this topic http://community.acer.com/t5/Linux/Ubuntu-on-E5-573G-71L9-black-screen-after-menu-on-Live-USB/td-p/405318

The solution was to change the version of the BIOS (the initial one not accepting Linux), but the swift 3 was just released so there is only one BIOS version available on the Acer website (the default one I already have).

 

Suggestions, pointers to similar questions that I may have missed and other help would be much appreciated. Are there any tests that I can carry out to find the probable cause of the black screen? Thanks.

«1

FAQ & Answers

  • JordanBJordanB ACE Posts: 3,670 Pathfinder

    1. Try creating your installation USB with rufus.....and the circled settings below.  Before you click "start", double check and make sure the settings haven't changed.

     

    https://rufus.akeo.ie/

     

    rufussettings.PNG

     

    2. Make sure secure boot is enabled.  Don't use legacy.

     

    3. Enable the F12 boot menu in the BIOS.

     

    4. For testing purposes, don't put them at the top of the boot order.......which means Windows will boot by default.

     

    5.  From what I remember, the only thing I added to the trusted secure boot settings was "Grub"....after I read eelcoherders post.  Because I'm pretty sure his post only says to add Grub.  Not sure if it matters.  Maybe I added the other file too and just can't remember.

     

    6. Hit the F12 key when you see the Acer screen to boot your USB media.  You've got to be quick on that F12 tap.

     

    7. I assume you have set a supervisor password.  I didn't set a user password.  Only set a supervisor password.

     

    8. I don't know if it matters, but I do have an HDD password.  I really doubt that matters.  Just letting you know that in full disclosure.  My only BIOS settings that are different than default are:

     

    A. Supervisor password

    B. HDD password

    C. F12 boot menu enabled

    D. Added grub to trusted secure boot as per eelcoherder's post.

     

    I don't know why you can't get it to work.

     

    About 5 or 6 other people have had problems on various models.  Honestly I don't know if it's user error or a BIOS problem or a combination of both.  One person had to resort to using an external DVD.  But another person tried the external DVD and couldn't even get that to work.

     

    That's all I know. 

     

    If I had your computer sitting in front of me, I could tell you in 2 minutes if it's a BIOS problem or not.

     

    I have installed both Ubuntu 16.04 and Mint 18 Sarah and didn't have any problems.  But I do boot to Windows 10 by default.  I don't toggle F6 to change any order.  If I want Linux, I just hit F12 at boot.  I don't have your computer model.

    I'm not an Acer employee.
  • padgettpadgett ACE Posts: 4,036 Pathfinder

    First, the Swift series replaces the R series so this is the right place.

     

    My thought is "How long did you wait at the black screen before proceeding ?" I have seen one to persist (sometimes with a cursor) for over an hour lately. That said Linux is usually quite verbose about the boot sequence.

  • JordanBJordanB ACE Posts: 3,670 Pathfinder

    I'm about 99 percent sure that the black screen is due to your UEFI rejecting your Ubuntu USB because it doesn't consider it secure. 

     

    I'm not an Acer employee.
  • leoleoleoleo Member Posts: 4

    Hello!

    Thank you for this answer, I did all the steps from the beginning but unfortunately it didn't solve the problem. Same black screen at the same step...

    I tried to add as trusted for executing one after the other files in EFI/BOOT, but booting from the stick (called Linux), the first executable file or the second leads to the same menu (with "try Ubuntu without installing ", "Install Ubuntu", "OEM install (for manufacturers)" and "Check disc for defects").

     

    I also filled the usb stick with zeros before running rufus, with ubuntu command:

    dd if=/dev/zero of=/dev/sdb1

    I don't have an external DVD reader, I will try to get one if nothing else works but that is not really convenient...

     

    I know it will be hard to help me further, but if you have other options I can try, I would really appreciate. Thank you anyway for what you already did.

     

    EDIT: No more result trying to change the touchpad type from “Advanced” to “Basic” as suggested for the Cloudbook 11 on this post http://community.acer.com/t5/Legacy-Laptops-and-Netbooks/Ubuntu-Linux/m-p/406757/highlight/true#M67021

  • JordanBJordanB ACE Posts: 3,670 Pathfinder

    There's quite a few topics over in the Ubuntu forum about how to install Ubuntu on an Acer computer with secure boot enabled on an insyde H2O UEFI. 

    I'm not an Acer employee.
  • leoleoleoleo Member Posts: 4
    @padgett, I let the black screen in this state one night long and nothing happened, waiting doesn't seem to be the right answer :/

    @JordanB, I had a look at over 50 acer topics so far, still no clue. I keep searching...
  • JordanBJordanB ACE Posts: 3,670 Pathfinder

    https://ubuntuforums.org/showthread.php?t=2291335&p=13341757#post13341757

     

    I guess you could try loading secure boot defaults....or deleting secure boot and then loading the secure boot defaults.  Or maybe even try loading the BIOS defaults (F9) and then save/exit (F10).

     

    I'm sorry but I'm out of ideas.  One other thing that I forgot to mention was I disabled Windows fast startup, but that shouldn't be related to your problem.

     

    disfast.PNG

     

     

    I'm not an Acer employee.
  • ManDayManDay Member Posts: 5

    Hello,

     

    I'm also a LInux user and I installed a Gentoo kernel with EFI stub support on a V13. For that I disabled Secure Boot and then later manually added the kernel EFI image and re-enabled it again. I don't know much about GRUB and I'm not sure about this, but I think if GRUB boots, you already passed secure boot, since the GRUB image must have been trusted.

     

    Could you try the following 2 things, please:

     

    1. Disable Secure Boot altogether. On my V13, this is done in the BIOS config under "Boot" > "Secure Boot" [Enabled]
    2. Boot a trustworthy image. I know first-hand how problematic "USB images" can be, and the things you are describing could mean a lot of things, depending on what the bootloader does. I suggest you download an image of the Fedora Live Disk and write it to an USB stick with dd if=./Fedora-Image.iso of=/dev/sd<your USB>.
  • GarMouTGarMouT Member Posts: 6

    Hi,

    Same problem with my new Swift 3 SF314-51-57HZ (bios 1.05)

    I think, i tried everything listed in topics :
    - UEFI or Legacy, Enable or disabled Secure boot, added and booted on efi files or directly to usb ... Linux Mint, Ubuntu, Debian ... Nothing. Try also, different partition scheme with rufus. It always finish to a black screen.

    JordanB, could you or someone else please confirm you success installing linux on this specific model : SF314-51 model, it will give me hope. If you did it, please give me your bios version.
     
    Thanks.

     

  • JordanBJordanB ACE Posts: 3,670 Pathfinder

    I don't have a swift.  

     

    I think you should call Acer support.  

     

    I was able to get Ubuntu installed after reading and following eelcoherder's post.  If it doesn't work for you, then I'm completely out of ideas.  It's possible that Acer may need to update BIOS for your model. Not sure.  

     

    I got the black screen too until I read eelcoherder's post.  

    I'm not an Acer employee.
  • JordanBJordanB ACE Posts: 3,670 Pathfinder

    Eelcoherder's post.

     

    (Personally, I didn't use F6 because I had Windows/Ubuntu dual boot. Windows boots by default. I enabled the F12 boot menu in the UEFI) So for me, it was just a matter of setting a supervisor password and then adding Grub to trusted secure boot settings.i

     

    eelcoh.PNG

    I'm not an Acer employee.
  • GarMouTGarMouT Member Posts: 6
    I did that, set a supervisor password, added the efi file to trusted secure boot with a name, get it to the top and booted on it automatically or with F12. Always got the black screen after grub menu.

    I also tried with a usb dvd drive instead of a usb key, same problem. I also try to boot with my usb key to another laptop, it works well, of course.

    Never seen that before.

    Thanks for you help.
  • JordanBJordanB ACE Posts: 3,670 Pathfinder

    Ok.  If you figure it out, please post.  I don't know why it won't work.  The only thing that I would know to do is call Acer.

    I'm not an Acer employee.
  • JordanBJordanB ACE Posts: 3,670 Pathfinder

    I did think of one other thing to try.  

     

    Try installing 64 bit Ubuntu 14.04.5 LTS desktop first.  

    I'm not an Acer employee.
  • GarMouTGarMouT Member Posts: 6

    Unfortunately, not better with 64 bit Ubuntu 14.04.5 LTS.

     

    I really think it's a bios problem like on this case :

    http://community.acer.com/t5/Linux/Ubuntu-on-E5-573G-71L9-black-screen-after-menu-on-Live-USB/td-p/405318

     

    I think Acer need to fix the bios on this product but how long it will take.

     

    Anyway, I know Linux is not officialy supported but it looks like strange that Acer never tried to boot just one time with a linux usb key on this product. So i'm still waiting for someone who success.

  • leoleoleoleo Member Posts: 4
    Hey GarMouT, it's a pleasure to see I'm not alone ^^

    So far I didn't get it done, and I'm now convinced I tried everything we listed above without success.
    I have two options though:
    - I successfully installed vmware workstation 12 on my Windows and I can lauch ubuntu on a virtual machine. It's not as good as dual-boot but enough for me for the moment.
    - A friend told me about Network Booting (booting via ethernet), I will try it in two days.

    I keep you up to date
  • sherwaniusmansherwaniusman Member Posts: 2

    Try installing debian

  • padgettpadgett ACE Posts: 4,036 Pathfinder

    BIOS in my devices is just bought by ACER fron INSYTE and current Windows systems must meet the UEFI specifications. If GRUB is appearing then control has transferred to it and there is a different issue.

     

    I suspect there is a configuration issue and my thought would be the last screen that appears.

  • GarMouTGarMouT Member Posts: 6

     

    Hope :

    https://www.instagram.com/p/BMeGjelDHta/

     

    Maybe with a SDCard ?

     

     

  • GarMouTGarMouT Member Posts: 6

    Hi,

     

    Just to let you know that I find a way to boot on Linux Mint 18 live usb (should probably work for ubuntu too).

     

    Choose "legacy" mode in bios and add "acpi=off" to the grub command line, between "quiet splash" and "--"

     

    No mouse and no network then but it's a start.

Sign In or Register to comment.

Who's Online1.3K

Abhisek
Abhisek
afroshxt
afroshxt
alphatdm
alphatdm
AnjoSs
AnjoSs
batmalin
batmalin
BillMiner1
BillMiner1
DarkHoax121
DarkHoax121
Dchat
Dchat
Dmann54
Dmann54
dnmuniz
dnmuniz
DOLLOR
DOLLOR
egydiocoelho
egydiocoelho
GrootMV
GrootMV
IVAN_PC
IVAN_PC
khayargoli
khayargoli
Leohart03
Leohart03
lilAE
lilAE
LucasSalvi
LucasSalvi
MaClane
MaClane
MartínCastillo
MartínCastillo
ODubhGhaill
ODubhGhaill
pkw
pkw
RAndradee
RAndradee
Spadeus
Spadeus
strader
strader
TigriPanGarfio
TigriPanGarfio
Uvelcc
Uvelcc
xapim
xapim
+1.3K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We want to recognize GAMING6698's dedicated efforts in the Acer Community. GAMING6698 has become one of the main collaborators since joining the Community in November of 2019.
On behalf of all our users and the Acer Team, we thank you for your dedication!

Total Posts and Comments: 3315

Total Points:5742

Total Accepted Answers: 289

GAMING6698 Mainframe Wrangler