Examples: Monday, today, last week, Mar 26, 3/26/04

Aspire One 10 S1002 Platform Drivers will not install correctly after WIN10 update.

dxnrepdxnrep Member Posts: 7 New User

After the anniversary update to W10 I lost the touchscreen functionality to my S1002.  I attempted to reinstall drivers contained in the Platform Driver download package and the update returns an error message, killing the process.  I disabled the windows driver certificate requirement, reloaded, and still got the same result.  Any solutions would be appreciated!

FAQ & Answers

  • padgettpadgett ACE Posts: 4,017 Pathfinder

    Is the error "unsupported OS" ? If so you may need to use compatibility more.

  • dxnrepdxnrep Member Posts: 7 New User

    I ran compatibility mode as administrator, etc.   No luck.   Here is the error screen:

     

    Error Message.PNG

     

    I rolled back the W10 to the version previous to the anniversary edition and still did not have any luck.  The problem is that all of the drivers currently in use are generic.  The system does not reconize any sound device nor does it recognize the touch screen capabilities.   Thanks in advance for your help!

  • padgettpadgett ACE Posts: 4,017 Pathfinder

    Is there anything meaningful in the log file ?

     

    Am at a disadvantaqge becuse the only recent device I have with a trackpad is an R11 (R3-131T). It has an ELAN unit and is working just fine with Anniversary. It is using a Microsoft driver.

  • dxnrepdxnrep Member Posts: 7 New User

    Looks like this may be the culprit:

     

    E File path not found. Please check the configuration file for the INF driver file : IntelBatteryManagement.inf - error code : 4294967295

     

    This triggered the rollback and exit from setup.

  • Acer-JoseAcer-Jose Administrator Posts: 1,063 Community Administrator

    Can you please share the Windows build on your S1002?  Press the Windows key Start+ I > System > About > OS Build.

  • meemee Member Posts: 1

    ( 14393.447 ) windows build

    Please help me, the touch screen do not work, audio, display too.

  • dxnrepdxnrep Member Posts: 7 New User

    Thanks for the response!   Since I posted last I have been able to reset the system.  I reinstalled W10 multiple times before the system finally identified some missing system drivers, which I started installing manually.  The platform driver package on the Acer site for this model contains the correct drivers.  The problem was that the installer locked up every time.   So I unzipped the drivers to a USB drive and went to the device manager to select and install.

    I am not sure why W10 did not identify unrecognized componants originally.

     

    Hope that helps those of you having the same issue.  

  • walidwalid Member Posts: 13

    me too i have same and audio go alone plz help

  • kram77kram77 Member Posts: 1

    well i've found a solution try this one it should work probably 

    first dxdiag your pc then dl all drivers at acer support

    second if the first step does not work

    go to device manager and manually update all drivers..

    it works like a charm thanks microsoft ... 

    more power Godbless you guys!!............. Smiley Happy

Sign In or Register to comment.

Who's Online in this Category0

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos