Examples: Monday, today, last week, Mar 26, 3/26/04

Touchpad not working on aspire E5-551G-T018 on windows 10 (not a simple problem)

Hi everyone, I will bug your head a little with this touchpad problem

 

4days ago my touchpad stopped working! Just like that. 

First I wanted to go in device manager and check for driver updates and etc but touchpad was not listed among the pointing devices, only my usb mouse was listed. After I would remove my usb mouse the entire tab for pointing devices would vanish. My touchpad just dissapeared. 

 

In windows 10 settings, under mouse and touchpad controls there were no touchpad options either. 

 

After googleing I found out that my lapy uses synaptic touchpad drivers. I tried instaling them and found them on two sources. One source had just 640kb for driver, I tried that one but it said that it was already installed. Then I found synaptic driver from the synaptic website and that one had 300mb drivers, that one installed but did nothing. Toucpad was stll not working.

 

Anyway before all this happened like a week before I was planning on buying a new SSD and installing win10 all over again. So after failing to fix touchpad I decided that it was time to do what I wanted for quite some time.

 

I went and bought brand new Patriot Blast 240GB SSD and replaced my old HDD. I booted my win10 os from DVD and started installation.

 

Hoping that whatever driver problem with my touchpad was would be fixed by removing the entire HDD along with the OS and installing everything new from the start.

 

But....

 

After win10 DVD loaded and instalation started. On the first windows instalation screen you get to choose the langunage, time zone and etc. 

 

THERE WAS NO POINTER! Touchpad was not working, again!

 

I inserted my usb mouse and lucky me pointer appeared immediatly! 

 

And after windows instalation, touchpad is still not working, in device manager there is no touchpad. But in windows 10 touchpad and mouse settings there is. In these win10 settings I can see touchpad and it is turned on.

 

Any ideas how to fix this? Is this software issue or did my touchpad die? Smiley Sad 

 

Btw, pardon my bad english it is not my native languange

FAQ & Answers

  • Can you tell us which touchpad is installed in your laptop? Whether Elantech or Synaptics, what's showing up in Device Manager, have you downloaded the appropriate drivers from acer support and installed?

    http://www.acer.com/ac/en/GB/content/drivers

     

  • Dusan_VDusan_V Posts: 8Member

    Untitled.png

     

    Yes I tried downloading official synaptics driver from acer drivers. It says installed, but nothing works.

     

    Untitled.png

    This is what it looks like in device manager. There is no touchpad as a device. My usb mouse is shown twice and I dont know why.

     

    Untitled.png

    And in windows 10 settings there is touchpad, it is turned on as you can see but it doesnt work..

     

    I dont know what to do anymore Smiley Sad

  • Dusan_VDusan_V Posts: 8Member

    Quick update:

     

    There is no touchpad option in bios Smiley Sad Smiley Sad Smiley Sad 

  • domspiderdomspider Posts: 1Member

    Hello,

     

    I have the same problem, did you fix it?!!

Sign In or Register to comment.

Who's Online114

Acer-Laura
Acer-Laura
MrGrudev
MrGrudev
ven98
ven98
xksiadz24
xksiadz24
+110 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Acer Community is now available in French! We are delighted to announce the addition of French to the list of supported languages in order to reach more users and expand on our mission to break the barriers between people and technology. You can access the French community from the drop down language menu located next to your username on the top right corner.


Participez aux discussions !

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.