Examples: Monday, today, last week, Mar 26, 3/26/04

Can an Aspire One power up without battery?

twalptwalp Posts: 4Member
edited January 2018 in Legacy Laptops and Netbooks

A friend asked me to look into why his Aspire One (P1VE6, 722-0879) doesn't power up. The transformer is putting out 19v so I assume it's okay. But with the transformer plugged into the netbook there's not a flicker of life after pressing the power button, regardless of whether the battery is installed or absent.  One possibility is that the battery is dead, and a battery must be present for the netbook to power up. Can anyone confirm if a working battery must be present for an Aspire One to power up?  Thanks.

FAQ & Answers

  • padgettpadgett Posts: 3,923ACE Pathfinder

    I have run a lot of Note/Netbooks/Laptops with the battery removed and just the power supply. I would suggest using a UPS to avoid a sudden shutdown if the mains power glitches.

  • twalptwalp Posts: 4Member

    Thank you for replying, padgett. I cannot recall a laptop that hasn't worked -- sans battery -- with its AC power transformer, but I wanted to verify that this particular model has that same capability.

     

    Since it won't power up using the transformer, with or without the battery attached, that would mean it's totally dead and not worth keeping. Hate to waste a cute little netbook!

  • padgettpadgett Posts: 3,923ACE Pathfinder

    My W3 had a bad battery and would not boot. But if I left the power connected for about 20 minutes "something" happened and the orange light came on. Then it would boot. Have since replaced the battery and now all is good.

  • RGodRGod Posts: 2Member New User
    Hi twalp,

    I'm really interested to know how things worked out for you.

    I've got an Aspire One 533 from way back when (2011, I think).

    I remember switching it on successfully maybe a year ago.

    I've tried to switch it on recently. No signs of life!

    Like you, I want to know if it is normally possible for the Acer Aspire One to run off the mains without the battery connected. I've tried this and there's still no signs of life from the machine. I'm trying to diagnose if the battery is the problem, as I think you were when you wrote your message.

    If anyone can pitch in with info on the Acer Aspire One, it will also be appreciated.

    Thanks!
  • padgettpadgett Posts: 3,923ACE Pathfinder

    Sure. I have a 532 that runs just fine without the battery.

  • RGodRGod Posts: 2Member New User
    Padgett,

    Thanks for the reply!

    I ended up buying a new battery, slotted it in and tried to switch the machine on.
    Unfortunately, the machine is still a brick!

    (Thanks for your reply, if I'd seen it earlier I wouldn't have bought the battery... But hey ho, it didn't cost too much.)

    I want to get the data off the machine and would ideally like to resell it as a working item.

    Any tips on what to do next?
    Is it likely to be a motherboard problem?

    Thanks
  • henmanhenman Posts: 24Member Troubleshooter
    A very late reply to this thread but I also have an AO533 and it works fine on the AC adaptor or transformer without the battery. I started running it without the battery because it was recommended to remove the battery if always being run on the AC adapter. Better for the battery if it is fully charged and doesn't need to be left on the transformer. I leave it on the transformer because the battery is a 3 cell and never had a long life. 
  • SavageBeastSavageBeast Posts: 1Member New User
    I've recently had a parallel experience with a P1VE6 model Aspire One Notebook and had to hold down the start/power on button for a long time before the computer would start up, and it would take longer over time to do so until it failed entirely to start up.  I took the notebook to a local computer technician, who determined that the battery had lost almost all of its charge and charging ability.  He removed the battery, and I can now power on the computer with the battery removed (and it does so without the orange light coming on), though I need to hold down the power-on key for a fairly long time. 

    I also was in the habit of using the notebook almost continuously relying only on the transformer electrical source.

    I am now searching for a new replacement battery.
Sign In or Register to comment.

Who's Online84

AumShanti
AumShanti
Cyriix
Cyriix
deadlyghost
deadlyghost
egydiocoelho
egydiocoelho
Karthi
Karthi
Klara
Klara
Kno63
Kno63
marjhing2016
marjhing2016
+76 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Acer Community is now available in French! We are delighted to announce the addition of French to the list of supported languages in order to reach more users and expand on our mission to break the barriers between people and technology. You can access the French community from the drop down language menu located next to your username on the top right corner.


Participez aux discussions !

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.