Examples: Monday, today, last week, Mar 26, 3/26/04

Touchpad stopped working after updating Bios to version 1.10 for Acer Aspire R5-471T-71W2

Hi Acer,

 

Today I saw a driver update through acer center app so I also checked Bios update if any on acer US download website. I was previously on Bios V 1.09 "Fixes PXE ROM Issues" and then updated to V 1.10 "Supports Elan Touchpad" which was released two days ago.

 

Now, after this bios update, my touchpad has stopped working completely. Please fixx this asap and let me know the resolution. I am using Acer Aspire R14 (R5-471T-71W2) model

 

Thanks

Nilay

 

FAQ & Answers

  • hellcat652003hellcat652003 Posts: 4Member

    Did you resovle touchpad problem? I was thinking of upgrading from 1.09 on my R5 471T but after reading your posting I decided to wait.

  • mit2nilmit2nil Posts: 8Member

    Yes problem was resolved automatically after few bootups. Probably it was some kind of glitch or so. 

  • hellcat652003hellcat652003 Posts: 4Member

    Did rev 1.10 bios give you more adjustment to the touchpad & mouse?

    I got the sensitivity adjusted better with the 1.09 bios. I first turned off the enhanced touchpad setting in the bios which helped with sensitivity but found the mouse would not come on from touchscreen mode. So I put it back to the enhanced setting and adjusted the mouse sensitivity with what was available. I got it adjusted so it was useable. This touchpad required some getting used to (newbee) with this laptop.

  • mit2nilmit2nil Posts: 8Member

    Well I was just frustrated by touchpad not working so I was just happy that it started working and didn't care about any enhancement that it might have added. 

  • IgnuanaRexIgnuanaRex Posts: 7Member

    I had this same problem.    This BIOS update is deeply flawed and needs to be removed and redone.    I can only imagine that more people haven't had this problem because they don't bother to go look for Acer updates online since there are basically none available.

     

    I tried many solutions and am a tech professional.   Ultimately a windows restore and reinstalling my touchpad driver fixed it.    It was a really ugly experience and turned me off from acer.   You should see screenshots of the broken English in BIOS.   I don't have the energy to take and post them.

  • ProfQuillProfQuill Posts: 5Member

    Tinkerer

    This is a rather old thread but thought I'd reply to provide a possible solution to this issue for those who might search (like I did).

     

    I've had my R5-471T for about 2 months, which has been just fine (other than it's not hardly the best keyboard ever made), and to tempt fate I too decided to update BIOS to v1.10.  Went OK, or so I thought, later that day saw that the touchpad was not working at all.  I don't use it all that much (I'm a mouse kind of guy), so didn't immediately relate that to the BIOS update. 

     

    I checked Device Manager and the touchpad was marked with a ! error saying something about the device wouldn't start (not real sure didn't write it down).  Tried all the usual things like disabling, uninstalling, scanning for changes, rebooting, power cycle, nothing helped, still showed an error and wouldn't work. Hard to believe the thing just up and broke.

     

    I got into the BIOS and saw the touchpad was set to 'advanced' with the note that the I2C driver must be installed with that setting (yeah, don't know what that is either, looked it up and it means Inter-Integrated Circuit, oh that helps).  Set it to BASIC, but after the boot, same result, did not work.

     

    Went into driver update for the touchpad, specifying Browse my computer, Let me pick, I saw the I2C HID device, selected that. 

     

    The touchpad immediately began working!  Yippee! Next, got back into the BIOS and set touchpad back to Advanced, after that boot, touchpad kept working.  I'm not sure I noticed any difference between the way it worked before the BIOS update, nor with Basic or Advanced, but I'm so happy it works now even if I don't use it a lot.

     

    One thing that's now different in Device Manager, the touchpad no longer appears under Mice and other pointing devices but is under Human Interface Devices as HID-compliant touch pad, and 2 I2C HID Devices; not sure if I should be messing with other drivers, but it's back to working and I'll choose not to mess with it further for now.

     

    So yeah, maybe with BIOS updates the better advice is "if it ain't broke, don't fix it", but sometimes I can't resist.  Now if this is a common or expected result of this update, it certainly behooves Acer to document this seeming requirement, or maybe they don't know either.  

     

    If I had just one request of Acer for what would probably be a BIOS issue would be to make the keyboard backlight function better, like don't forget the setting upon sleeping, and make the timeout longer.  I'd love to configure that but assume it's pretty well hard-coded.

  • aQaQ Posts: 1Member

    Created an account just to thank you. I did what you said and my touchpad is working now. Its really weird I know but you saved me a lot of time and hassle.

    Cheers!

  • ProfQuillProfQuill Posts: 5Member

    Tinkerer

    First of all aQ, wanted to acknowledge your success and thanks.  

     

    The main purpose of this post is to alert anyone still reading or coming across this issue of another bit of a problem.  I JUST updated to the lastest Windows 10 release, 1703, the 'Creators update', which isn't quite being rolled out yet but can be obtained from MS right now.  I've just updated (always a glutton for punishment but had been playing with the Insider Preview in a VM so was OK with it) -- so far so good, but my touchpad broke again, the same as decscribed in this thread.

     

    Solution is the same and very simple, get into Device Manager, notice that the touchpad is showing an error, ask it to update driver selecting the I2C HID device, one quick click later the error goes away and the touchpad resumes functionality.

     

    Note that in this instance that's it, no need (if there ever was) to get into the BIOS.

     

    So what's going on here, despite any issues with the Acer BIOS, Windows just isn't setting up the device properly by default.

     

     

Sign In or Register to comment.

Who's Online171

Brambledeen
Brambledeen
egydiocoelho
egydiocoelho
himizu
himizu
IVAN_PC
IVAN_PC
Melchizedek
Melchizedek
paulojuniore98
paulojuniore98
StevenGen
StevenGen
Telephonedialer
Telephonedialer
+163 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.