Predator G9-591 - Diagonal screen tear

BruceLeroyJones Member Posts: 5
edited March 29 in 2016 Archives

I'm getting diagonal screen tearing when playing.  So far, it's happened in DOOM, and Wolfenstein: The Old Blood.  


Nivdia driver is 368.39


The problem seems very similar to that described in this post:


You'll find links to various other posts, with what appears to be very similar problems as well.


Has anyone else run into this?  


I've played with vsync and a few resolutions, nothing has worked so far.  


This is VERY frustrating Smiley Sad  Because otherwise, I love this machine.


  • BruceLeroyJones
    BruceLeroyJones Member Posts: 5

    An update - 


    I rolled my driver back to 350.0 (which is the driver available for download from Acer for my machine).  Interestingly, on my first playthrough after installing the older driver, I didn't have the diagonal line.  However, when I started DOOM a second time, it was back.


    Smiley Sad


    Next day -
    Done some more research.  


    Updated Nvidia back to latest (368.39)


    For anyone with the same problem (and if you also have this problem please add a post!), I've had some success by running MSI Afterburner, and frame limiting to 50 fps.  I'm then able to run DOOM at HIGH settings without the diagonal line.


    I've not tested on Wolfenstein yet.  I won't update this again unless the fix doesn't work anywhere else.


    I do believe this to be an nvidia problem with their mobile GPU's, but so far they don't seem to have done anything, nor even acknowledged it.


    If anyone else is having this problem, perhaps Acer should lean on them...

  • beststevie
    beststevie ACE Posts: 506 Pioneer

    I have the same issue with the Doom Demo. With no other game.


    So I don't think it's a Nvidia driver problem. Maybe there are other games with that issue?



  • BruceLeroyJones
    BruceLeroyJones Member Posts: 5

    it happened to me in the Wolfenstein games as well...


    I'm working on downloading Fallout 4 and maybe Dishonored.  I'll turn off my 3rd party frame limiting and see how they behave.


  • AJ-KW
    AJ-KW Member Posts: 68

    I've had this issue before, with Quantum Break and other games, the best possible fix is:


    go to nvidia settings and switch your V-Sync to Adaptive,


    If this does not work, lowering your in game Graphics Quality can be a fix as well...


    Hope this helps!



  • BruceLeroyJones
    BruceLeroyJones Member Posts: 5

    Thanks for the advice man!


    One thing - I don't see Adaptive as an option for vsync, only 'ON' or 'Off', or 'Use 3d application settings'.


    Are you using the GTX 980m with 368.3 drivers also, and am I missing an advanced option somewhere??



  • AJ-KW
    AJ-KW Member Posts: 68

    I am running 970m on my predator 15, and 980m on my predator 17, driver ver 368.39

    GeForce Experience 2.11.4


    I just checked, i am surprised there is no adaptive anymore, only on and off,

    check your triple buffering settings, mine is off maybe this one will reduce tearing if enabled..


    i don't get diagonal screen tearing on all games, like yesterday i was playing Killer Instinct and Gears of War

    but it happens on some games like Quantum Break or Tomb Rider due to its settings, but reducing graphics

    always helps reducing the tearing, because if your laptop is packing so much power, its really normal to get

    diagonal tearing on max settings, i wish if the laptop screen supported the G-SYNC, but if you don't find any

    solution, using an external G-SYNC monitor would be your last option...

  • beststevie
    beststevie ACE Posts: 506 Pioneer

    the solution for Doom is, to go to the graphics settings in Doom and adjust the vsync setting from adpative to off. Tearings are dissapearing completly.


    Could you set this as solution if it works for you, too?

  • BruceLeroyJones
    BruceLeroyJones Member Posts: 5

    Thanks for the reply.


    This works for me, but only half the time.  It's really odd. Like, if I run Doom right after booting, I may not see the diagonal line, but one I a) load another level or b) quit the game and restart it w/o rebooting the laptop, the line will be back.


    Also, Minecraft is another title where I'm seeing the line, though it's only noticable on certain textures.

  • ChevyCam94
    ChevyCam94 Member Posts: 178 Skilled Fixer
    I had that with Fallout 4. I turned V-sync "ON", and enabled triple buffering. That solved my issue. On the most recent driver. Play around with the settings in the NVIDIA control panel.

    My install of Metal Gear Sold Revengence had tearing too, but with V-sync and buffering, its flawless.
  • rov63rus
    rov63rus Member Posts: 2 New User

    I have exact the same problem on G9-592 in Doom4, Fallout 4 and some others


    Playing with v-sync option reducing/resolving this problem.


    May be some ingineer from Acer Team explain what is it ?

  • rov63rus
    rov63rus Member Posts: 2 New User

    I've just installed latest win10 update + clean nvidia 387.92 driver install.


    Now Doom is played without tearing!