Examples: Monday, today, last week, Mar 26, 3/26/04

Identify touchpad on Aspire 5742G? Elantech or Synaptics?

mrpetemrpete Posts: 32Member
I have an Acer Aspire 5742G with a mobile i5 CPU. The exact Aspire laptop model is below. It was bought in France. I believe that an alias or some other terminology for this model is PEW71.

5742G-486G75Mnkk

The driver page for this model lists both Synaptics and ELANTECH as possible touchpad devices.

How can I figure out which touchpad it has?

I used the Acer program HWVendorDetection.exe that was mentioned in another thread on this board, but the list of devices return is very short and is ...

LAN
VGA
VGA_2
Wireless LAN

http://global-download.acer.com/FilesDownload/HWID/HWVendorDetection.exe

When I run System Info for Windows SIW I get ...

Property........Value

Mouse

Device ID.......ACPI\PNP0F13\4&2B0DBF63&0
Status..........0x0180000a Started
Problem.........0x00000000 (0)
Service.........i8042prt
Capabilities....0x00000020
Config Flags....0x00000400
Hardware IDs....ACPI\PNP0F13
Hardware IDs....*PNP0F13
Class GUID......{4D36E96F-E325-11CE-BFC1-08002BE10318}
Enumerator name.ACPI
Phys Obj Name...\Device\00000034
Install State...0x00000003

It appears from searching around that PNP0F13 is a generic identifier for a mouse device.

It appears that the touchpad is hooked into the laptop mainboard via a PS2 interface.

Thank You!

FAQ & Answers

  • laurent_14laurent_14 Posts: 6,663ACE Pathfinder

    Hello,

     

    You can identify the device like this (read the tutorial).

  • mrpetemrpete Posts: 32Member

    Hi Laurent, thanks for the reply. I also thank you because you have helped me in the past.

     

    I did most of the device identification in my first post.  The key number is PNP0F13 which is a rather generic (but not totally generic) number for a mouse or pointing device.

     

    When I go through the list of characteristics in Device Mgr (like your link suggested) the device manufacturer is given as Microsoft! Of course that's wrong.

     

    After trying all of the device drivers listed below I'm rather sure that my touchpad was made by Synaptics. However, installing Synaptics device drivers does not help me with my problem, which is that I REALLY want to turn off tap-to-click, but there is no way as the drivers below offer me pretty close to zero "custom options."

     

    Drivers I've tried in Windows 10:

    Synaptics Win7 driver from acer.com (installed in Win7 compatibility mode)

    ELANTECH Win7 driver from acer.com (installed in Win7 compatibility mode)

    Synaptics Win10 driver from synaptics.com - this is the "latest & greatest"

     

    One of the two Synaptics drivers offered a meager one or two very small additional options. I think that one of those two Synaptics driver downloads offered two variations if you did them manually ("have disk") ... like PS/2 and SM bus ... or something like that. Each time I rolled back or uninstalled, etc.

     

    I opted to go back to the generic Microsoft driver which I'm 100% sure will consistantly work properly in Win10. I'm sure it won't fall on its face, but it lacks the fine features I'm looking for.

     

    Oh well ...

Sign In or Register to comment.

Who's Online172

Acer-David
Acer-David
AkbSantos
AkbSantos
Felipe1994
Felipe1994
KevinPozos
KevinPozos
rajchhetri25
rajchhetri25
risingblaze1
risingblaze1
sirhenry22
sirhenry22
Woodywon
Woodywon
+164 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.