Examples: Monday, today, last week, Mar 26, 3/26/04

Upgraded Travelmate B115-M to Windows 10, touchpad not working

VegardHaVegardHa Posts: 2Member
edited November 2017 in Travelmate and Extensa
Hello everyone,

Yesterday I updated my Travelmate 115M from Windows 8 to Windows 10. Now my touchpad is not working, I can't even see the arrow on the screen. I've been following and reading tons of guides and forums, but nothing has worked. I have installed the ELAN driver from the Aver support page, but I get the error code (10) when trying to update or enable the driver. I'm now writing from my smartphone and won't even list all the things I've tried.

Anyone had the same issue? Any help would be appreciated.

Thanks!

FAQ & Answers

  • philetusphiletus Posts: 4,428ACE Pathfinder

    The problem is, when Windows 10 installed, it installed the touchpad driver it wanted regardless if it was correct.

    When you try to update the driver, Win 10 ignores it and reinstalls it's favorite driver. 

    Try doing the steps here. You're probably going to need a usb mouse if you can't see the cursor.

    http://community.acer.com/t5/E-and-M-Series-Laptops/Acer-Aspire-E1-571-Touchpad-Scroll-Not-Working-After-Windows-10/m-p/376098#U376098

    If you get Win 10's driver stopped, you can try the roll back, but if not, install the Win 8.1 driver.

  • VegardHaVegardHa Posts: 2Member

    Thanks a lot for the reply. But this doesn't work either. When I entered the Device Manager the first time after installing Windows 10 the 'Mice and other pointing devices' wasn't even showing in the list. It wasn't until I downloaded the drivers from the Acer website and tried to enable the 'Unknown device' that appeared right after installation that the 'Mice and other pointing devices' became visible. So it is not possible to do a roll back. 

    I have downloaded the Synaptics driver and I get the option of enabling drivers called Synaptics PS/2 Port Touchpad, Synaptics SMBus Touchpad, and Synaptics SMBus Forcepad. I also have ELAN on the list and can enable ELAN I2C Filter Driver. I downloaded all the touchpad drivers for Windows 10 and Windows 8.1, and none of them work. Usually I get this message:

     

    "This device cannot start. (Code 10)

    Insufficient system resources exist to complete the API."

    So I have no idea what to do...

  • philetusphiletus Posts: 4,428ACE Pathfinder

    You either have Symantic or Elan. You can't use both drivers.

    This may or may not work. Uninstall the touchpad in Programs and features. Check that you don't have both drivers installed. Reboot and disconnect from the net. Go to the touchpad driver and see if Win 10 loaded one. Right click, select uninstall and check delete software. Reboot and check again. Keep doing that until there is no driver.

    Then install the 8.1 driver. 

    If it works, Win 10 will reinstall it's driver the first time you reboot.

  • sundeep471sundeep471 Posts: 1Member New User
    The problem is due to serial IO(I2C and GPIO) driver not correctly installed.
    Download the intel IO driver(Serial IO Driver) as mentioned in acer's site

    When you launch it, it would ask you to either uninstall OR repair the driver.
    Select Uninstall and then let it complete.
    Now Pick the same driver again and install it this time, and let the process be complete.

    Now, Reboot the system, and check if the touchpad works
    If touchpad worked after above serial IO driver re-installation, Good.

    If it doesn't work even after re-installation of serial IO Driver, then it means that the very touchpad driver is missing.
    you would need to download the respective(Elan or synaptic) driver from acer's site and install it.
    Then reboot the system to have the newly installed driver in effect.

    NOTE: Having both ELAN and synaptic drivers doesn't actually hamper touchpad working on your system. They just co-exist.
    Which ever Hardware device is found during system startup, will be used and appropriate driver would be invoked.
    Atleast, that is how folks write drivers.
  • APPLES123APPLES123 Posts: 2Member New User
    How do I update my windows travel mate b115 8.1 to windows 10?
  • MikeComputernetMikeComputernet Posts: 17Member Troubleshooter
    copy your files to an external hard drive , do a fresh installation of windows 10 , down all the required drivers from the Acer website , specifically under your laptop model name or serial number confirmed.you are good to solve the problem.
Sign In or Register to comment.

Who's Online195

Atefovic
Atefovic
BearVadar
BearVadar
gamingnoob29
gamingnoob29
gshaw
gshaw
IVAN_PC
IVAN_PC
Josealves
Josealves
karan316
karan316
Kno63
Kno63
maciek75575
maciek75575
marius21kns
marius21kns
MechDragon
MechDragon
shikebful
shikebful
ven98
ven98
+182 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Acer Community is now available in French! We are delighted to announce the addition of French to the list of supported languages in order to reach more users and expand on our mission to break the barriers between people and technology. You can access the French community from the drop down language menu located next to your username on the top right corner.


Participez aux discussions !

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.